Bug 112960 - Crash when RMB clicking on file [backtrace]
Summary: Crash when RMB clicking on file [backtrace]
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Unclassified
Component: file icon view (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 133560 137173 138101 140991 141384 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-09-20 20:34 UTC by Dik Takken
Modified: 2008-08-22 11:45 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dik Takken 2005-09-20 20:34:09 UTC
Version:            (using KDE KDE 3.4.1)
Installed from:    Gentoo Packages
OS:                Linux

I was managing some files, right-clicked on a file and Konqueror crashed before it could even display the RMB menu.

Full debug backtrace:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 11086)]
[KCrash handler]
#5  0x46778e88 in QPixmap::convertToImage() const ()
   from /usr/qt/3/lib/libqt-mt.so.3
#6  0xb75bc004 in KWin::setIcons(unsigned long, QPixmap const&, QPixmap const&)
    (win=0, icon=@0xbfd0e5d8, miniIcon=@0xbfd0e660) at kwin.cpp:505
#7  0xb78a9745 in KMainWindow::setIcon(QPixmap const&) (this=0x824d788, 
    p=@0xbfd0e750) at kmainwindow.cpp:1217
#8  0xb7ed78ac in KonqMainWindow::setIcon(QPixmap const&) (this=0x824d788, 
    pix=@0xbfd0e750) at konq_mainwindow.cc:5163
#9  0xb7ecb190 in KonqMainWindow::setLocationBarURL(QString const&) (
    this=0x824d788, url=@0x841075c) at konq_mainwindow.cc:3559
#10 0xb7e93671 in KonqView::setLocationBarURL(QString const&) (this=0x8410730, 
    locationBarURL=@0x8) at konq_view.cc:631
#11 0xb7e9c94f in KonqViewManager::setActivePart(KParts::Part*, bool) (
    this=0x82579e0, part=0x0, immediate=true) at konq_viewmgr.cc:1357
#12 0xb7e9a660 in KonqViewManager::clear() (this=0x82579e0)
    at konq_viewmgr.cc:917
#13 0xb7eda30e in KonqMainWindow::stayPreloaded() (this=0x824d788)
    at konq_mainwindow.cc:5641
#14 0xb7ed786c in KonqMainWindow::queryExit() (this=0x8)
    at konq_mainwindow.cc:5158
#15 0xb78a8ff7 in KMainWindow::shuttingDown() (this=0x0)
    at kmainwindow.cpp:1090
#16 0xb78a9b5a in KMainWindow::qt_invoke(int, QUObject*) (this=0x824d788, 
    _id=71, _o=0xbfd0eb90) at kmainwindow.moc:139
#17 0xb7e05b06 in KParts::MainWindow::qt_invoke(int, QUObject*) (
    this=0x824d788, _id=71, _o=0xbfd0eb90) at mainwindow.moc:98
#18 0xb7edbfff in KonqMainWindow::qt_invoke(int, QUObject*) (this=0x824d788, 
    _id=71, _o=0xbfd0eb90) at konq_mainwindow.moc:716
#19 0x46820a93 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/qt/3/lib/libqt-mt.so.3
#20 0x468208d4 in QObject::activate_signal(int) ()
   from /usr/qt/3/lib/libqt-mt.so.3
#21 0xb7572a23 in KApplication::shutDown() (this=0x8) at kapplication.moc:232
#22 0xb7566208 in KApplication::xioErrhandler(_XDisplay*) (this=0xbfd0fa70, 
    dpy=0x8) at kapplication.cpp:729
#23 0xb75643b8 in kde_xio_errhandler (dpy=0x0) at kapplication.cpp:178
#24 0x460e9a9e in _XIOError () from /usr/lib/libX11.so.6
#25 0x08075c18 in ?? ()
#26 0xb73fca20 in ?? ()
#27 0x46177588 in ?? () from /usr/lib/libX11.so.6
#28 0x460e73b1 in _XRead () from /usr/lib/libX11.so.6
Comment 1 Tommi Tervo 2006-09-04 20:24:39 UTC
*** Bug 133560 has been marked as a duplicate of this bug. ***
Comment 2 Tommi Tervo 2006-11-13 09:25:53 UTC
*** Bug 137173 has been marked as a duplicate of this bug. ***
Comment 3 Tommi Tervo 2006-11-30 09:05:19 UTC
*** Bug 138101 has been marked as a duplicate of this bug. ***
Comment 4 Tommi Tervo 2006-11-30 09:11:16 UTC
*** Bug 124202 has been marked as a duplicate of this bug. ***
Comment 5 Tommi Tervo 2007-02-01 09:25:57 UTC
*** Bug 140991 has been marked as a duplicate of this bug. ***
Comment 6 Tommi Tervo 2007-02-08 08:44:11 UTC
*** Bug 141384 has been marked as a duplicate of this bug. ***
Comment 7 Elias Probst 2007-03-10 21:27:00 UTC
Please fix this bug! It makes my konqueror crash ~10 times a day and slows down effective work extremely because of lost contents in form fields etc.

Are there any other information you could need for resolving this?

Here's another backtrace of such a crash, looks similar to the one above, but maybe it helps you fixing the problem:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1233320272 (LWP 25845)]
[KCrash handler]
#9  0xb6ffb7d1 in QPixmap::convertToImage () from /usr/qt/3/lib/libqt-mt.so.3
#10 0xb70ab9ce in QPixmap::createHeuristicMask ()
   from /usr/qt/3/lib/libqt-mt.so.3
#11 0xb7011d8a in QWidget::setIcon () from /usr/qt/3/lib/libqt-mt.so.3
#12 0xb7a02ec8 in KMainWindow::setIcon (this=0x812e580, p=@0xbf9c2484)
    at kmainwindow.cpp:1227
#13 0xb6538b53 in KonqMainWindow::setIcon (this=0x812e580, pix=@0xbf9c2484)
    at konq_mainwindow.cc:5287
#14 0xb6535589 in KonqMainWindow::setLocationBarURL (this=0x812e580, 
    url=@0x903ad44) at konq_mainwindow.cc:3603
#15 0xb650cd25 in KonqView::setLocationBarURL (this=0x903ad18, 
    locationBarURL=@0xbf9c2528) at konq_view.cc:644
#16 0xb6514b8f in KonqViewManager::setActivePart (this=0x8153a88, part=0x0, 
    immediate=true) at konq_viewmgr.cc:1356
#17 0xb6514cbf in KonqViewManager::clear (this=0x8153a88)
    at konq_viewmgr.cc:917
#18 0xb6552c43 in KonqMainWindow::stayPreloaded (this=0x812e580)
    at konq_mainwindow.cc:5764
#19 0xb6552ff3 in KonqMainWindow::queryExit (this=0x812e580)
    at konq_mainwindow.cc:5282
#20 0xb7a02370 in KMainWindow::shuttingDown (this=0x0) at kmainwindow.cpp:1104
#21 0xb7a06a89 in KMainWindow::qt_invoke (this=0x812e580, _id=71, 
    _o=0xbf9c2758) at kmainwindow.moc:139
#22 0xb7ecf8eb in KParts::MainWindow::qt_invoke (this=0x812e580, _id=71, 
    _o=0xbf9c2758) at mainwindow.moc:98
#23 0xb65586d9 in KonqMainWindow::qt_invoke (this=0x812e580, _id=71, 
    _o=0xbf9c2758) at konq_mainwindow.moc:746
#24 0xb7098f0e in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#25 0xb7099a48 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#26 0xb76b7f3e in KApplication::shutDown (this=0xbf9c323c)
    at kapplication.moc:234
#27 0xb76b8b4b in KApplication::xioErrhandler (this=0xbf9c323c, dpy=0x8090a38)
    at kapplication.cpp:726
#28 0xb76b8b86 in kde_xio_errhandler (dpy=0x8090a38) at kapplication.cpp:179
#29 0xb6b9107b in _XIOError () from /usr/lib/libX11.so.6
#30 0xb6b91056 in _XIOError () from /usr/lib/libX11.so.6
#31 0xb6b91fb4 in _XRead () from /usr/lib/libX11.so.6
#32 0xbf9c27e8 in ?? ()
#33 0xb6994201 in poll () from /lib/libc.so.6
Backtrace stopped: previous frame inner to this frame (corrupt stack?)
Comment 8 Tommi Tervo 2007-03-16 13:59:57 UTC
QT update _may_ help, any volunteers to recompile Qt and KDE?
http://www.trolltech.com/developer/notes/changes/changes-3.3.8
- Fixed a rare crash in QPixmap::convertToImage() when XGetImage() fails.
Comment 9 Elias Probst 2007-06-20 21:16:59 UTC
Since I've updated Qt (to 3.3.8) some months ago this never happened again.
So the solution seems to be an upgrade + recompiling affected applications.

I think this bug can be closed.
Comment 10 Dik Takken 2007-06-20 21:52:11 UTC
I'm still on QT 3.3.6, but the crash never occurred again. But it's a rare crash, so....
Comment 11 maini10 2007-07-12 11:22:51 UTC
Complete backtrace of this crash in Kubuntu (KDE 3.5.6)

Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1231673680 (LWP 4755)]
[KCrash handler]
#6 0xb723c0ac in QPixmap::convertToImage () from /usr/lib/libqt-mt.so.3
#7 0xb78b2f6c in KWin::setIcons (win=56623112, icon=@0xbfea33f4,
    miniIcon=@0xbfea3334)
    at /root/kdelibs/kdelibs-3.5.6/./kdecore/kwin.cpp:507
#8 0xb6d3d09d in KMainWindow::setIcon (this=0x81233d8, p=@0xbfea33f4)
    at /root/kdelibs/kdelibs-3.5.6/./kdeui/kmainwindow.cpp:1231
#9 0xb66e2996 in KonqMainWindow::setIcon ()
   from /usr/lib/libkdeinit_konqueror.so
#10 0xb66d02d8 in KonqMainWindow::setLocationBarURL ()
   from /usr/lib/libkdeinit_konqueror.so
#11 0xb66d0383 in KonqView::setLocationBarURL ()
   from /usr/lib/libkdeinit_konqueror.so
#12 0xb66fd57b in KonqViewManager::setActivePart ()
   from /usr/lib/libkdeinit_konqueror.so
#13 0xb671193f in KonqViewManager::clear ()
   from /usr/lib/libkdeinit_konqueror.so
#14 0xb6711b32 in KonqMainWindow::stayPreloaded ()
   from /usr/lib/libkdeinit_konqueror.so
#15 0xb6711f66 in KonqMainWindow::queryExit ()
   from /usr/lib/libkdeinit_konqueror.so
#16 0xb6d159c0 in KMainWindow::shuttingDown (this=0x2)
    at /root/kdelibs/kdelibs-3.5.6/./kdeui/kmainwindow.cpp:1104
#17 0xb6e74b61 in KMainWindow::qt_invoke (this=0x81233d8, _id=-1233907709,
    _o=0x1) at ./kmainwindow.moc:139
#18 0xb7fbffb3 in KParts::MainWindow::qt_invoke (this=0x81233d8, _id=72,
    _o=0xbfea372c) at ./mainwindow.moc:98
#19 0xb671f453 in KonqMainWindow::qt_invoke ()
   from /usr/lib/libkdeinit_konqueror.so
#20 0xb72f1957 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#21 0xb72f23fc in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#22 0xb789889c in KApplication::shutDown (this=0xbfea5868)
    at ./kapplication.moc:234
#23 0xb789896e in KApplication::xioErrhandler (this=0xbfea5868, dpy=0x80cda80)
    at /root/kdelibs/kdelibs-3.5.6/./kdecore/kapplication.cpp:726
#24 0xb78989c9 in kde_xio_errhandler (dpy=0x80cda80)
    at /root/kdelibs/kdelibs-3.5.6/./kdecore/kapplication.cpp:179
#25 0xb6f5ef4d in _XIOError () from /usr/lib/libX11.so.6
#26 0xb6f5ff06 in _XRead () from /usr/lib/libX11.so.6
#27 0xb6f60924 in _XReply () from /usr/lib/libX11.so.6
#28 0xb6f407b0 in XGetGeometry () from /usr/lib/libX11.so.6
#29 0xb6eea75d in XftDrawPicture () from /usr/lib/libXft.so.2
#30 0xb6eea880 in XftDrawCreateBitmap () from /usr/lib/libXft.so.2
#31 0xb723dae8 in QPixmap::init () from /usr/lib/libqt-mt.so.3
#32 0xb7308bd1 in QPixmap::QPixmap () from /usr/lib/libqt-mt.so.3
#33 0xb7296e3e in QBitmap::QBitmap () from /usr/lib/libqt-mt.so.3
#34 0xb7242625 in QPainter::drawPixmap () from /usr/lib/libqt-mt.so.3
#35 0xb7242dd8 in QPainter::drawPixmap () from /usr/lib/libqt-mt.so.3
#36 0xb724328d in QPainter::drawTiledPixmap () from /usr/lib/libqt-mt.so.3
#37 0xb5fad5f7 in khtml::RenderBox::paintBackgroundExtended (this=0x8a9ca58,
    p=0x8463f48, c=@0x8a5526c, bgLayer=0x8a5524c, clipy=342, cliph=20, _tx=6,
    _ty=342, w=161, h=20, bleft=0, bright=0, pleft=0, pright=0)
    at /root/kdelibs/kdelibs-3.5.6/./khtml/rendering/render_box.cpp:613
#38 0xb5f97dbe in khtml::RenderBox::paintBackground (this=0x8a9ca58,
    p=0x8463f48, c=@0x8a5526c, bgLayer=0x8a5524c, clipy=342, cliph=20, _tx=6,
    _ty=342, w=161, height=20)
    at /root/kdelibs/kdelibs-3.5.6/./khtml/rendering/render_box.cpp:398
#39 0xb5fa2613 in khtml::RenderBox::paintBackgrounds (this=0x8a9ca58,
    p=0x8463f48, c=@0x8a5526c, bgLayer=0x8a5524c, clipy=342, cliph=20, _tx=6,
    _ty=342, w=161, height=20)
    at /root/kdelibs/kdelibs-3.5.6/./khtml/rendering/render_box.cpp:392
#40 0xb5fcad60 in khtml::RenderBox::paintBoxDecorations (this=0x8a9ca58,
    paintInfo=@0xbfea4280, _tx=6, _ty=342)
    at /root/kdelibs/kdelibs-3.5.6/./khtml/rendering/render_box.cpp:381
#41 0xb5fda0ce in khtml::RenderBlock::paintObject (this=0x8a9ca58,
    pI=@0xbfea4280, _tx=6, _ty=342, shouldPaintOutline=true)
    at /root/kdelibs/kdelibs-3.5.6/./khtml/rendering/render_block.cpp:1627
#42 0xb5fda39d in khtml::RenderBlock::paint (this=0x8a9ca58, pI=@0xbfea4280,
    _tx=6, _ty=342)
    at /root/kdelibs/kdelibs-3.5.6/./khtml/rendering/render_block.cpp:1611
#43 0xb5fd9ff4 in khtml::RenderBlock::paintObject (this=0x8585da4,
    pI=@0xbfea4280, _tx=6, _ty=342, shouldPaintOutline=true)
    at /root/kdelibs/kdelibs-3.5.6/./khtml/rendering/render_block.cpp:1645
#44 0xb5fda39d in khtml::RenderBlock::paint (this=0x8585da4, pI=@0xbfea4280,
    _tx=6, _ty=318)
    at /root/kdelibs/kdelibs-3.5.6/./khtml/rendering/render_block.cpp:1611
#45 0xb5fd9ff4 in khtml::RenderBlock::paintObject (this=0x8585c54,
    pI=@0xbfea4280, _tx=6, _ty=318, shouldPaintOutline=true)
    at /root/kdelibs/kdelibs-3.5.6/./khtml/rendering/render_block.cpp:1645
#46 0xb5fda39d in khtml::RenderBlock::paint (this=0x8585c54, pI=@0xbfea4280,
    _tx=6, _ty=243)
    at /root/kdelibs/kdelibs-3.5.6/./khtml/rendering/render_block.cpp:1611
#47 0xb5fd9ff4 in khtml::RenderBlock::paintObject (this=0x85857b8,
    pI=@0xbfea4280, _tx=6, _ty=243, shouldPaintOutline=true)
    at /root/kdelibs/kdelibs-3.5.6/./khtml/rendering/render_block.cpp:1645
#48 0xb5fda39d in khtml::RenderBlock::paint (this=0x85857b8, pI=@0xbfea4280,
    _tx=4, _ty=110)
    at /root/kdelibs/kdelibs-3.5.6/./khtml/rendering/render_block.cpp:1611
#49 0xb5fd9ff4 in khtml::RenderBlock::paintObject (this=0x8585128,
    pI=@0xbfea4280, _tx=4, _ty=110, shouldPaintOutline=true)
    at /root/kdelibs/kdelibs-3.5.6/./khtml/rendering/render_block.cpp:1645
#50 0xb5fda39d in khtml::RenderBlock::paint (this=0x8585128, pI=@0xbfea4280,
    _tx=0, _ty=106)
    at /root/kdelibs/kdelibs-3.5.6/./khtml/rendering/render_block.cpp:1611
#51 0xb5fd9ff4 in khtml::RenderBlock::paintObject (this=0x8585040,
    pI=@0xbfea4280, _tx=0, _ty=106, shouldPaintOutline=true)
    at /root/kdelibs/kdelibs-3.5.6/./khtml/rendering/render_block.cpp:1645
#52 0xb5fda39d in khtml::RenderBlock::paint (this=0x8585040, pI=@0xbfea4280,
    _tx=0, _ty=0)
    at /root/kdelibs/kdelibs-3.5.6/./khtml/rendering/render_block.cpp:1611
#53 0xb5ff5cd6 in khtml::RenderLayer::paintLayer (this=0x85850c4,
    rootLayer=0x8583f28, p=0x8463f48, paintDirtyRect=@0xbfea45bc,
    selectionOnly=false)
    at /root/kdelibs/kdelibs-3.5.6/./khtml/rendering/render_layer.cpp:918
#54 0xb5ff5b7b in khtml::RenderLayer::paintLayer (this=0x8584010,
    rootLayer=0x8583f28, p=0x8463f48, paintDirtyRect=@0xbfea45bc,
    selectionOnly=false)
    at /root/kdelibs/kdelibs-3.5.6/./khtml/rendering/render_layer.cpp:941
#55 0xb5ff5bed in khtml::RenderLayer::paintLayer (this=0x8583f28,
    rootLayer=0x8583f28, p=0x8463f48, paintDirtyRect=@0xbfea45bc,
    selectionOnly=false)
    at /root/kdelibs/kdelibs-3.5.6/./khtml/rendering/render_layer.cpp:948
#56 0xb5ff5f97 in khtml::RenderLayer::paint (this=0x8583f28, p=0x8463f48,
    damageRect=@0xbfea45bc, selectionOnly=false)
    at /root/kdelibs/kdelibs-3.5.6/./khtml/rendering/render_layer.cpp:820
#57 0xb5f212ab in KHTMLView::drawContents (this=0x848b410, p=0xbfea46b8,
    ex=0, ey=0, ew=1116, eh=750)
    at /root/kdelibs/kdelibs-3.5.6/./khtml/khtmlview.cpp:725
#58 0xb7427162 in QScrollView::drawContentsOffset ()
   from /usr/lib/libqt-mt.so.3
#59 0xb7427b34 in QScrollView::viewportPaintEvent ()
   from /usr/lib/libqt-mt.so.3
#60 0xb74284d8 in QScrollView::eventFilter () from /usr/lib/libqt-mt.so.3
#61 0xb5ee88a9 in KHTMLView::eventFilter (this=0x848b410, o=0x84640b8,
    e=0xbfea4cf4) at /root/kdelibs/kdelibs-3.5.6/./khtml/khtmlview.cpp:1954
#62 0xb72f0f04 in QObject::activate_filters () from /usr/lib/libqt-mt.so.3
#63 0xb72f0f82 in QObject::event () from /usr/lib/libqt-mt.so.3
#64 0xb732865b in QWidget::event () from /usr/lib/libqt-mt.so.3
#65 0xb7288b88 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#66 0xb728b552 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#67 0xb795dc82 in KApplication::notify (this=0xbfea5868, receiver=0x84640b8,
    event=0xbfea4cf4)
    at /root/kdelibs/kdelibs-3.5.6/./kdecore/kapplication.cpp:550
#68 0xb721b389 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#69 0xb725557d in QWidget::repaint () from /usr/lib/libqt-mt.so.3
#70 0xb74272c5 in QScrollView::repaintContents () from /usr/lib/libqt-mt.so.3
#71 0xb74273cf in QScrollView::repaintContents () from /usr/lib/libqt-mt.so.3
#72 0xb5f2032e in KHTMLView::timerEvent (this=0x848b410, e=0xbfea5208)
    at /root/kdelibs/kdelibs-3.5.6/./khtml/khtmlview.cpp:3459
#73 0xb72f0fda in QObject::event () from /usr/lib/libqt-mt.so.3
#74 0xb732865b in QWidget::event () from /usr/lib/libqt-mt.so.3
#75 0xb7288b88 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#76 0xb728b552 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#77 0xb795dc82 in KApplication::notify (this=0xbfea5868, receiver=0x848b410,
    event=0xbfea5208)
    at /root/kdelibs/kdelibs-3.5.6/./kdecore/kapplication.cpp:550
#78 0xb721b389 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#79 0xb727b5d3 in QEventLoop::activateTimers () from /usr/lib/libqt-mt.so.3
#80 0xb722fec5 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#81 0xb72a325e in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#82 0xb72a306e in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#83 0xb728a731 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#84 0xb671a894 in kdemain () from /usr/lib/libkdeinit_konqueror.so
#85 0xb7fd2524 in kdeinitmain () from /usr/lib/kde3/konqueror.so
#86 0x0804e4df in launch (argc=5, _name=0x80c4ce4 "konqueror",
    args=0x80c4d40 "", cwd=0x0, envc=0, envs=0x80c4d45 "", reset_env=false,
    tty=0x0, avoid_loops=false, startup_id_str=0x8050e2e "0")
    at /root/kdelibs/kdelibs-3.5.6/./kinit/kinit.cpp:673
#87 0x0804ed6a in handle_launcher_request (sock=10)
    at /root/kdelibs/kdelibs-3.5.6/./kinit/kinit.cpp:1240
#88 0x0804f118 in handle_requests (waitForPid=0)
    at /root/kdelibs/kdelibs-3.5.6/./kinit/kinit.cpp:1443
#89 0x080503ac in main (argc=5, argv=0xbfea5ff4, envp=0xbfea600c)
    at /root/kdelibs/kdelibs-3.5.6/./kinit/kinit.cpp:1909
#90 0xb7d5a8cc in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#91 0x0804b971 in _start ()
Comment 12 Lubos Lunak 2008-07-21 16:22:43 UTC
SVN commit 835987 by lunakl:

Remove emitting of aboutToQuit() from KApplication::xioErrhandler() - the application
is not about to quit, it is about to fall flat on its face. There is really not that
much to do once KDE apps lose their connection to the X server. How that can happen
while the X server still continues to run is a different question and I don't know
the answer. It is quite possible it is caused by careless usage of one X connection
from several threads concurrently without proper locking.

CCBUG: 166685
CCBUG: 166432
CCBUG: 166401
CCBUG: 166179
CCBUG: 165451
CCBUG: 165307
CCBUG: 165059
CCBUG: 164740
CCBUG: 164665
CCBUG: 163751
CCBUG: 163355
CCBUG: 161787
CCBUG: 160692
CCBUG: 160458
CCBUG: 158194
CCBUG: 158088
CCBUG: 157607
CCBUG: 154011
CCBUG: 151293
CCBUG: 146891
CCBUG: 146700
CCBUG: 146562
CCBUG: 144383
CCBUG: 143375
CCBUG: 141871
BUG: 140683
CCBUG: 139162
CCBUG: 134708
CCBUG: 133332
CCBUG: 128588
CCBUG: 112960



 M  +0 -1      kapplication.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=835987
Comment 13 Dominik Tritscher 2008-08-21 21:47:06 UTC
So this seems to be fixed, and can be closed.