Bug 112449 - "Select Categories" has strange focus behaviour
Summary: "Select Categories" has strange focus behaviour
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kab3
Classification: Unclassified
Component: general (show other bugs)
Version: 3.4
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Tobias Koenig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-12 04:36 UTC by Mark Williamson
Modified: 2009-08-05 16:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Williamson 2005-09-12 04:36:03 UTC
Version:           3.4 (using KDE 3.4.0, Debian Package 4:3.4.0-0ubuntu3.4 (3.1))
Compiler:          gcc version 3.3.5 (Debian 1:3.3.5-8ubuntu2)
OS:                Linux (i686) release 2.6.10-5-386

* Open a contact in the addressbook for editting
* click "Select Categories"
* change some categories
* Click OK _on the contact window_, ignoring the "Select Categories" window

The changes made do not take effect.

It's not clear if this is intended but I did find it rather surprising a) that I could use the "outer" OK and b) that the settings disappeared.
Comment 1 Philip Rodrigues 2006-09-21 17:22:34 UTC
Confirmed on r582187. Perhaps the 'select categories' dialog should be made modal?
Comment 2 Tobias Koenig 2007-02-09 18:00:55 UTC
SVN commit 631975 by tokoe:

Change non-modal dialogs into modal ones to prevent the user
from closing the contact editor dialog before the category editor dialog.

BUG:112449


 M  +2 -4      addresseeeditorwidget.cpp  


--- branches/KDE/3.5/kdepim/kaddressbook/addresseeeditorwidget.cpp #631974:631975
@@ -782,8 +782,7 @@
   }
 
   mCategorySelectDialog->setSelected( QStringList::split( ",", mCategoryEdit->text() ) );
-  mCategorySelectDialog->show();
-  mCategorySelectDialog->raise();
+  mCategorySelectDialog->exec();
 }
 
 void AddresseeEditorWidget::categoriesSelected( const QStringList &list )
@@ -799,8 +798,7 @@
              mCategorySelectDialog, SLOT( updateCategoryConfig() ) );
   }
 
-  mCategoryEditDialog->show();
-  mCategoryEditDialog->raise();
+  mCategoryEditDialog->exec();
 }
 
 void AddresseeEditorWidget::emitModified()
Comment 3 Tobias Koenig 2009-08-05 16:27:07 UTC
The development of the old KAddressBook will be discontinued for KDE 4.4.
Since the new application has the same name, but a completly new code base we close all bug reports against the old version and ask the submitters to resend there reports against the new product.