Bug 112118 - Juk no longer finds covers
Summary: Juk no longer finds covers
Status: RESOLVED FIXED
Alias: None
Product: juk
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Scott Wheeler
URL:
Keywords:
: 114979 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-09-06 14:52 UTC by Alessandro Dal Grande
Modified: 2005-10-25 22:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alessandro Dal Grande 2005-09-06 14:52:03 UTC
Version:           2.2.2 (using KDE KDE 3.4.2)
Installed from:    Debian testing/unstable Packages
Compiler:          Gcc 4.0.1 amd64 platform
OS:                Linux

I can't download covers with Cover Manager any more: any search with it (that I think uses Google) will give no results. Even for covers I downloaded with Juk of KDE 3.4.1, that I'm sure they are on the net. Even if I try to search with a more general question.
Any other experiencing this problem?
My solution now is to manually download a cover from Google and then load it in Juk.
Comment 1 Michael Pyne 2005-09-07 00:11:36 UTC
This is because of a change in the way KHTML works.  JuK wasn't properly using KHTML so a change in KHTML exposed a bug in JuK's handling of the feature.  I'm surprised it didn't crash.

Anyways, the bug is fixed in /trunk, and I thought I backported the fix but it appears that I forgot.  I will backport and the fix should work in 3.4.3 (and will also be in 3.5).
Comment 2 Michael Pyne 2005-09-07 00:12:39 UTC
SVN commit 457901 by mpyne:

Backport fix for bug 112118 (JuK Google cover search doesn't work anymore) to KDE 3.4.

Sorry about forgetting to do so earlier.

BUG:112118


 M  +13 -1     googlefetcher.cpp  


--- branches/KDE/3.4/kdemultimedia/juk/googlefetcher.cpp #457900:457901
@@ -18,6 +18,8 @@
 #include <dom/dom_exception.h>
 #include <dom/dom2_traversal.h>
 
+#include <khtml_part.h>
+
 #include <kapplication.h>
 #include <kstatusbar.h>
 #include <kmainwindow.h>
@@ -85,8 +87,18 @@
     // choice if we're going to screen-scrape Google.
     try {
 
-    DOM::HTMLDocument search;
+    KHTMLPart part;
+
+    // Create empty document.
+
+    part.begin();
+    part.end();
+
+    DOM::HTMLDocument search = part.htmlDocument();
     search.setAsync(false); // Grab the document before proceeding.
+
+    kdDebug(65432) << "Performing Google Search: " << url << endl;
+
     search.load(url.url());
 
     DOM::HTMLElement body = search.body();
Comment 3 Michael Pyne 2005-10-25 22:35:53 UTC
*** Bug 114979 has been marked as a duplicate of this bug. ***