Bug 110915 - Confusing error requester while sending to self
Summary: Confusing error requester while sending to self
Status: RESOLVED FIXED
Alias: None
Product: knotes
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Michael Brade
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-16 21:15 UTC by Marcin Orlowski
Modified: 2006-01-10 01:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcin Orlowski 2005-08-16 21:15:44 UTC
Version:           3.5 (using KDE 3.4.1, Debian Package 4:3.4.1-1 (3.1))
Compiler:          gcc version 3.3.6 (Debian 1:3.3.6-5)
OS:                Linux (i686) release 2.6.11.10

Whenever I try to send a note to myself while having "Accept incoming notes" disabled, I see "Communication error: No such file or directory".
Comment 1 Michael Brade 2006-01-10 01:16:28 UTC
SVN commit 496193 by brade:

rewrote the networking code to use KNetwork:
 * fixed #110915: KNetwork has better error reporting than the previous
   code, now it says "connection actively refused" instead of "No such
   file or directory"
 * fixed #110838: this one was caused by an uninitialize variable, so it
   wasn't reproducible

BUG: 110838, 110915


 M  +9 -0      ChangeLog  
 M  +17 -11    knotesapp.cpp  
 M  +6 -3      knotesapp.h  
 M  +31 -19    knotesnetrecv.cpp  
 M  +8 -5      knotesnetrecv.h  
 M  +20 -18    knotesnetsend.cpp  
 M  +9 -7      knotesnetsend.h