Bug 110838 - KNotes via network does not work properly
Summary: KNotes via network does not work properly
Status: RESOLVED FIXED
Alias: None
Product: knotes
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Michael Brade
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-15 20:30 UTC by rgpublic
Modified: 2006-01-10 01:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rgpublic 2005-08-15 20:30:06 UTC
Version:            (using KDE KDE 3.4.0)
Installed from:    SuSE RPMs

Mmm, I've been a bit hesitant to file this bug because I must admit
that I dont have much information that might help here.
Nevertheless, network sending of notes just does not work with my
colleague most of the time. Some strange facts:
1) If he wants to send a note to me it always works flawlessly
2) I can send a note to him only in rare cases. Most of the time
nothing happens. Sometimes it does work for no aparrent reason.
I havent been able to figure out why it sometimes works.
3) If I do a telnet to his KNotes port and enter some letters,
it works always.

Point 3) seems to suggest that it isnt a network problem.
Anyway, we did double check that our local SuSE firewall is disabled
and that the package wont get lost in our company firewall.

We both use the same KDE version (3.4) that comes with SuSE 9.3.
Unfortunately we havent got the capabilities and resources to compile
a current CVS version so we cannot test if the problem is resolved.

We really did try a lot to find out if this is our fault before
filing this bug.

If there is anything we can do/try please let me know.
If you think this is complete non-sense and I'm hallucinating, feel
free to close this bug as works-for-me ;-)
We'll live without that feature then, thought I must admit it would be 
a really great feature if it worked properly.
Comment 1 Michael Brade 2006-01-10 01:16:29 UTC
SVN commit 496193 by brade:

rewrote the networking code to use KNetwork:
 * fixed #110915: KNetwork has better error reporting than the previous
   code, now it says "connection actively refused" instead of "No such
   file or directory"
 * fixed #110838: this one was caused by an uninitialize variable, so it
   wasn't reproducible

BUG: 110838, 110915


 M  +9 -0      ChangeLog  
 M  +17 -11    knotesapp.cpp  
 M  +6 -3      knotesapp.h  
 M  +31 -19    knotesnetrecv.cpp  
 M  +8 -5      knotesnetrecv.h  
 M  +20 -18    knotesnetsend.cpp  
 M  +9 -7      knotesnetsend.h