Bug 109704 - Choosing a name for the download doesn't work
Summary: Choosing a name for the download doesn't work
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmldonkey
Classification: Unclassified
Component: general (show other bugs)
Version: 0.10.1
Platform: unspecified Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Aleksey Markelov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-07-27 14:34 UTC by Iñaki Baz Castillo
Modified: 2018-09-03 03:37 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
download rename patch (2.87 KB, patch)
2009-05-16 16:21 UTC, Aleksey Markelov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Iñaki Baz Castillo 2005-07-27 14:34:44 UTC
Version:           0.10.1 (using KDE 3.4.1, Debian Package 4:3.4.1-1 (3.1))
Compiler:          gcc version 3.3.6 (Debian 1:3.3.6-5)
OS:                Linux (i686) release 2.6.10

When I look for files if I do double-click in some file it appears "Choose the text of the new download". I change its name but in the "Downloads" tab the name of the new download it's the original instead of the name I have set.
Comment 1 FiNeX 2008-12-26 14:01:29 UTC
Confirmed using current KDE4 version (r901634)
Comment 2 Aleksey Markelov 2009-05-16 16:21:11 UTC
Created attachment 33723 [details]
download rename patch

Look like mldonkey no longer uses list in Download_query message, see src/daemon/common/commonResult.ml (let result_download). Only way I see is to send rename request after fileAdded signal was received. Attached patch works for me but I'm not sure if it's best solution.
Comment 3 Eduard Huguet 2011-01-29 00:15:16 UTC
I merged your patch to "../kde/branches/work/kmldonkey", as it seems to run fine.
Comment 4 Eduard Huguet 2011-04-13 10:34:14 UTC
Merged to trunk (version changed to 2.0.6), so it should be marked as "fixed"
Comment 5 Andrew Crouthamel 2018-09-03 03:37:35 UTC
Hello! Sorry to be the bearer of bad news, but this project has been
unmaintained for many years and I will be closing this bug.