Bug 108274 - Close Other Tabs shortcut key closes wrong tabs
Summary: Close Other Tabs shortcut key closes wrong tabs
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 98607 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-06-28 16:17 UTC by Kevin Yeung
Modified: 2007-12-10 15:20 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Yeung 2005-06-28 16:17:47 UTC
Version:            (using KDE KDE 3.4.1)
Installed from:    SuSE RPMs
OS:                Linux

When using a shortcut key assigned to "Close Other Tabs", the current visible tab gets closed and the wrong tab remains. Here're the steps to reproduce this problem:

1. Settings, Configure Shortcuts..., Search for "Close Other Tabs". Assign a key to it. I assigned F4.
2. Go to http://www.kde.org/ or any website. Open many tabs.
3. Pick the 3rd tab to make it the current tab.
4. Press F4.
5. Will notice that the current tab is closed and a wrong tab remains as the last tab.

Right-clicking a tab and using the popup menu to close other tabs doesn't seem to suffer from this problem.
Comment 1 Pascal Létourneau 2005-07-01 06:24:54 UTC
SVN commit 430384 by pletourn:

Keep the current tab when removing the other tabs via the keyboard

BUG:108274


 M  +1 -1      konq_viewmgr.cc  


--- branches/KDE/3.4/kdebase/konqueror/konq_viewmgr.cc #430383:430384
@@ -635,7 +635,7 @@
 
   for ( it.toFirst(); it != 0L; ++it )
   {
-    if( it.current() != tab)
+    if( it.current() != currentFrame )
       removeTab(it.current());
   }
 
Comment 2 Pascal Létourneau 2005-07-01 21:13:23 UTC
*** Bug 98607 has been marked as a duplicate of this bug. ***
Comment 3 Volkov Ivan 2007-12-10 15:20:31 UTC
In KDE 3.5.8 ( Kubuntu 7.10 ) i have the same bug! I've checked kdebase/konqueror/konq_viewmgr.cc, the "if( it.current() != currentFrame )" is present there, but i can commit the same bug!
To reproduce it open three tabs, for example
http://bugs.winehq.org/show_bug.cgi?id=10147
http://www.overclockers.ru/hardnews/27628.shtml
and
http://www.overclockers.ru/hardnews/27627.shtml
then pick the first one (bugs.winehq.org) and press a hotkey to close other tabs. The rightmost tab will remain open.
The main difference between what i can see and the bug 108274 is that it appears only with certain pages opened in tabs.
I have flash player and mplayer plugins loaded.