Bug 107820 - Lists aren't exported in OpenOffice documents
Summary: Lists aren't exported in OpenOffice documents
Status: RESOLVED FIXED
Alias: None
Product: kword
Classification: Miscellaneous
Component: opendocument (show other bugs)
Version: 1.5 or before
Platform: Gentoo Packages Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: Thomas Zander
URL:
Keywords:
: 113460 138779 150580 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-06-21 03:37 UTC by Diego Elio Pettenò
Modified: 2009-11-07 21:09 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Document with an ordered list in KWord format (2.95 KB, application/octet-stream)
2005-06-21 14:16 UTC, Diego Elio Pettenò
Details
Document converted from the other in OpenOffice 1.1 format (2.09 KB, application/octet-stream)
2005-06-21 14:17 UTC, Diego Elio Pettenò
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò 2005-06-21 03:37:05 UTC
Version:           1.4 rc1 (using KDE KDE 3.4.1)
Installed from:    Gentoo Packages
OS:                Linux

Trying to use KWord to edit an OpenOffice (1.1) document, all the lists in the document are stripped of the saved version of the document.

It loads them fines but when KWord saves the document in OpenOffice format, they are lost (they don't even show up whem reopening that file with KWord itself).

This makes unpractical using KWord directly to handle OpenOffice 1.1 files.
Comment 1 David Faure 2005-06-21 12:07:53 UTC
Hello, thanks for the report.
Please attach a test document in reply to this mail. 
Comment 2 Diego Elio Pettenò 2005-06-21 14:16:33 UTC
Created attachment 11535 [details]
Document with an ordered list in KWord format
Comment 3 Diego Elio Pettenò 2005-06-21 14:17:01 UTC
Created attachment 11536 [details]
Document converted from the other in OpenOffice 1.1 format
Comment 4 David Faure 2005-09-27 02:12:07 UTC
The bug still exists (with the .sxw format), but note that the OASIS OpenDocument format (.odt, default for OO-2.0 and hopefully KOffice-1.5) fixes this problem.
Comment 5 Diego Elio Pettenò 2005-09-27 03:11:46 UTC
Unfortunately, ODT is not a complete solution. While KOffice seems to load fine the documents from OpenOffice 1.9, it's not true the opposite: an ODT saved with KOffice containing lists is loaded without lists on OpenOffice 1.9 (latest version, it's true for at least the last 5 alphas/betas I've tried).
So I still think that missing the export in SXW is a quite big problem, as between this and the other problem (not sure who's responsible to that, but as KOffice seems to load OO's ODTs, I'd probably say it's not KOffice's) there's currently no way to export a document with lists with it from KWord to OpenOffice Writer (RTF doesn't work, bug in OpenOffice handling).
Comment 6 David Faure 2005-09-27 10:47:55 UTC
On Tuesday 27 September 2005 03:11, Diego Pettenò wrote:
> Unfortunately, ODT is not a complete solution. While KOffice seems to load fine the documents from OpenOffice 1.9, it's not true the opposite: an ODT saved with KOffice containing lists is loaded without lists on OpenOffice 1.9 (latest version, it's true for at least the last 5 alphas/betas I've tried).


Yes, this is due to a missing implementation in OpenOffice, see http://www.openoffice.org/issues/show_bug.cgi?id=52127
(feel free to vote on that one :)

This is the proper long-term solution, ODT is going to be the native format in both suites,
whereas the Oo-1.1.x format is going to die. I don't object to fixing the .sxw exporter
of course, but that's a job for Nicolas Goutte anyway, I don't know that code.
Comment 7 David Faure 2005-09-27 23:55:04 UTC
*** Bug 113460 has been marked as a duplicate of this bug. ***
Comment 8 Richard Bos 2005-09-28 19:59:56 UTC
How do I vote at OOo?  I clicked "vote for this bug", but I was only
shown a help page.  I did not find a "create a login" button.
Comment 9 Richard Bos 2005-09-28 21:05:16 UTC
One can create an OOo login by going to the "my pages" tab.
Just register, and wait quite a while before confirmation email
is sent.  The bug has now 6 votes...

Comment 10 Shriramana Sharma 2005-09-29 01:32:14 UTC
Pardon, but are we sure that this is not a bug with KOffice? I too had many interoperability issues with KOffice and OOo and would like to vote.
Comment 11 David Faure 2005-09-29 10:41:46 UTC
> Pardon, but are we sure that this is not a bug with KOffice?


Yes, I am sure. The files created by KOffice are valid (they validate against 
the strict RelaxNG schema, and make sense semantically as well).
The only problem is that there are two ways to model numbered lists in
OpenDocument, and we use one when writing out files, and OpenOffice.org
only supports the other. (And we support both when reading, this is why we can read
OOo's lists). However both ways are part of the standard,
so the fault lies with OpenOffice.org not being able to read it.
Comment 12 Thomas Zander 2007-10-19 23:45:09 UTC
*** Bug 150580 has been marked as a duplicate of this bug. ***
Comment 13 Thomas Zander 2007-10-19 23:59:56 UTC
*** Bug 138779 has been marked as a duplicate of this bug. ***