Bug 104879 - Submissions to audioscrobbler are sometimes not cronological
Summary: Submissions to audioscrobbler are sometimes not cronological
Status: RESOLVED WORKSFORME
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 1.2.3
Platform: Debian testing Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-05-01 03:28 UTC by Adeodato Simó
Modified: 2006-06-11 12:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adeodato Simó 2005-05-01 03:28:17 UTC
Hello, I'm forwarding Debian Bug #307084 (http://bugs.debian.org/307084). It 
was reported by Gordon Haverland <ghaverla@materialisations.com>: 
 
---------------------------8<---------------------------------------------- 
> > Occasionally, I get messages back from Audioscrobbler, saying 
> > that a certain submission is being treated as spam since it 
> > was previously reported.  The difference in times is always 
> > (?) 15 seconds.  Some kind of timeout issue? 
> 
>   How do you receive such messages? (Popup, mail, stderr.) Can 
> you include the full text of one, if that would be possible? 
 
It is a message on my "home page" at audioscrobbler.com. 
 
>: Your plugin reported a submission error: Spam protection 
>: triggered this submission dated earlier than previous 
>: submission (this:2005-04-30 11:54:45, 
>: last: 2005-04-30 11:55:00) 
 
Audioscrobbler reports that my plugin is "Plugin ID: ark, Version: 
0.1". 
 
I'm not sure what song was reported twice.  This happens maybe 
once or twice a day. 
---------------------------8<---------------------------------------------- 
 
Basically, see http://www.audioscrobbler.com/forum/28/_/7082.
Comment 1 Matiss Piesins 2005-05-07 21:30:04 UTC
I have no specific evidence, but just the impression, that sometimes, after starting amarok again, it had a list of unsubmitted songs. These should get processed now, but instead - amarok remembers about them just after it has submitted the freshly played song and now tries to submit the cached ones.

Ha, I just read that topic (see above link) and it confirms with what I described above - amaroks plugin does not confirm to what audioscrobbler whants, that is:

1) songs must be submitted chronologically (and with, say, 20 sec pause between each submission)

2) (my suggestion) if the cache file gets too big, the submission que might become too long to complete before the new (freshly) played song should be submitted. To avoid too much complexity - either the cache should have some validity time and limited max length, or the submission should be done with a sort of spooling service, like with mail and printing systems.
Comment 2 Alexandre Oliveira 2005-05-10 21:49:04 UTC
"amarok remembers about them just after it has submitted the freshly played song and now tries to submit the cached ones".
No, we add it to a queue, and submit the first ten (maximum allowed) of that queue, so we should be doing the right thing.

1) The 20 second is between the playtime of each song, not between the submitions.
2) As I can see, we only submit ten songs in each playing song, the others wait for next song.

It's difficult to test this, as audioscrobbler is always offline when I want to test.

Anyway, for anyone that can reproduce this: don't you listen to music in different computers, or maybe using different local users (for the same audioscrobbler profile) or something?
Comment 3 Adeodato Simó 2005-05-11 00:07:26 UTC
* Alexandre Oliveira [Tue, 10 May 2005 19:49:06 -0000]:

> Anyway, for anyone that can reproduce this: don't you listen to music
> in different computers, or maybe using different local users (for the
> same audioscrobbler profile) or something?


  The original submitter of the Debian bug answers to this:

* Gordon Haverland [Tue, 10 May 2005 14:16:19 -0600]:

> I'm only running amarok as a single user on my Linux machine (not
> root).  I only have one ID at audioscrobbler (and last.fm), and
> if I am connected to audioscrobbler to display my user page, I
> only use Mozilla (not firefox, konqueror, ...) to display that
> page.


> I do have a few other users listed in /etc/passwd on my machine,
> but they are for minor uses and even when I have one of them
> active, they don't listen to music (use the various sound
> devices).


> This is a SMP machine, with 2 CPUs.  So I maybe it has something
> to do with that?  (Grasping at straws. :-))


> If upstream wants me to run a development code or something, I am
> more than willing to download something and compile it here, if
> need be.  But it seems reproducible in that I can expect to see
> it once a day or so.

Comment 4 Matiss Piesins 2005-05-12 00:10:35 UTC
perhaps it's really just the overload or some other problems at audioscrobblers side, not ours.
I didn't realize I could see the debug output in konsole, but now, as of yesterday, there have been changes in amaroks code (something with KIO::smth).
What happens now is - in the middle of song it tries to submit some (supposedly 10) songs, but fails with "[WARNING!] KIO error! errno: 63".
Still there are no good evidence that there are no problems at the server.
Comment 5 Matiss Piesins 2005-06-03 16:16:40 UTC
Now the server seems to be quite stable for some time already, and as of build from 19 of May (that KIO::something is back to the old type) it submits everything nicely.

IMO no problems here -> bug is not valid and could be closed
Comment 6 Alexandre Oliveira 2005-06-27 07:03:57 UTC
If people can still reproduce this, reopen please!