Bug 103671 - feed list is being truncated when disk is full
Summary: feed list is being truncated when disk is full
Status: RESOLVED FIXED
Alias: None
Product: akregator
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-11 17:34 UTC by Till
Modified: 2008-10-25 21:24 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Till 2005-04-11 17:34:11 UTC
Version:            (using KDE KDE 3.4.0)
Installed from:    Debian testing/unstable Packages

I just lost my whole feed list, because my home-partition was full. Akregator was running. Then it exited and when starting it again, it told me, that it created a backup... Well, the backup was 0 Bytes. Additionally there was a feeds.opml~ file, which contained all my feeds. But after closing down Akregator and starting it again, this file was also 0 Bytes -> All feeds gone. Of course I could have backuped te feeds.opml~ file before, but this would not be nice.
Akregator should simply be able to keep it's feed list, although the disk is full.
Comment 1 Frank Osterfeld 2005-09-30 10:04:11 UTC
SVN commit 465588 by osterfeld:

store feed list in the backend as backup. If feeds.opml is corrupt, akregator falls back to the backup 
now and loads that instead. 
Hopefully that also fixes the problem with full partitons (if metakit handles this - it should. I have to 
check, wasn't yet able to reproduce 103671)
BUG: 104015
CCBUG: 103671


 M  +52 -29    akregator_part.cpp  
 M  +47 -10    mk4storage/storagemk4impl.cpp  
Comment 2 Frank Osterfeld 2008-10-25 21:24:13 UTC
SVN commit 875832 by osterfeld:

Use KSaveFile when writing to files.
It's both more secure (think symlink attacks) and also prevents half-written and thus corrupt feed lists.
Already fixed in trunk, not need to forwardport.
BUG:103671


 M  +8 -7      akregator_part.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=875832