Bug 103366 - Editing an 'Album date' in the widget below the calendar widget Albums forgets the modification unless return (that closes the dialog too)
Summary: Editing an 'Album date' in the widget below the calendar widget Albums forget...
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 3.4
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-06 17:59 UTC by Achim Bohnet
Modified: 2011-07-27 13:18 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Achim Bohnet 2005-04-06 17:59:31 UTC
Version:           0.7.2 (using KDE 3.4.0, Debian Package 4:3.4.0-0pre2 (3.1))
Compiler:          gcc version 3.3.5 (Debian 1:3.3.5-8)
OS:                Linux (i686) release 2.6.10-1-686

Verifed with debian 0.7.2-2 pkg and todays cvs build:

o Set album sort order to date
o edit album properties...
o change date manually in the widget below the calendar
  widget, e.g., 6.4.2005 -> 6.4.1978

now click on okay button or <TAB> and then on okay button
--> date is forgotten when one oneopen properties again.

instead when you changed the date manually and then press
<return> the modified date is saved, but unfortunately the
dialog is closed too.

Achim
Comment 1 Achim Bohnet 2005-04-06 18:22:14 UTC
FWIW Original bug report: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=302899
Comment 2 Renchi Raju 2005-04-16 19:06:42 UTC
reassigning to kdelibs. the problem is that the widget for entering date manually in kdatepicker will only validate the date entered if enter is pressed. it doesn't swallow the keypressevent (for enter) and it is passed to the parentwidget and most of the time a ok button (which closes the parent widget) comes into focus after that and the parent widget is closed. some suggestions for further improvement:
a) validate date and update calendar widget on focus out event 
b) use a variant of qdateedit to enter the date at the bottom. the current lineedit, imho, is not the best tool to enter a date manually.
Comment 3 Christoph Feck 2011-07-27 13:18:25 UTC
No longer happens. While Enter still closes the dialog (which is expected), using the OK button correctly remembers the album date.