Bug 102641 - Winkey is not working
Summary: Winkey is not working
Status: RESOLVED NOT A BUG
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal with 2 votes (vote)
Target Milestone: ---
Assignee: Aaron J. Seigo
URL:
Keywords:
: 103294 105580 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-03-28 07:25 UTC by Łukasz Derkacz
Modified: 2005-07-06 19:39 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Łukasz Derkacz 2005-03-28 07:25:35 UTC
Version:           3.4.0 (using KDE 3.4.0, compiled sources)
Compiler:          gcc version 3.3.4
OS:                Linux (i686) release 2.4.26

After upgrading to KDE 3.4 I've lost ability to open KDE Menu by pressing Winkey. Now I have to set it Winkey+regular key. But it worked with 3.3.
Regards
Comment 1 Thiago Macieira 2005-03-28 13:02:00 UTC
Not a bug. It was intentionally removed because the code that supported this was a big hack and unmaintanable.

If you want to use the Win key alone, you need to make it a non-modifier in your X configuration.
Comment 2 info 2005-03-29 11:00:30 UTC
Hi,

> If you want to use the Win key alone,
> you need to make it a non-modifier in your X configuration.

(Not strictly KDE, but...) It might be useful to say how to do it, because it is almost impossible for non-experts to work out how to change the keyboard in X. 

I solved it after much googling and struggling through lots of geektalk (what are hyper, super and meta keys?) by editing /etc/X11/xkb/symbols/pc/de (for German layout) and adding a line in the basic section

xkb_symbols "basic" {
(....)
    key <LWIN>  { [ F28 ] }; # Add this line
};

This makes the windows key the F28 key and it works like any other function key.

Perhaps this should be included in the FAQ, but I don't know if there is a better or preferred way.
Comment 3 Łukasz Derkacz 2005-03-29 11:16:43 UTC
Well, Setting Winkey as a normal key collides with amaroK shortcuts, so I did other thing, I set Winkey+Tab to activate kmenu. =) A way simpler...
Comment 4 Maksim Orlovich 2005-04-05 17:42:12 UTC
*** Bug 103294 has been marked as a duplicate of this bug. ***
Comment 5 Jarne Cook 2005-04-05 17:48:59 UTC
Two words.
"Wow", and "Lame".
Comment 6 Maksim Orlovich 2005-05-13 06:44:50 UTC
*** Bug 105580 has been marked as a duplicate of this bug. ***
Comment 7 Mohd Asif Ali Rizwaan 2005-07-05 17:18:40 UTC
One more anti-user act by kicker developers :((
Comment 8 Łukasz Derkacz 2005-07-05 17:27:37 UTC
Hey, I don't like it either, But why can't You appreciate their work? Those people are working hard to do their best. If they say that it was a big hack, they had good reasons to remove that. You would better see constant kicker's crashes or something similiar?
Comment 9 Mohd Asif Ali Rizwaan 2005-07-05 17:56:35 UTC
>Hey, I don't like it either, But why can't You appreciate their work? Those people are working hard to do their best. If they say that it was a big hack, they had good reasons to remove that. You would better see constant kicker's crashes or something similiar? 

I appreciate their work, the bug reports and wishlists are implicit appreciations. I wouldn't care to complain if I don't appreciate and know that they are good people.

I feel so sad, using Win key to pop up KMenu is natural for ALL windows users. And I have been used to it like you. 

We were never warned, nor given an alternative, not even a way to configure the xorg config thing (which even after googling couldn't figure out how to enable win key). Without any warning they've removed "A much used feature", I would rather say "A can't live without it feature."

It's their right to remove the code, but informing us or providing alternative would be nice.

BTW, I've never ever seen kicker crash with/without the Win key working. The kicker code is perfect. Just plain removal of unmaintainable code without an alternative is IMO not good.

Aaron please buddy, add support for Win key!
Comment 10 Thiago Macieira 2005-07-06 06:48:23 UTC
> One more anti-user act by kicker developers :((

I'll be brief because your comment doesn't deserve a lot of my time:
1) it was the kwin developer that removed the feature, not the kicker developers
2) it was severely broken (see comment #1)
Comment 11 Aaron J. Seigo 2005-07-06 19:39:11 UTC
i'll just add that asking for a feature you use that broke things constantly for many others is fairly selfish. it was a choice between breaking functionality (certain key board shortcuts using modifiers, in this case the Win key) or providing a quicky way for people to access the menu when there already is such a way (Alt+F1, which is there by default, or the X11 config change) ... 

we try not to do these things without thinking about the broader picture. we're not perfect and do make wrong decisions from time to time, but i think in thise case we made the best decision possible in a "damned if you do, damned if you don't" situation. we picked the option that damned us the least ;)