Bug 102209 - MARQUEE tag causes entire page content to shift with scrolling marquee
Summary: MARQUEE tag causes entire page content to shift with scrolling marquee
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Unclassified
Component: khtml parsing (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-22 21:26 UTC by t35t0r t35t0r
Modified: 2007-10-13 12:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description t35t0r t35t0r 2005-03-22 21:26:05 UTC
Version:            (using KDE KDE 3.3.2)
Installed from:    Gentoo Packages
Compiler:          gcc version 3.3.5  (Gentoo Linux 3.3.5-r1, ssp-3.3.2-3, pie-8.7.7.1) 
OS:                Linux

The marquee tag on this website http://cflfm.com/ causes the entire content of the page to scroll to the left.
Comment 1 Thiago Macieira 2005-03-23 00:36:13 UTC
Confirmed. Must be caused by the strange HTML:

open <center>
open <p>
open <font>
open <b>
open <font>
close <font>
close <font>
close <b>
never close <p> or <center>

The DOM tree shows the entire page inside <marquee>
Comment 2 Allan Sandfeld 2007-10-13 12:56:57 UTC
SVN commit 724766 by carewolf:

 Update HTML-Parser to parse more HTML5 like, and allow custom HTML tags. This
 makes us more compatible with IceWeasel and Opera
 BUG: 109557
 BUG: 102209
 CCBUG: 148715
 CCBUG: 150694



 M  +8 -0      ChangeLog  
 M  +39 -40    html/dtd.cpp  
 M  +19 -2     html/dtd.h  
 M  +3 -3      html/html_elementimpl.cpp  
 M  +73 -34    html/htmlparser.cpp  
 M  +2 -0      html/htmlparser.h  
 M  +8 -6      html/htmltokenizer.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=724766