Bug 100569 - "Jump to the currently playing item" button does not update Tag Editor
Summary: "Jump to the currently playing item" button does not update Tag Editor
Status: RESOLVED FIXED
Alias: None
Product: juk
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Scott Wheeler
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-01 17:56 UTC by Thomas McGuire
Modified: 2005-10-06 05:00 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas McGuire 2005-03-01 17:56:16 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
OS:                Linux

When using the "Jump to the currently playing item" button in the lower right corner and the tag editor is visible, the fields in the tag editor are not updated in case the current song is in a different playlist.

To reproduce:
0. Enable Tag Editor
1. Double-click a song in a playlist to start it
2. Switch to another playlist and single-click any item there. The fields in the Tag Editor are now updated  
    with the information from this item.
3. Click the "Jump to currently playing item" button. The Playlist will now change to the first one and the 
    current playing item will be selected. However, the Tag Editor still displays the old item.
Comment 1 Michael Pyne 2005-10-06 04:58:51 UTC
SVN commit 467719 by mpyne:

Fix bug 100569 (Jump to currently playing item feature doesn't update tag editor) in KDE 3.5.

CCBUG:100569


 M  +8 -1      playlist.cpp  


--- branches/KDE/3.5/kdemultimedia/juk/playlist.cpp #467718:467719
@@ -921,9 +921,16 @@
     Playlist *l = playingItem()->playlist();
 
     l->clearSelection();
+
+    // Raise the playlist before selecting the items otherwise the tag editor
+    // will not update when it gets the selectionChanged() notification
+    // because it will think the user is choosing a different playlist but not
+    // selecting a different item.
+
+    m_collection->raise(l);
+
     l->setSelected(playingItem(), true);
     l->ensureItemVisible(playingItem());
-    m_collection->raise(l);
 }
 
 void Playlist::slotColumnResizeModeChanged()
Comment 2 Michael Pyne 2005-10-06 05:00:22 UTC
SVN commit 467720 by mpyne:

Backport fix for bug 100569 (Jump to playing item doesn't update tag editor) to KDE 3.4.

BUG:100569


 M  +8 -1      playlist.cpp  


--- branches/KDE/3.4/kdemultimedia/juk/playlist.cpp #467719:467720
@@ -883,9 +883,16 @@
     Playlist *l = playingItem()->playlist();
 
     l->clearSelection();
+
+    // Raise the playlist before selecting the items otherwise the tag editor
+    // will not update when it gets the selectionChanged() notification
+    // because it will think the user is choosing a different playlist but not
+    // selecting a different item.
+
+    m_collection->raise(l);
+
     l->setSelected(playingItem(), true);
     l->ensureItemVisible(playingItem());
-    m_collection->raise(l);
 }
 
 void Playlist::slotColumnResizeModeChanged()