Bug 100185 - Still no KDE notifications after login
Summary: Still no KDE notifications after login
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: knotify (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Carsten Pfeiffer
URL:
Keywords:
: 100499 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-02-24 17:47 UTC by Oliver Zimmermann
Modified: 2007-11-16 17:27 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Fix for arts knotifyrc config (561 bytes, patch)
2005-02-27 15:04 UTC, Laurent Montel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Zimmermann 2005-02-24 17:47:27 UTC
Version:           Unbekannt (using KDE 3.4.0 Level "a" , SUSE 9.2 UNSUPPORTED)
Compiler:          gcc version 3.3.4 (pre 3.3.5 20040809)
OS:                Linux (i686) release 2.6.8-24.11-smp

It's there for a long time now and did not "vanish" with the updates: When I log into my KDE session, I have no system notifications. Only after executing the command "kdeinit knotify", I get the sound. What can I do to have it right from the start?
Comment 1 Stephan Binner 2005-02-27 14:50:33 UTC
Check/post ~/.kde/share/config/knotifyrc
Comment 2 Laurent Montel 2005-02-27 15:03:29 UTC
I created a patch to fix it.
Because when arts crashed it changed knotifyrc value.
But we can't restore value after.
So I reactivate it into kdebase/kcontrol/arts/
see my patch.
Comment 3 Laurent Montel 2005-02-27 15:04:22 UTC
Created attachment 9862 [details]
Fix for arts knotifyrc config
Comment 4 Stephan Binner 2005-02-27 15:09:29 UTC
> But we can't restore value after.

Mhm? kcontrol/knotify/knotify.cpp PlayerSettingsDialog::save()
Comment 5 Laurent Montel 2005-02-27 17:15:24 UTC
Hi,
Ok in kde3.3.2 I didn't see it.
But I think that it will be a very good idea to reactivate it
when we select arts sound.
Because it's not easy to find it.

Regards.
Comment 6 Tom 2005-02-27 18:04:30 UTC
SuSE 9.2 KDE 3.4rc1 rpms
gcc version 3.3.4 (pre 3.3.5 20040809)
Linux (i686) 2.6.8-24.11-default

Same problem here. System notifications won't play until 'kdeinit knotify'. I think it has something to do with the aRts packages Suse provides (for some reason they also prevent k3b from compiling).

//knotifyrc:
[Misc]
External player=amarok
LastConfiguredApp=KMail
Use external player=false
Volume=100

[StartProgress]
Arts Init=true
KNotify Init=true
Use Arts=true

//kdeinit knotify:

kdeinit knotify
kdeinit: Shutting down running client.
---------------------------------
It looks like dcopserver is already running. If you are sure
that it is not already running, remove /home/user/.DCOPserver_AthlonXP1800__0
and start dcopserver again.
---------------------------------

KDE Daemon (kded) already running.
kbuildsycoca running...
Reusing existing ksycoca
kbuildsycoca: WARNING: Property 'X-KDE-Weight' is defined multiple times (KOfficeFilter)

 
Comment 7 Tom 2005-02-28 09:40:54 UTC
Well, I've compiled arts from source and what shall I say - now it works. So my problem is definitely a SuSE package problem...
Comment 8 Stephan Binner 2005-03-01 12:05:33 UTC
*** Bug 100499 has been marked as a duplicate of this bug. ***
Comment 9 Christopher Martin 2005-06-09 00:14:32 UTC
This problem is still present in KDE 3.4.1 - basically, once you've turned off arts, turning it on again won't re-enable knotify, since in knotifyrc "Arts Init" and "Use Arts" remain false. The patch previously posted by Laurent Montel works well to allow use of knotify (with arts) when arts is re-enabled.

The patch doesn't seem to have been applied to SVN, though, and I was wondering if there were any reasons why this was the case. The patch does seem to work well enough, though I realize it's not a complete solution - for instance, if arts crashed, and then the user logged out and then in, knotify would still be broken until the user manually stopped/started arts. But nevertheless, it's a help for users, who should not have to edit a config file to get knotify working.

Thanks!
Comment 10 Juha Tuomala 2007-01-02 12:31:27 UTC
This problem is still present in KDE 3.5.5.

Manually editing knotifyrc:
Arts Init=true 
KNotify Init=true 
Use Arts=true

fixes the sound notify problem for kmail. If there is a patch, multiple reports and it's not committed, should we stop reporting these problems then?

Please, less eyecandy, more bug fixes.
Comment 11 Olivier Goffart 2007-11-16 17:27:59 UTC
KDE4 will use Phonon instead of artsd