Summary: | PATCH: Allow full paths when specifying --keytab= | ||
---|---|---|---|
Product: | [Applications] konsole | Reporter: | Kurt Hindenburg <khindenburg> |
Component: | general | Assignee: | Konsole Developer <konsole-devel> |
Status: | RESOLVED LATER | ||
Severity: | wishlist | ||
Priority: | NOR | ||
Version: | CVS | ||
Target Milestone: | --- | ||
Platform: | Compiled Sources | ||
OS: | Linux | ||
Latest Commit: | Version Fixed In: | ||
Sentry Crash Report: | |||
Attachments: |
Patch to allow full filenames in --keytab
Adds ability to use absolute filenames in --keytab=; also adds --keytabs Adds ability to use absolute filenames in --keytab=; also adds --keytabs code for --keytrans |
Description
Kurt Hindenburg
2004-04-23 21:13:51 UTC
Created attachment 5750 [details]
Patch to allow full filenames in --keytab
The QFile::encodeName should be done before QFile::exists already, and the QFile::exists should only be done if the file starts with a "/" IMHO. While you are at it, you may also wish to add a --keytabs option which lists all available keytabs, just like --schemas, --profiles and --types. Created attachment 6133 [details]
Adds ability to use absolute filenames in --keytab=; also adds --keytabs
The --keytabs is not entirely correct. The default keytab 'default.Keytab' is not listed as it is not a *.keytab file. This may confuse users when/if they try to find where XTerm (XFree 4.x.x) comes from... (i.e. I have 5 items in the Keyboard menu, and --keytabs only lists 4 files). Should I also include 'default.Keytab' in the list? Why is default.Keytab not default.keytab? The two "QString keytab = QFile::encodeName(keyTab);" lines are wrong and not needed at all. Instead, the line keytab = args->getOption("keytab"); should read: keytab = QFile::decodeName(args->getOption("keytab")); default.Keytab is a compiled-in default, it isn't actually read from disk and default.Keytab is only added for documentation purposes. Maybe it should be renamed to "default.keytab.readme" to make that more clear. I suggest to list it as "default", without .keytab or .Keytab Created attachment 6138 [details]
Adds ability to use absolute filenames in --keytab=; also adds --keytabs
.K. Here the new patch with the decodeName changes.
I added a message about using any other keytab string. IMHO using the
'buildin' as the default is a bug; konsole should use the 'default saved'.
I also think a warning should be printed if the given keytab is not found (ie.
--keytab thiskeytab).
But not with the bug report.
I think renaming default.Keytab to default.keytab.readme is a very good idea.
Created attachment 7711 [details]
code for --keytrans
This is half of this bug report; the --keytrans list. I'll do the other half
shortly.
Will look into this. Dropping this patch as it does not apply to the current version of Konsole (KDE 4) |