Bug 75995

Summary: samba and konqueror dont work, but samba works fine in terminal
Product: [Applications] konqueror Reporter: Jesse Ragsdale <jmr62>
Component: generalAssignee: Konqueror Developers <konq-bugs>
Severity: normal    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:

Description Jesse Ragsdale 2004-02-24 09:06:26 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
Compiler:          suse 9.0 
OS:          Linux

when i try to access samba so i can connect to other boxes running XP and enterprise server 2003 from suse 9.0, i can't - using konqueror, i get this error message:

Internal Error
Please send a full bug report at http://bugs.kde.org
libsmbclient reported an error, but didn't specify what the problem is. This might indicate a severe problem with your network - but also might indicate a problem with libsmbclient.
If you want to help us, please provide a tcpdump of the network interface while you try to browse (be aware that it might contain private data, so don't post it if you're unsure about that - you can send it privately to the developers if they ask for it)

a guy on linuxquestions.org tried to help me out.  apparently if i type in terminal:

smbclient -L servername -U username

it prompts me for a password to the account of the box, and i enter the password and i get all the info i need on both boxes, so i presume samba is set up correctly in some aspects.  i can access the internet just fine from suse 9.0 but not the network.  help?
Comment 1 Stephan Kulow 2004-02-24 10:56:51 UTC
most often this error is about wrong setup DNS, e.g. some server got a different IP when you look the name up over netbios than over DNS/hosts.

*** This bug has been marked as a duplicate of 66381 ***
Comment 2 Jesse Ragsdale 2004-03-10 12:07:24 UTC
ok, so what should i be doing? I don't know how to tweak samba.  i've gotten it running without a problem in red hat 9 and mandrake. I never had to do a thing, it just worked right off the bat. i'd really appreciate any help here.

Comment 3 juanS 2004-06-02 04:32:46 UTC
I dont underStund the solution for this Bug, anyone can explain me better? Mi email is jgarbora@adinet.com.uy

No entiendo la solucion de este bug, alguien me puede explicar mas claro ? mi email es jgarbora@adinet.com.uy

Thanks / Gracias

Comment 4 Raúl 2007-02-27 16:16:10 UTC
JuanS. It was not a bug, it was a configuration problem. You should ask for samba support elsewhere, after reading the doc: http://wiki.samba.org/index.php/Main_Page