Bug 482970

Summary: Auto hide not working when primary screen is changed
Product: [Plasma] KScreen Reporter: Edvinas <edvinasbureika>
Component: commonAssignee: kscreen-bugs-null <kscreen-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: normal CC: nate
Priority: NOR    
Version: 6.0.1   
Target Milestone: ---   
Platform: Arch Linux   
OS: Linux   
Latest Commit: Version Fixed In:

Description Edvinas 2024-03-09 11:55:40 UTC
SUMMARY

I have a laptop and when I plug an external monitor in and set it as a primary display the panel auto hide/dodge windows feature does not work, the panel simply stays up. It does however work if the primary screen does not change.

STEPS TO REPRODUCE

1. Set the visibility of the panel to dodge windows or auto hide
2. Plug in an external monitor
3. Set the external monitor to be primary

OBSERVED RESULT

The auto hide/dodge active windows feature will not work, panel will be visible at all times.

EXPECTED RESULT

The panel has to dodge windows/auto hide.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma:  Arch linux 6.7.8-arch1-1 (64 bit)/KDE plasma 6.0.1 wayland
KDE Plasma Version: 6.0.1
KDE Frameworks Version: 6.0.0
Qt Version:  6.6.2
Comment 1 Nate Graham 2024-03-11 22:40:46 UTC
Is your auto-hide panel located on a screen edge that then becomes a shared edge with the newly-plugged-in external screen?
Comment 2 Edvinas 2024-03-11 23:57:26 UTC
(In reply to Nate Graham from comment #1)
> Is your auto-hide panel located on a screen edge that then becomes a shared
> edge with the newly-plugged-in external screen?

Yes. My laptop monitor is at the bottom and external is at the top, the panel moves to the external monitor. Forgot to mention that.
Comment 3 Nate Graham 2024-03-11 23:59:40 UTC
Thanks, that was relevant! This makes it a duplicate of Bug 351175, which was just fixed a few days ago for plasma 6.1.

*** This bug has been marked as a duplicate of bug 351175 ***