Bug 481363

Summary: No button to record the screen before taking a screenshot in Spectacle
Product: [Applications] Spectacle Reporter: Alessandro Astone <ales.astone>
Component: GeneralAssignee: Noah Davis <noahadvs>
Status: RESOLVED DUPLICATE    
Severity: normal CC: kde, nate, olib141
Priority: NOR Keywords: qt6
Version: unspecified   
Target Milestone: ---   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In:

Description Alessandro Astone 2024-02-15 12:56:55 UTC
SUMMARY
When configuring Spectacle to not take a screenshot on launch, there is no part of the UI to start a screen recording.
You have to first take a screenshot, and in the next page there is a Recording tab on the right.


STEPS TO REPRODUCE
1. Configure...
2. When launching Spectacle: Do not take a screenshot automatically
3. Close Spectacle
4. Start Spectacle

OBSERVED RESULT
There are only buttons to take a screenshot, but nowhere to start a recording.

EXPECTED RESULT
A section of the UI to start a recording

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: Fedora Rawhide KDE
(available in About System)
KDE Plasma Version: 5.93.0
KDE Frameworks Version: 5.249.0
Qt Version: 6.6.1

ADDITIONAL INFORMATION
This is the same in 24.01.95 and 23.08.4
Comment 1 Oliver Beard 2024-02-15 14:18:27 UTC
I believe the best solution here is to make the UI in this mode use the normal UI, and show the left view empty with no screenshot present. There might be assumptions in the code that it always contains a screenshot that might need to be addressed.

If we remove the option to not take a screenshot on launch, this may combine undesirably with the option to always save after taking a screenshot.
Comment 2 Nate Graham 2024-02-15 16:45:17 UTC

*** This bug has been marked as a duplicate of bug 468778 ***