Bug 480704

Summary: BIG CRASH AFTER LATEST UPDATE IN TESTING EDITION - 2024-02-01
Product: [KDE Neon] neon Reporter: Valter Mura <valtermura>
Component: Packages Testing EditionAssignee: Neon Bugs <neon-bugs>
Status: REOPENED ---    
Severity: crash CC: jr, neon-bugs, nicolas.fella, sitter, tagwerk19
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Neon   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: coredump info of sddm-greeter crash

Description Valter Mura 2024-02-01 21:19:01 UTC
SUMMARY
***
After executing the latest update, the system log in only in command line mode, because unable to login in Graphical mode, and returns the following error(s):

1st error) with pkcon update command >>> Irreversible error: Error while installing package: trying overwriting "usr/share/kwin/tabbox/thumbnail_grid/contents/ui/main.qml" present also in package kwin-addons 4

2nd error)  with sudo apt full-upgrade >>> The following packages have unmet dependencies: 
breeze : Depends: kde-style-breeze (= 4:5.27.8+p22.04+vstable+git20240109.0024-0) but version 4:5.91.90+p22.04+vstable+git20240130.0024-0 is installed
                Depends: kwin-style-breeze (= 4:5.27.8+p22.04+vstable+git20240109.0024-0) but version 4:5.91.90+p22.04+vstable+git20240130.0024-0 is installed
kwin-addons : Depends: kdeplasma-addons-data (= 4:5.27.10+p22.04+vstable+git20240108.1453-0) but version 4:5.91.90+p22.04+vstable+git20240201.0354-0 is installed
kwin-common : Depends: kwin-data = 4:5.27.10+p22.04+vstable+git20240108.1356-0) but version 4:5.91.90+p22.04+vstable+git20240201.354-0 is installed
plasma-workspace-wayland : Depends: plasma-workspace (= 4:5.27.10+p22.04+vstable+git20240108.1426-0) but version 4:5.91.90+p22.04+vstable+git20240130.0024-0 is installed

I tried also to execute the suggestion, i.e. try "apt --fix-broken install" but nothing happened.

I need your help in order to fix the errors and make the system working again.
Comment 1 tagwerk19 2024-02-02 19:18:29 UTC
Confirming....

Install of neon-testing-20240102-0250.iso (on BTRFS, in a KVM guest)
sudo pkcon refresh; sudo pkcon update

As above, no SDDM, possible to get a text console with <Ctrl><Alt>F3
Comment 2 tagwerk19 2024-02-06 17:47:42 UTC
(In reply to Valter Mura from comment #0)
> ...  Error while installing package: trying overwriting
> "usr/share/kwin/tabbox/thumbnail_grid/contents/ui/main.qml" present also in
> package kwin-addons 4
I'm still getting this ...
... Is there a workround?
Comment 3 Valter Mura 2024-02-06 19:49:57 UTC
UPDATE - I tried to launch "apt ---fix-broken install" as suggested by apt application, and I got the following error:

Extracting of kwin-common (4:5.91.90+p22.04+vstable+git20240201.0354-0) on (4.5.27.10+p22.04+vstable+git20240108.1356-0)...
dpkg: error elaborating archive "/var/cache/apt/archives/kwin-common_4%3a5.91.90+p22.04+vstable+git20240201.0354-0_amd64.deb (--unpack):
   trying overwriting "/usr/share/kwin/tabbox/thumbnail_grid/contents/ui/main.qml" present also in package kwin-addons 4:5.27.10+p22.04+vstable+git20240108.1453-0
dpkg-deb:  error: the sub-process paste has been terminated by signal (Pipe aborted)
Errors occurred in the processing:
/var/cache/apt/archives/kwin-common_4%3a5.91.90+p22.04+vstable+git20240201.0354-0_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I/We need help to solve this problem, the system is stucked and cannot update. Also cannot login in Graphical mode, I need to login after a Ctrl+Alt+F3 in CL mode.
Comment 4 Jonathan Riddell 2024-02-06 20:29:21 UTC
I added a breaks/replaces so apt should sort this once built
https://invent.kde.org/neon/kde/kwin/-/commit/2d57e3d9e08e068f876e25929905b005b7288525

or you can remove kwin-addons
Comment 5 tagwerk19 2024-02-07 07:04:06 UTC
(In reply to Jonathan Riddell from comment #4)
> I added a breaks/replaces so apt should sort this once built
> https://invent.kde.org/neon/kde/kwin/-/commit/
> 2d57e3d9e08e068f876e25929905b005b7288525
> 
> or you can remove kwin-addons
The "pkcon update" moves past the thumbnail grid, kwin-addons now but stumbles on
    '/usr/share/config.kcfg/jpegcreatorsettings5.kcfg', which is also in package kio-extras-data
No cut and paste, hopefully no typos...

Reopen or a New Issue? I've reopened....
Comment 6 tagwerk19 2024-02-07 09:39:25 UTC
(In reply to tagwerk19 from comment #5)
> The "pkcon update" moves past the thumbnail grid, kwin-addons now but
> stumbles on
>     '/usr/share/config.kcfg/jpegcreatorsettings5.kcfg', which is also in
> package kio-extras-data
If I repeat the update, I get ...

Error while installing package: trying to overwrite '/usr/share/doc/HTML/ca/kioslave5/bzip2/index.cache.bz2', which is also in package kio-extras-data 4
Comment 7 Jonathan Riddell 2024-02-07 09:50:53 UTC
Thanks for reporting this valuable information.  

I've added versioned breaks to kio-extras5 for the files which moved from the old packages there
https://invent.kde.org/neon/neon-packaging/kio-extras5/-/commit/48a5773f5ddaa490ac0056048846b8e5ca6b19b6

(Note we have extra QA on User edition which will catch this but for testing edition we are more reliable on helpful testers like you)
Comment 8 Jonathan Riddell 2024-02-07 09:52:33 UTC
That should also sort the jpegcreatorsettings5.kcfg issue too.  Let me know if you have further issues.
Comment 9 tagwerk19 2024-02-07 18:00:32 UTC
(In reply to Jonathan Riddell from comment #7)
> Note we have extra QA on User edition which will catch this but for testing edition ...
That's valuable information.

I've generally held off reporting these as I thought I'd be just "adding noise". Now I know :-)
Comment 10 Valter Mura 2024-02-07 22:57:16 UTC
Hi
I reopen because I tried to update, first I gave pkcon refresh and then pkcon update. I got the following error:
Irreversible error: Error while installing package: trying overwriting "usr/share/kxmlgui5/plasmadiscover/plasmadiscoverui.rc" present also in package plasma-discover-common 5.27.10+p22.04+vstable+git20240109.0243-0

So I rebooted, gave again pkcon refresh && update. The system discharge again packages and gave another error:
Irreversible error: Error while installing package: trying overwriting "usr/share/config.kcfg/jpegcreatorsettings5.kcfg" present also in package kio-extras-data 4
(all errors written by hand, so I apologise if there is some error)

Then I stopped and shutdown the machine, waiting for another update.
Comment 11 Jonathan Riddell 2024-02-08 10:07:03 UTC
I've added the breaks/replaces for the plasma-discover package now thanks
https://invent.kde.org/neon/kde/plasma-discover/-/commit/1856a791b2a504d433aafc673adfdeea50ed11e2
Comment 12 Jonathan Riddell 2024-02-08 10:13:40 UTC
https://invent.kde.org/neon/kde/kio-extras/-/commit/576d5b6aa66a27d13644ba29cdbf734af607d0b3
Also added for kio-extras too, let me know how that works
Comment 13 tagwerk19 2024-02-08 10:58:57 UTC
Edging forward ...
    ... now:
    Error while installing package: trying to overwrite '/usr/lib/x86_64-linux-gnu/libkdsoap.so.2.1.1', which is also in package libkdsoap2

Having an ssh connection to the machine gives you back cut-and-paste :-)
Comment 14 Jonathan Riddell 2024-02-08 11:32:12 UTC
New kdsoap5 built which should fix it

Keep them coming..
Comment 15 tagwerk19 2024-02-08 11:51:18 UTC
(In reply to Jonathan Riddell from comment #14)
> Keep them coming..

pkcon at 100% CPU for 10 minutes or so...

    Proceed with changes? [N/y] y

                                            [=========================]         
    Updating packages                       [=========================]         
    Loading cache                           [=========================]         
    Downloading packages                    [=========================]         
    Running                                 [=========================]         
    Removing packages                       [=========                ] (36%)   
    Installing packages                     [=========================]         
    Removing packages                       [=========================]         
    Installing packages                     [=========================]         
    Removing packages                       [=========================]         
    Installing packages                     [=========================]         
    Removing packages                       [=========================]         
    Installing packages                     [=======                  ] (29%)  

And then:
    Error while installing package: trying to overwrite '/usr/bin/baloo_filemetadata_temp_extractor', which is also in package libkf5baloowidgets-bin 4
Comment 16 Jonathan Riddell 2024-02-08 13:24:24 UTC
I removed the baloo-widgets-5 packages and added a breaks... one more try!
Comment 17 tagwerk19 2024-02-08 17:30:26 UTC
(In reply to Jonathan Riddell from comment #16)
> I removed the baloo-widgets-5 packages and added a breaks... one more try!
I think we are getting close, I now have an SDDM logon (*) and a Plasma 6 desktop. Now, it's just a:

    Error while installing package: trying to overwrite '/usr/bin/baloo_filemetadata_temp_extractor', which is also in package libkf5baloowidgets-bin 4

OK, the SDDM logon doesn't accept an enter after the password. I know that's reported elsewhere, I'll see if I can find it...
Comment 18 tagwerk19 2024-02-08 17:33:31 UTC
(In reply to tagwerk19 from comment #17)
> OK, the SDDM logon doesn't accept an enter after the password. I know that's
> reported elsewhere, I'll see if I can find it...
... Bug 478875
Comment 19 Valter Mura 2024-02-08 19:07:11 UTC
Hi, nothing new. Now I get:

Irreversible error: Error while installing package: trying overwriting "usr/share/locale/ar/LC_MESSAGES/libtextautocorrection.mo" present also in package libkf5textaddons-data 1.5.2+p22.04+vstable+git20240109.0209-0

(errors written by hand, so I apologise if there is something wrong)
Comment 20 Jonathan Riddell 2024-02-08 20:13:50 UTC
https://invent.kde.org/neon/kf6/kf6-ktextaddons/-/commit/931668620bbbef9301f540ac737ca2176ad20eac
'breaks libkf5textaddons-data for moved libtextautocorrection.mo'
Comment 21 Valter Mura 2024-02-10 17:45:02 UTC
HI,
ok, the system now restarted, but returns the following error:
"Aggiornamento di 1 pacchetto non riuscito
Error while installing package: trying to overwrite '/usr/share/locale/ar/LC_MESSAGES/libtextautocorrection.mo', which is also in package libkf5textaddons-data 1.5.2+p22.04+vstable+git20240109.0209-0"

Now, many things don't work, for example:
- Firefox doesn't have Icon
- Widgets don't work, returning the error: "This widget was written for an unknown older version of Plasma and is not compatible with Plasma 6. Please contact the widget's author for an updated version.Error loading applet: Package does not exist." (unknown widget); and "This widget was written for an unknown older version of Plasma and is not compatible with Plasma 6. Contact the author of the widget for an updated version." (Weather Widget and Key State); for System Monitor widget, no sensor is available.
- Lokalize crashes; KDEsvn crashes

I attach a screenshot of my desktop

My present system:
Operating System: KDE neon Testing Edition
KDE Plasma Version: 6.0.0
KDE Frameworks Version: 6.0.0
Qt Version: 6.6.1
Kernel Version: 6.5.0-14-generic (64-bit)
Graphics Platform: Wayland
Graphics Processor: NVE7
Comment 22 tagwerk19 2024-02-11 10:18:25 UTC
(In reply to Valter Mura from comment #21)
> Error while installing package: trying to overwrite
> '/usr/share/locale/ar/LC_MESSAGES/libtextautocorrection.mo', which is also
> in package libkf5textaddons-data 1.5.2+p22.04+vstable+git20240109.0209-0"
I get something similar:
    Error while installing package: trying to overwrite '/usr/share/locale/ar/LC_MESSAGES/baloowidgets5.mo', which is
    also in package libkf5baloowidgets5

Apologies, I thought I had posted this but it looks like I hadn't :-/
Comment 23 tagwerk19 2024-02-16 12:11:02 UTC
A little further, now stumbling at:

    Error while installing package: trying to overwrite '/usr/share/applications/kde-mimeapps.list',
    which is also in package neon-settings-2 0.4+p22.04+vstable+git20240125.1041

I think this is being tracked in Bug 481364
Comment 24 Valter Mura 2024-02-16 22:54:59 UTC
(In reply to Valter Mura from comment #21)
> HI,
> ok, the system now restarted, but returns the following error:
> "Aggiornamento di 1 pacchetto non riuscito
> Error while installing package: trying to overwrite
> '/usr/share/locale/ar/LC_MESSAGES/libtextautocorrection.mo', which is also
> in package libkf5textaddons-data 1.5.2+p22.04+vstable+git20240109.0209-0"
> 
> Now, many things don't work, for example:
> - Firefox doesn't have Icon
> - Widgets don't work, returning the error: "This widget was written for an
> unknown older version of Plasma and is not compatible with Plasma 6. Please
> contact the widget's author for an updated version.Error loading applet:
> Package does not exist." (unknown widget); and "This widget was written for
> an unknown older version of Plasma and is not compatible with Plasma 6.
> Contact the author of the widget for an updated version." (Weather Widget
> and Key State); for System Monitor widget, no sensor is available.
> - Lokalize crashes; KDEsvn crashes
> 
> I attach a screenshot of my desktop
> 
> My present system:
> Operating System: KDE neon Testing Edition
> KDE Plasma Version: 6.0.0
> KDE Frameworks Version: 6.0.0
> Qt Version: 6.6.1
> Kernel Version: 6.5.0-14-generic (64-bit)
> Graphics Platform: Wayland
> Graphics Processor: NVE7

I'm still stuck in this error... I can't go further... I don't know if there's a workaround.
Comment 25 Valter Mura 2024-02-16 23:03:27 UTC
I also tried "apt-get --check" and I got the following:

The following packages has unmet dependencies:
 kpim6-akonadi-contacts : Depends: kf6-ktextaddons (>= 0.0.1+p22.04+vstable+git20240206.0340) but it is not installed
 kpim6-kidentitymanagement : Depends: kf6-ktextaddons (>= 0.0.1+p22.04+vstable+git20240208.0427) but it is not installed
 kpim6-kpimtextedit : Depends: kf6-ktextaddons (>= 0.0.1+p22.04+vstable+git20240206.0340) but it is not installed
 kpim6-libkleo : Depends: kf6-ktextaddons (>= 0.0.1+p22.04+vstable+git20240208.0427) but it is not installed
 libsasl2-modules-kdexoauth2 : Depends: libkpimgapi5-data but it is not installed

So, I tried, again, to give the command "apt --fix-broken-install" and I got the following errors (in Italian, sorry, I cannot now translate the strings):

Preparativi per estrarre .../kf6-ktextaddons_0.0.1+p22.04+vstable+git20240215.0159-0_amd64.deb...
Estrazione di kf6-ktextaddons (0.0.1+p22.04+vstable+git20240215.0159-0)...
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/kf6-ktextaddons_0.0.1+p22.04+vstable+git20240215.0159-0_amd64.deb (--unpack):
 tentata sovrascrittura di "/usr/share/locale/ar/LC_MESSAGES/libtextautocorrection.mo" presente anche nel pacchetto libkf5textaddons-data 1.5.2+p22.04+vstable+git20240109.0209-0
dpkg-deb: errore: il sottoprocesso paste è stato terminato dal segnale (Pipe interrotta)
Preparativi per estrarre .../libkpimgapi5-data_23.08.4+p22.04+vstable+git20240207.0942-0_all.deb...
Estrazione di libkpimgapi5-data (23.08.4+p22.04+vstable+git20240207.0942-0)...
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libkpimgapi5-data_23.08.4+p22.04+vstable+git20240207.0942-0_all.deb (--unpack):
 tentata sovrascrittura di "/usr/share/locale/ar/LC_MESSAGES/libkgapi_qt.qm" presente anche nel pacchetto libkpimgapi-data 23.08.4+p22.04+vstable+git20240108.0456-0
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/kf6-ktextaddons_0.0.1+p22.04+vstable+git20240215.0159-0_amd64.deb
 /var/cache/apt/archives/libkpimgapi5-data_23.08.4+p22.04+vstable+git20240207.0942-0_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Comment 26 Valter Mura 2024-02-17 17:04:47 UTC
Another error:
/var/cache/apt/archives/kpim6-kldap_23.08.4+p22.04+vstable+git20240214.0131-0_amd64.deb
trying to overwrite '/usr/share/locale/af/LC_MESSAGES/kio_ldap.mo', which is also in package kio-ldap 23.08.4+p22.04+vstable+git20240108.0428-0

/var/cache/apt/archives/kf6-ktextaddons_0.0.1+p22.04+vstable+git20240215.0159-0_amd64.deb
trying to overwrite '/usr/share/locale/ar/LC_MESSAGES/libtextautocorrection.mo', which is also in package libkf5textaddons-data 1.5.2+p22.04+vstable+git20240109.0209-0
Comment 27 Valter Mura 2024-02-18 20:28:28 UTC
And after rebooting, the system doesn't update and a notification appears:
"Unable to update 1 package
Error while installing package: trying to overwrite '/usr/share/locale/ar/LC_MESSAGES/libtextautocorrection.mo', which is also in package libkf5textaddons-data 1.5.2+p22.04+vstable+git20240109.0209-0"

So, please tell me if there's a workaround or I have to wait for some new update.
Presently my system is:
Operating System: KDE neon Testing Edition
KDE Plasma Version: 6.0.0
KDE Frameworks Version: 6.0.0
Qt Version: 6.6.1
Kernel Version: 6.5.0-14-generic (64-bit)
Graphics Platform: Wayland
Graphics Processor: NVE7
Comment 29 Valter Mura 2024-02-20 11:18:18 UTC
Sorry Jonathan, but again, after updating through Discover and rebooting:

Aggiornamento di 1 pacchetto non riuscito
Error while installing package: trying to overwrite '/usr/share/locale/ar/LC_MESSAGES/libtextautocorrection.mo', which is also in package libkf5textaddons-data 1.5.2+p22.04+vstable+git20240109.0209-0 

The system doesn't update.

Also, if I try to pkcon refresh && update, the app freezes and stays "running" without doing anything. This is reason for me to reopen the bug report. Maybe there's something wrong with my own system...
I will try now to use apt and see if there are more warnings.
Comment 30 Valter Mura 2024-02-20 11:26:46 UTC
And this is what I get if I use the "apt-get full-upgrade" command:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 kaddressbook : Dipende: kf6-kparts (>= 5.245.0+p22.04+vstable+git20240211.0136) ma la versione 5.245.0+p22.04+vstable+git20240206.0339-0 è installata
                Dipende: kf6-kuserfeedback (>= 5.245.0+p22.04+vstable+git20240210.0021) ma la versione 5.245.0+p22.04+vstable+git20240206.2042-0 è installata
                Dipende: kpim6-kontactinterface (>= 23.08.4+p22.04+vstable+git20240206.0421) ma non è installato
                Dipende: kpim6-libkdepim (>= 4:23.08.4+p22.04+vstable+git20240204.0022) ma non è installato
                Dipende: kpim6-pimcommon (>= 4:23.08.4+p22.04+vstable+git20240212.0340) ma non è installato
 knotes : Dipende: kpim6-kdepim-runtime ma non è installato
          Dipende: kf6-kparts (>= 5.245.0+p22.04+vstable+git20240211.0136) ma la versione 5.245.0+p22.04+vstable+git20240206.0339-0 è installata
          Dipende: kf6-kstatusnotifieritem (>= 5.245.0+p22.04+vstable+git20240215.0108) ma la versione 5.245.0+p22.04+vstable+git20240208.0405-0 è installata
          Dipende: kf6-ktextaddons (>= 0.0.1+p22.04+vstable+git20240215.0159) ma non è installato
          Dipende: kpim6-kcalendarutils (>= 4:23.08.4+p22.04+vstable+git20240214.0022) ma non è installato
          Dipende: kpim6-kontactinterface (>= 23.08.4+p22.04+vstable+git20240206.0421) ma non è installato
          Dipende: kpim6-pimcommon (>= 4:23.08.4+p22.04+vstable+git20240212.0340) ma non è installato
 kontact : Dipende: kpim6-kdepim-runtime ma non è installato
           Dipende: kf6-kparts (>= 5.245.0+p22.04+vstable+git20240211.0136) ma la versione 5.245.0+p22.04+vstable+git20240206.0339-0 è installata
           Dipende: kpim6-kontactinterface (>= 23.08.4+p22.04+vstable+git20240206.0421) ma non è installato
           Dipende: kpim6-libkdepim (>= 4:23.08.4+p22.04+vstable+git20240204.0022) ma non è installato
           Dipende: kpim6-pimcommon (>= 4:23.08.4+p22.04+vstable+git20240212.0340) ma non è installato
           Raccomanda: accountwizard ma non è installato
           Raccomanda: akregator ma non è installato
           Raccomanda: kmail ma non è installato
 korganizer : Dipende: kpim6-kdepim-runtime ma non è installato
              Dipende: kf6-kholidays (>= 5.245.0+p22.04+vstable+git20240209.0105) ma la versione 5.245.0+p22.04+vstable+git20240207.1032-0 è installata
              Dipende: kf6-kparts (>= 5.245.0+p22.04+vstable+git20240211.0136) ma la versione 5.245.0+p22.04+vstable+git20240206.0339-0 è installata
              Dipende: kf6-kuserfeedback (>= 5.245.0+p22.04+vstable+git20240210.0021) ma la versione 5.245.0+p22.04+vstable+git20240206.2042-0 è installata
              Dipende: kpim6-akonadi-calendar (>= 4:23.08.4+p22.04+vstable+git20240216.0132) ma non è installato
              Dipende: kpim6-calendarsupport (>= 4:23.08.4+p22.04+vstable+git20240206.0947) ma non è installato
              Dipende: kpim6-eventviews (>= 4:23.08.4+p22.04+vstable+git20240208.0658) ma non è installato
              Dipende: kpim6-incidenceeditor (>= 23.08.4+p22.04+vstable+git20240212.0026) ma non è installato
              Dipende: kpim6-kcalendarutils (>= 4:23.08.4+p22.04+vstable+git20240214.0022) ma non è installato
              Dipende: kpim6-kidentitymanagement (>= 23.08.4+p22.04+vstable+git20240212.0303) ma la versione 23.08.4+p22.04+vstable+git20240208.0637-0 è installata
              Dipende: kpim6-kmailtransport (>= 23.08.4+p22.04+vstable+git20240215.0313) ma non è installato
              Dipende: kpim6-kontactinterface (>= 23.08.4+p22.04+vstable+git20240206.0421) ma non è installato
              Dipende: kpim6-libkdepim (>= 4:23.08.4+p22.04+vstable+git20240204.0022) ma non è installato
              Dipende: kpim6-pimcommon (>= 4:23.08.4+p22.04+vstable+git20240212.0340) ma non è installato
 kpim6-akonadi-contacts : Dipende: kf6-ktextaddons (>= 0.0.1+p22.04+vstable+git20240212.0242) ma non è installato
 kpim6-akonadi-search : Dipende: kf6-ktextaddons (>= 0.0.1+p22.04+vstable+git20240208.0427) ma non è installato
 kpim6-kidentitymanagement : Dipende: kf6-ktextaddons (>= 0.0.1+p22.04+vstable+git20240208.0427) ma non è installato
 kpim6-kpimtextedit : Dipende: kf6-ktextaddons (>= 0.0.1+p22.04+vstable+git20240206.0340) ma non è installato
 kpim6-libkleo : Dipende: kf6-ktextaddons (>= 0.0.1+p22.04+vstable+git20240208.0427) ma non è installato
 libkf5declarative5-dbgsym : Dipende: libkf5declarative5 (= 5.115.0+p22.04+vstable+git20240210.1423-0) ma la versione 5.114.0+p22.04+vstable+git20240208.0706-0 è installata
 libkf5gravatar5 : Dipende: libkf5pimcommon5 (>= 4:23.08.1+p22.04+vstable+git20240108.1232)
 libkf5jobwidgets5 : Dipende: libkf5jobwidgets-data (= 5.114.0+p22.04+vstable+git20240206.1340-0) ma la versione 5.115.0+p22.04+vstable+git20240210.1319-0 è installata
 libkf5messagecore5 : Dipende: libkf5pimcommon5 (>= 4:23.08.1+p22.04+vstable+git20240108.1232)
 libkf5templateparser5 : Dipende: libkf5libkdepim5
 libsasl2-modules-kdexoauth2 : Dipende: libkpimgapi5-data ma non è installato

So, many dependencies are not met. The app, also, suggests me to use "apt --fix-broken install" without packages (o specifying a solution)
Comment 31 tagwerk19 2024-02-21 08:11:17 UTC
Tried a second Neon Testing image and had to "force-overwrite" a couple of times (after a Ctrl-Alt-F3)
    sudo dpkg -i --force-overwrite kwin-common_4%3a5.91.90+p22.04+vstable+git20240220.0137-0_amd64.deb
and then
    sudo dpkg -i --force-overwrite kf6-baloowidgets_4%3a23.08.5+p22.04+vstable+git20240219.1653-0_amd64.deb 

I'm not sure whether I'm trying to do delicate surgery with a felling axe, club hammer and chainsaw but I did get the SDDM logon screen back 8-)
Comment 32 Jonathan Riddell 2024-02-21 13:42:36 UTC
Valter Mura: I'm afraid I'm unable to help here, I think your system has some dbgsym packages installed which are not well handled, try removing e.g.  libkf5declarative5-dbgsym and the other pim 5 packages

tagwerk19: any other issues?
Comment 33 tagwerk19 2024-02-21 13:56:34 UTC
(In reply to Jonathan Riddell from comment #32)
> tagwerk19: any other issues?
Not since comment 31, I seem to be installing a stream of updates.

I snapshotted the system a couple of days back, I'm happy to roll back and check whether the updates work without manual intervention.
Comment 34 tagwerk19 2024-02-21 15:36:57 UTC
(In reply to tagwerk19 from comment #33)
> ... I snapshotted the system a couple of days back, I'm happy to roll back and
> check whether the updates work without manual intervention ...
I did, and it's clearly a moving target :-)

Here we are for completeness:

> The following packages have unmet dependencies:
>   qml-module-org-kde-runnermodel: Depends: libkf5runner5 but it is not going to be installed
Comment 35 tagwerk19 2024-02-22 21:15:23 UTC
And also (on another Neon Testing system)

Error while installing package: trying to overwrite '/usr/lib/x86_64-linux-gnu/libKirigami.so.6.0.0', which is also in package kf6-kirigami2 5.245.0+p22.04+vstable+git20240215.0120-0

I assume the order of things is not deteministic and different Neon Testing can give different results.
Comment 36 tagwerk19 2024-02-22 22:06:53 UTC
Created attachment 166028 [details]
coredump info of sddm-greeter crash
Comment 37 tagwerk19 2024-02-22 22:09:03 UTC
(In reply to tagwerk19 from comment #35)
> Error while installing package: trying to overwrite
>     '/usr/lib/x86_64-linux-gnu/libKirigami.so.6.0.0', which is also in package
>     kf6-kirigami2 5.245.0+p22.04+vstable+git20240215.0120-0
Since this I'm getting a 

    Feb 22 22:47:39 neon-dev systemd[723]: Starting Portal service (GTK/GNOME implementation)...
    Feb 22 22:47:39 neon-dev unknown[772]: cannot open display: 
    Feb 22 22:47:39 neon-dev systemd[723]: xdg-desktop-portal-gtk.service: Main process exited, code=exited, status=1/FAILURE
    Feb 22 22:47:39 neon-dev systemd[723]: xdg-desktop-portal-gtk.service: Failed with result 'exit-code'.
    Feb 22 22:47:39 neon-dev systemd[723]: Failed to start Portal service (GTK/GNOME implementation).
    Feb 22 22:47:39 neon-dev systemd-coredump[758]: Process 731 (sddm-greeter) of user 119 dumped core.
                                               
and I don't get an SDDM logon screen.  I've attached the coredumpctl info...
Comment 38 tagwerk19 2024-02-23 08:06:36 UTC
(In reply to tagwerk19 from comment #37)
> Since this I'm getting a 
> 
>     Feb 22 22:47:39 neon-dev systemd[723]: Starting Portal service
> (GTK/GNOME implementation)...
>     Feb 22 22:47:39 neon-dev unknown[772]: cannot open display: 
>     Feb 22 22:47:39 neon-dev systemd[723]: xdg-desktop-portal-gtk.service:
> Main process exited, code=exited, status=1/FAILURE
>     Feb 22 22:47:39 neon-dev systemd[723]: xdg-desktop-portal-gtk.service:
> Failed with result 'exit-code'.
>     Feb 22 22:47:39 neon-dev systemd[723]: Failed to start Portal service
> (GTK/GNOME implementation).
>     Feb 22 22:47:39 neon-dev systemd-coredump[758]: Process 731
> (sddm-greeter) of user 119 dumped core.
Opened a separate issue - Bug 481711
Comment 39 tagwerk19 2024-02-23 11:36:39 UTC
(In reply to tagwerk19 from comment #35)
> And also (on another Neon Testing system)
> 
> Error while installing package: trying to overwrite
> '/usr/lib/x86_64-linux-gnu/libKirigami.so.6.0.0', which is also in package
> kf6-kirigami2 5.245.0+p22.04+vstable+git20240215.0120-0
This seems to be solved...
    ... also the SDDM-Greeter issue
Comment 40 tagwerk19 2024-02-25 21:12:48 UTC
(In reply to tagwerk19 from comment #34)
> The following packages have unmet dependencies:
>   qml-module-org-kde-runnermodel: Depends: libkf5runner5 but it is not going to be installed
Still hitting this one...