Bug 479866

Summary: Window borders with fractional scaling
Product: [Plasma] kwin Reporter: Michel Le Bihan <michel>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: normal CC: kde, nate
Priority: NOR Keywords: qt6
Version: 5.92.0   
Target Milestone: ---   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: Dolphin 125%
System Monitor 125%

Description Michel Le Bihan 2024-01-15 21:07:58 UTC
Created attachment 164930 [details]
Dolphin 125%

SUMMARY
Some windows have a strange border with fractional scaling.


STEPS TO REPRODUCE
1. Set scaling to 125%
2. Open Dolphin or System Monitor
3. Notice that there is a borer at the bottom and on the right of the window
4. Set scaling to 100% or 200%
5. Open Dolphin or System Monitor
6. Notice that those apps don't have a border

OBSERVED RESULT
Some windows have a strange border with fractional scaling.

EXPECTED RESULT
Whether a window has a border or not should not depend on whether fractional scaling is enabled. (the border probably shouldn't be there)

SOFTWARE/OS VERSIONS
Operating System: Fedora Linux 40
KDE Plasma Version: 5.92.0
KDE Frameworks Version: 5.248.0
Qt Version: 6.6.1
Kernel Version: 6.8.0-0.rc0.20240112git70d201a40823.5.fc40.x86_64 (64-bit)
Graphics Platform: Wayland
Processors: 8 × 11th Gen Intel® Core™ i5-1135G7 @ 2.40GHz
Memory: 15.3 GiB of RAM
Graphics Processor: Mesa Intel® Xe Graphics
Manufacturer: LENOVO
Product Name: 20TA000EPB
System Version: ThinkPad E14 Gen 2

ADDITIONAL INFORMATION
Please see the screenshots
Comment 1 Michel Le Bihan 2024-01-15 21:08:23 UTC
Created attachment 164931 [details]
System Monitor 125%
Comment 2 Nate Graham 2024-01-17 15:40:05 UTC

*** This bug has been marked as a duplicate of bug 462005 ***
Comment 3 Michel Le Bihan 2024-01-17 16:41:39 UTC
Hmm. I see that bug 462005 is fixed. In what version of Breeze will the fix be?
Comment 4 Nate Graham 2024-01-17 16:49:48 UTC
6.0, as the "Version Fixed In" field in that bug report says.
Comment 5 Michel Le Bihan 2024-01-17 17:38:24 UTC
Well, I was using `5.92.0`, so the fix should have been there.
Comment 6 Nate Graham 2024-01-17 22:54:44 UTC
Aha, it's not in fact fixed. Will re-open the other one.