Bug 471431

Summary: kded5 crash on system update
Product: [Applications] systemsettings Reporter: petrk <pepko94>
Component: kcm_touchpadAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: normal CC: kdelibs-bugs, natalie_clarius, nicolas.fella
Priority: NOR    
Version: 5.27.6   
Target Milestone: ---   
Platform: Arch Linux   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: segfault details with backtrace

Description petrk 2023-06-25 10:56:18 UTC
Created attachment 159889 [details]
segfault details with backtrace

It seems that often when I update my system kded5 decides to segfault.

Details from package manager on what was updated:
[2023-06-25T11:32:56+0100] [ALPM] upgraded aalib (1.4rc5-16 -> 1.4rc5-17)
[2023-06-25T11:32:56+0100] [ALPM] upgraded btrfs-progs (6.3.1-1 -> 6.3.2-1)
[2023-06-25T11:32:56+0100] [ALPM] upgraded libcups (1:2.4.5-1 -> 1:2.4.6-1)
[2023-06-25T11:32:56+0100] [ALPM] upgraded libssh2 (1.10.0-3 -> 1.11.0-1)
[2023-06-25T11:32:56+0100] [ALPM] upgraded libpng (1.6.39-1 -> 1.6.40-1)
[2023-06-25T11:32:56+0100] [ALPM] upgraded cups (1:2.4.5-1 -> 1:2.4.6-1)
[2023-06-25T11:32:56+0100] [ALPM] upgraded mesa (23.1.2-1 -> 23.1.3-1)
[2023-06-25T11:32:56+0100] [ALPM] upgraded sdl2 (2.26.5-2 -> 2.28.0-1)
[2023-06-25T11:32:56+0100] [ALPM] upgraded flac (1.4.2-1 -> 1.4.3-1)
[2023-06-25T11:32:56+0100] [ALPM] upgraded libopenmpt (0.7.1-1 -> 0.7.2-1)
[2023-06-25T11:32:56+0100] [ALPM] upgraded darktable (2:4.2.1-6 -> 2:4.4.0-1)
[2023-06-25T11:32:57+0100] [ALPM] upgraded electron25 (25.1.1-3 -> 25.2.0-2)
[2023-06-25T11:32:57+0100] [ALPM] upgraded lib32-brotli (1.0.9-5 -> 1.0.9-12)
[2023-06-25T11:32:57+0100] [ALPM] upgraded lib32-flac (1.4.2-1 -> 1.4.3-1)
[2023-06-25T11:32:57+0100] [ALPM] upgraded lib32-libpng (1.6.39-1 -> 1.6.40-1)
[2023-06-25T11:32:57+0100] [ALPM] upgraded lib32-libcups (2.4.4-1 -> 2.4.6-1)
[2023-06-25T11:32:57+0100] [ALPM] upgraded lib32-libssh2 (1.10.0-2 -> 1.11.0-1)
[2023-06-25T11:32:57+0100] [ALPM] upgraded lib32-nvidia-utils (535.54.03-1 -> 535.54.03-2)
[2023-06-25T11:32:57+0100] [ALPM] upgraded lib32-mesa (23.1.2-1 -> 23.1.3-1)
[2023-06-25T11:32:57+0100] [ALPM] upgraded lib32-mesa-vdpau (23.1.2-1 -> 23.1.3-1)
[2023-06-25T11:32:57+0100] [ALPM] upgraded lib32-opencl-nvidia (535.54.03-1 -> 535.54.03-2)
[2023-06-25T11:32:57+0100] [ALPM] upgraded lib32-sdl2 (2.26.5-1 -> 2.28.0-1)
[2023-06-25T11:32:57+0100] [ALPM] upgraded vulkan-mesa-layers (23.1.2-1 -> 23.1.3-1)
[2023-06-25T11:32:57+0100] [ALPM] upgraded lib32-vulkan-mesa-layers (23.1.2-1 -> 23.1.3-1)
[2023-06-25T11:32:57+0100] [ALPM] upgraded vulkan-radeon (23.1.2-1 -> 23.1.3-1)
[2023-06-25T11:32:57+0100] [ALPM] upgraded lib32-vulkan-radeon (23.1.2-1 -> 23.1.3-1)
[2023-06-25T11:32:57+0100] [ALPM] upgraded lib32-vulkan-virtio (23.1.2-1 -> 23.1.3-1)
[2023-06-25T11:32:57+0100] [ALPM] upgraded libva-mesa-driver (23.1.2-1 -> 23.1.3-1)
[2023-06-25T11:32:57+0100] [ALPM] upgraded libzip (1.9.2-1 -> 1.10.0-1)
[2023-06-25T11:32:58+0100] [ALPM] upgraded linux-zen (6.3.8.zen1-1 -> 6.3.9.zen1-1)
[2023-06-25T11:33:01+0100] [ALPM] upgraded linux-zen-headers (6.3.8.zen1-1 -> 6.3.9.zen1-1)
[2023-06-25T11:33:01+0100] [ALPM] upgraded mesa-vdpau (23.1.2-1 -> 23.1.3-1)
[2023-06-25T11:33:01+0100] [ALPM] upgraded ostree (2023.3-1 -> 2023.4-1)
[2023-06-25T11:33:01+0100] [ALPM] upgraded qt5-base (5.15.10+kde+r129-1 -> 5.15.10+kde+r129-3)
[2023-06-25T11:33:01+0100] [ALPM] upgraded powerdevil (5.27.6-1 -> 5.27.6-3)
[2023-06-25T11:33:03+0100] [ALPM] upgraded pycharm-community-edition (2023.1.2-1 -> 2023.1.3-1)
[2023-06-25T11:33:03+0100] [ALPM] upgraded python-cryptography (40.0.2-1 -> 41.0.1-2)
[2023-06-25T11:33:03+0100] [ALPM] upgraded python-google-auth (2.17.3-1 -> 2.18.0-1)
[2023-06-25T11:33:03+0100] [ALPM] upgraded python-googleapis-common-protos (1.59.0-2 -> 1.59.1-1)
[2023-06-25T11:33:03+0100] [ALPM] upgraded python-pytest (7.3.2-1 -> 7.4.0-1)
[2023-06-25T11:33:03+0100] [ALPM] upgraded python-sentry_sdk (1.25.1-1 -> 1.26.0-1)
[2023-06-25T11:33:03+0100] [ALPM] upgraded python-setuptools (1:67.8.0-1 -> 1:68.0.0-1)
[2023-06-25T11:33:03+0100] [ALPM] upgraded qt6-base (6.5.1-2 -> 6.5.1-4)
[2023-06-25T11:33:03+0100] [ALPM] upgraded sddm (0.19.0-9 -> 0.20.0-1)
[2023-06-25T11:33:03+0100] [ALPM] upgraded vulkan-virtio (23.1.2-1 -> 23.1.3-1)
[2023-06-25T11:33:03+0100] [ALPM] upgraded wolfssl (5.6.2-1 -> 5.6.3-1)
[2023-06-25T11:33:03+0100] [ALPM] upgraded yt-dlp (2023.06.21-1 -> 2023.06.22-1)
Comment 1 petrk 2023-06-25 10:59:02 UTC
#0  __pthread_kill_implementation (threadid=<optimized out>, signo=signo@entry=11, no_tid=no_tid@entry=0)
    at pthread_kill.c:44
#1  0x00007f2f8609f2d3 in __pthread_kill_internal (signo=11, threadid=<optimized out>) at pthread_kill.c:78
#2  0x00007f2f8604fa08 in __GI_raise (sig=11) at ../sysdeps/posix/raise.c:26
#3  0x00007f2f87b613ac in KCrash::defaultCrashHandler(int) (sig=11)
    at /usr/src/debug/kcrash/kcrash-5.107.0/src/kcrash.cpp:611
#4  0x00007f2f8604fab0 in <signal handler called> () at /usr/lib/libc.so.6
#5  0x00007f2f85f0a1ed in XPending (dpy=0x18) at /usr/src/debug/libx11/libX11-1.8.6/src/Pending.c:51
#6  0x00007f2f641b1d91 in XlibNotifications::processEvents() (this=<optimized out>)
    at /usr/src/debug/plasma-desktop/plasma-desktop-5.27.6/kcms/touchpad/backends/x11/xlibnotifications.cpp:63
#7  XlibNotifications::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)
    (_o=0x55f59a06c040, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>)
    at /usr/src/debug/plasma-desktop/build/kcms/touchpad/touchpad_autogen/include/moc_xlibnotifications.cpp:91
#8  0x00007f2f868d0863 in doActivate<false>(QObject*, int, void**)
    (sender=0x55f599f88c50, signal_index=5, argv=0x7ffe499808c0) at kernel/qobject.cpp:3937
#9  0x00007f2f868d1f19 in QSocketNotifier::activated(int, QSocketNotifier::QPrivateSignal)
    (this=this@entry=0x55f599f88c50, _t1=<optimized out>, _t2=...) at .moc/moc_qsocketnotifier.cpp:185
#10 0x00007f2f868d200b in QSocketNotifier::event(QEvent*) (this=0x55f599f88c50, e=<optimized out>)
    at kernel/qsocketnotifier.h:115
#11 0x00007f2f8757893f in QApplicationPrivate::notify_helper(QObject*, QEvent*)
    (this=<optimized out>, receiver=0x55f599f88c50, e=0x7ffe499809d0) at kernel/qapplication.cpp:3640
#12 0x00007f2f8689b778 in QCoreApplication::notifyInternal2(QObject*, QEvent*)
    (receiver=0x55f599f88c50, event=0x7ffe499809d0) at kernel/qcoreapplication.cpp:1064
#13 0x00007f2f868e9336 in socketNotifierSourceDispatch(GSource*, GSourceFunc, gpointer) (source=0x55f599b17d50)
    at kernel/qeventdispatcher_glib.cpp:107
#14 0x00007f2f85310981 in g_main_dispatch (context=0x7f2f7c000ee0) at ../glib/glib/gmain.c:3460
#15 g_main_context_dispatch (context=0x7f2f7c000ee0) at ../glib/glib/gmain.c:4200
#16 0x00007f2f8536db39 in g_main_context_iterate.isra.0
    (context=context@entry=0x7f2f7c000ee0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>)
    at ../glib/glib/gmain.c:4276
#17 0x00007f2f8530e032 in g_main_context_iteration (context=0x7f2f7c000ee0, may_block=1) at ../glib/glib/gmain.c:4343
#18 0x00007f2f868ea5cc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>)
    (this=0x55f599b17dc0, flags=...) at kernel/qeventdispatcher_glib.cpp:423
Comment 2 petrk 2023-07-14 21:03:01 UTC
After such crash there is a chance for my keymap to get reset to US. Special characters are not working properly It can't be a coincidence and it's not first time it happened. Here's output from localectl:
System Locale: LANG=pl_PL.UTF-8
    VC Keymap: uk
   X11 Layout: gb
    X11 Model: pl
Comment 3 Nicolas Fella 2023-09-06 14:10:22 UTC

*** This bug has been marked as a duplicate of bug 426937 ***