Bug 469831

Summary: Usage of Qt SVG renderer causes some SVGs to be rendered incorrectly in Koko
Product: [Applications] Koko Reporter: cheatumj
Component: GeneralAssignee: Unassigned bugs mailing-list <unassigned-bugs>
Status: RESOLVED UPSTREAM    
Severity: normal CC: nate, postix
Priority: NOR    
Version: 23.04.1   
Target Milestone: ---   
Platform: Arch Linux   
OS: Linux   
See Also: https://bugs.kde.org/show_bug.cgi?id=336436
https://bugs.kde.org/show_bug.cgi?id=448234
Latest Commit: Version Fixed In:
Attachments: The file that is rendered incorrectly

Description cheatumj 2023-05-16 02:28:42 UTC
Created attachment 158986 [details]
The file that is rendered incorrectly

SUMMARY
A certain SVG file that I have is rendered incorrectly in Koko. This does not appear to happen for other SVG files I have tested.

STEPS TO REPRODUCE
1. Open the attached shield.svg file in Koko.

OBSERVED RESULT
How the image appears in Koko: https://ibb.co/pjMJ57g
Zoomed out: https://ibb.co/JQW56fz

EXPECTED RESULT
The image as rendered correctly by Firefox: https://ibb.co/3RhSmf5

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Arch Linux
KDE Plasma Version: 5.27.5
KDE Frameworks Version: 5.105.0
Qt Version: 5.15.9

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2023-05-16 14:14:31 UTC
It's a general problem with the Qt SVG library that we use. See Bug 336436 and Bug 448234.

In this specific case, it looks like it's related to lack of clipping support in that SVG rendering library, which I believe is being worked on for Qt 6.
Comment 2 Nate Graham 2024-06-15 16:00:45 UTC
So I think it's time to close this as RESOLVED UPSTREAM. The Qt folks have put work into improving their SVG renderer, with some improvements landing in 6.7, and others in 6.8, with still more to come.

So far no feasible alternative to waiting for these fixes has emerged. That makes it, in all practicality, purely an upstream issue, and thankfully our upstream appears to be working to address it.