Bug 467142

Summary: Show open application when trying to close a session
Product: [Plasma] kwin Reporter: Tobias G. <tobi.goergens>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: wishlist    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:

Description Tobias G. 2023-03-10 08:48:35 UTC
SUMMARY
Currently, when hitting shutdown/reboot/logout in Plasma, the session is simply quitted, no matter what applications are currently running/what their state is.
This might lead to users losing unsaved work or long shutdown times (to the maximum defined by systems), due to applications not wanting to quit.
This problem could be solved by showing a list of still open applications after pressing shutdown etc. and, in the best case, the user should be prominently warned if an application reports an unsaved state.
Plasma should remain active for as long as this list is visible or a timer is running out (e.g. 60 seconds), shutting down/rebooting anyway.
The user should have the option to cancel the shutdown or shutdown anyway.
In this phase, Plasma could already try to close open applications so the list gets smaller and only really blocking/important applications remain.
All applications with an unsaved state should be shown and the issue should be obvious (e.g. with a subtitle stating that there's unsaved work)
Other Desktop Environments already support this and this feature could have prevented me from unintentionally losing edited files.
The system monitor already supports showing a list of applications, so detecting them and distinguishing them from other processes seems to be possible.
In a KDE manner, this feature could be made optional and not enforced to users.

Is this a useful feature?
What do others think about this?

If wanted, I could add a wireframe to visualize what I mean.
Comment 1 Vlad Zahorodnii 2023-03-10 08:52:36 UTC

*** This bug has been marked as a duplicate of bug 461176 ***