Bug 466918

Summary: plasmashell does not automatically start when when logging into the Wayland session with "Aborting shell load: The activity manager daemon (kactivitymanagerd) is not running"
Product: [Plasma] plasmashell Reporter: alphabitserial <alphabitserial>
Component: Startup processAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: normal CC: alphabitserial, kde, nate, sam
Priority: NOR Keywords: wayland
Version: 5.27.2   
Target Milestone: 1.0   
Platform: Arch Linux   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: Boot log as requested by Nate Graham

Description alphabitserial 2023-03-06 00:27:30 UTC
SUMMARY
plasmashell does not automatically start when when logging into the Wayland session.

STEPS TO REPRODUCE
1. Log into Plasma (Wayland) from SDDM

OBSERVED RESULT
plasmashell does not automatically start. It starts fine if I open KRunner and enter `kstart5 plasmashell`

EXPECTED RESULT
plasmashell should automatically start.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Arch Linux
KDE Plasma Version: 5.27.2
KDE Frameworks Version: 5.103.0
Qt Version: 5.15.8

ADDITIONAL INFORMATION
I am using an NVIDIA RTX 3050 with driver version 525.89.02

The issue is consistent, not intermittent.

This may or may not be related, but when I experience this issue, KWallet doesn't automatically unlock, either. I'm not using automatic login with SDDM, where that behavior would be expected.

Please let me know of any additional information I could provide that may be of assistance with debugging.
Comment 1 Nate Graham 2023-03-07 20:50:26 UTC
Can you please reboot to reproduce the issue, then use KRunner to launch Konsole, enter `journalctl --user --boot 0 > ~/Desktop/bootlog.txt`, and then attach ~/Desktop/bootlog.txt?
Comment 2 alphabitserial 2023-03-08 02:59:15 UTC
Created attachment 157100 [details]
Boot log as requested by Nate Graham

You can find that boot log attached. Thank you! Please keep me looped in on next steps if I can still be of help gathering more debugging information.
Comment 3 Nate Graham 2023-03-08 15:28:05 UTC
Found the issue:

Mar 07 20:54:16 archon plasmashell[3141]: Aborting shell load: The activity manager daemon (kactivitymanagerd) is not running.
Mar 07 20:54:16 archon plasmashell[3141]: If this Plasma has been installed into a custom prefix, verify that its D-Bus services dir is known to the system for the daemon to be activatable.
Mar 07 20:54:16 archon plasmashell[3141]: Aborting shell load: The activity manager daemon (kactivitymanagerd) is not running.
Mar 07 20:54:16 archon plasmashell[3141]: If this Plasma has been installed into a custom prefix, verify that its D-Bus services dir is known to the system for the daemon to be activatable.

Now we need to figure out why that's not happening.
Comment 4 alphabitserial 2023-03-08 15:31:44 UTC
I've installed Plasma via the plasma-meta Arch Linux package, not to a custom prefix, so we can rule that out. Is there anything I can do to help identify the cause of the issue?

❯ paru -Q | rg kactivitymanagerd
kactivitymanagerd 5.27.2-1.1
Comment 5 alphabitserial 2023-03-16 03:22:29 UTC
After today's update to Plasma 5.27.3 the issue is still present.
Comment 6 Nate Graham 2023-04-10 03:15:41 UTC

*** This bug has been marked as a duplicate of bug 466193 ***