Bug 463955

Summary: Mouse movement is not smooth when a game is running in the background on Wayland
Product: [Plasma] kwin Reporter: Fushan Wen <qydwhotmail>
Component: wayland-genericAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: normal CC: kde
Priority: NOR Keywords: wayland
Version: masterFlags: qydwhotmail: Wayland+
Target Milestone: ---   
Platform: openSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description Fushan Wen 2023-01-07 02:16:00 UTC
SUMMARY
Running Portal 2 on Plasma Wayland, mouse movement becomes stuttered even when the game is in the background.

STEPS TO REPRODUCE
1. Open Portal 2
2. Play a map
3. Switch to another window

OBSERVED RESULT
Mouse movement is not smooth

EXPECTED RESULT
Smooth mouse movement

SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20230103
KDE Plasma Version: 5.26.80
KDE Frameworks Version: 5.102.0
Qt Version: 5.15.7
Kernel Version: 6.1.2-1-default (64-bit)
Graphics Platform: X11
Processors: 8 × AMD Ryzen 7 4700U with Radeon Graphics
Memory: 15.0 GiB of RAM
Graphics Processor: AMD Radeon Graphics
Manufacturer: HP
Product Name: HP ZHAN 66 Pro A 14 G3
Comment 1 David Edmundson 2023-01-09 16:21:28 UTC
Performance is being constantly worked upon.
We do have some issues with our render timing when the GPU is strained that we intend on working on.

As a bug report, I'll close it as it's not very specific.
Comment 2 Fushan Wen 2023-09-16 05:05:45 UTC

*** This bug has been marked as a duplicate of bug 472663 ***