Bug 463925

Summary: The newly saved gradient map preset colours are wrong, they turn darker
Product: [Applications] krita Reporter: Konayachi <kona.yachiyachi+kde>
Component: FiltersAssignee: Krita Bugs <krita-bugs-null>
Status: CONFIRMED ---    
Severity: normal CC: ginoba
Priority: NOR    
Version: 5.1.3   
Target Milestone: ---   
Platform: Appimage   
OS: Linux   
Latest Commit: Version Fixed In:

Description Konayachi 2023-01-06 12:42:15 UTC
SUMMARY
I encounter a weird behavior on the gradient map feature.
After I make a new gradient map set, when I’m about to save it as a new preset - the newly saved preset has different colours than the original gradient map I intended to save.
It turns darker out of nowhere, and the colours are wrong too.

See the video demonstration here: https://www.youtube.com/watch?v=D72HdbVKhEU

STEPS TO REPRODUCE
1. Create a drawing like usual.
2. Create a filter mask on a layer with drawing.
3. Choose Gradient Map, and play around with the colour slider bar to choose the desired colour.
4. Try to save the created gradient map set to a new preset by typing the desired name and then press the + button.

OBSERVED RESULT
There are two results, and they don't always reproduce the same way.
Result A: a newly saved gradient map preset appears on the list. The colour looks different from the intended colours on the slider bar (it turns darker). Upon clicking on that new preset, the colour on the canvas changed to the wrong colour.
Result B: a newly saved gradient map preset appears on the list. The colour looks the same from the intended colours on the slider bar. Upon clicking on that new preset, the colour on the canvas also changed to the wrong colour.

EXPECTED RESULT
The newly saved preset should represents the same colours as intended.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Linux Mint 21, appimage

ADDITIONAL INFORMATION
Yesterday I made 6 gradient map filter mask layers for different purposes. I tried to save each of them as separate presets, and this issues happened on all of them. The newly saved presets have the colours wrong from intended, makes it useless to create presets.
Today I revisited this file, 5 out of 6 saved presets (which displayed wrong colours, and gave wrong colours) now give the correct colours although they still have wrong colours display. On the last 1, the issue persists. I can also reproduce this multiple times, where the saved preset has darker colours. (as shown in the video)
Comment 1 Deif Lou 2023-01-06 17:26:09 UTC
Seems more like an issue saving the gradient with the generic gradient editor, since it is reproducible in the gradient fill layer as well.