Bug 458034

Summary: Misleading link to download Krita update?
Product: [Applications] krita Reporter: Tim <tim.six>
Component: UsabilityAssignee: Krita Bugs <krita-bugs-null>
Status: RESOLVED FIXED    
Severity: wishlist CC: halla
Priority: NOR    
Version: 5.0.2   
Target Milestone: ---   
Platform: Microsoft Windows   
OS: Microsoft Windows   
Latest Commit: Version Fixed In:
Attachments: screenshot of Krita on my computer

Description Tim 2022-08-18 15:10:41 UTC
Created attachment 151409 [details]
screenshot of Krita on my computer

SUMMARY
Users are notified under the "News" section in the opening screen of Krita about new updates to Krita. Despite appearing as a link, it is impossible to interact with it - clicking it does not do anything.

STEPS TO REPRODUCE
1. Open Krita 5.0.2
2. Look under "News" section for update download link (in this situation, update to 5.1.0)
3. Attempt to click link to update

OBSERVED RESULT
Nothing happens (e.g. devs just trolled the entire userbase LOL)

EXPECTED RESULT
Krita should begin the update process, navigate to update page, or do something

SOFTWARE/OS VERSIONS
Windows: Windows 10 Home 64-Bit (10.0 Build 19044)

ADDITIONAL INFORMATION
pretty funny tbh, but still a bug
Comment 1 Halla Rempt 2022-08-18 16:07:02 UTC
Yes, that's something someone else on irc also reported yesterday evening. I'm not sure what's up, the code "looks" correct, but I'll confirm the issue. Can't fix it for 5.1.0, though :-)
Comment 2 Tiar 2022-08-30 17:39:57 UTC
Git commit 148a5e9bb784d4d84ff5595afe1ab9e48f70883d by Agata Cacko.
Committed on 30/08/2022 at 17:39.
Pushed by tymond into branch 'master'.

Fix update link on Welcome Page widget

Before this commit, the update link on the Welcome Page widget
would look clickable but it wasn't possible to click it.
That was because the widget wasn't enabled.
This commit enables it and makes the link clickable.

M  +1    -0    libs/ui/KisWelcomePageWidget.cpp

https://invent.kde.org/graphics/krita/commit/148a5e9bb784d4d84ff5595afe1ab9e48f70883d
Comment 3 Tiar 2022-08-30 17:40:27 UTC
Git commit 1097f415888596fd9ea18a749e047f50e3253fbe by Agata Cacko.
Committed on 30/08/2022 at 17:40.
Pushed by tymond into branch 'krita/5.1'.

Fix update link on Welcome Page widget

Before this commit, the update link on the Welcome Page widget
would look clickable but it wasn't possible to click it.
That was because the widget wasn't enabled.
This commit enables it and makes the link clickable.


(cherry picked from commit 148a5e9bb784d4d84ff5595afe1ab9e48f70883d)

M  +1    -0    libs/ui/KisWelcomePageWidget.cpp

https://invent.kde.org/graphics/krita/commit/1097f415888596fd9ea18a749e047f50e3253fbe