Bug 455972

Summary: Application Launcher Search Defaulting to Mouse Cursor Instead of Top Result
Product: [Plasma] plasmashell Reporter: James Mowery <jmowery>
Component: Application Launcher (Kickoff)Assignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: normal CC: jmowery, mikel5764, noahadvs
Priority: NOR    
Version: 5.25.1   
Target Milestone: 1.0   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In:

Description James Mowery 2022-06-26 19:25:25 UTC
SUMMARY
When using the "Mod" key to type in an application or item to launch, you expect the top result would to be selected for launching. But if the mouse cursor is anywhere near the application launcher, especially located where an item on the list might be, it will default to selecting the item under the mouse cursor. It also sometimes re-takes priority over using keyboard arrows to select items. This was not the case in prior versions and it results in very often launching unintended applications..

STEPS TO REPRODUCE
1. Hover mouse over an area where the application launcher will display results from typing in a search (without moving mouse)
2. Press "Mod" key to launch application launcher
3. Type in a search result that should appear as the top result
4. Press "Enter" to select the result
OBSERVED RESULT
1. Instead of the top result being selected, as one might expect, the item where the mouse cursor is located is selected instead. This did not happen in previous versions of Plasma.
2. If you use the arrow keys to try to manually select a result, sometimes it will revert back to the mouse location instead.

EXPECTED RESULT
1. The top-most result should be selected by default with no mouse movement.
2. If you use the arrow keys to navigate up and down to different options, the arrow keys and the select you made there should take priority instead of it reverting to the mouse cursor (sporadic occurrence)

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Arch Linux (rolling)
KDE Plasma Version: 5.25.1 
KDE Frameworks Version: 5.95.0 
Qt Version: 5.15.5

ADDITIONAL INFORMATION
Quick video of mouse cursor (not being moved) but the item under the mouse cursor being selected when pressing "Enter" key: https://filerun.mowery.io/wl/?id=5InD4vwGIyb1lr9Kcf6mywvo6HU1Bh60&fmode=open
Comment 1 Noah Davis 2022-06-26 19:33:10 UTC

*** This bug has been marked as a duplicate of bug 455674 ***
Comment 2 Noah Davis 2022-06-26 19:33:57 UTC
I think someone is working on a solution for this right now
Comment 3 James Mowery 2022-06-26 19:36:54 UTC
Ah apologies for missing the duplicate. I tried searching before submitting. Might not have used the right search terminology for this.  Thank you for cleaning this up for me!
Comment 4 Noah Davis 2022-06-26 19:41:36 UTC
(In reply to James Mowery from comment #3)
> Ah apologies for missing the duplicate. I tried searching before submitting.
> Might not have used the right search terminology for this.  Thank you for
> cleaning this up for me!

No worries. Duplicates just indicate that the bug is important to people.