Bug 455559

Summary: Internal display black after unplugging external monitor
Product: [Plasma] kwin Reporter: shashwatkhanna312
Component: wayland-genericAssignee: KWin default assignee <kwin-bugs-null>
Severity: normal CC: bugseforuns, nate
Priority: NOR    
Version: 5.25.0   
Target Milestone: ---   
Platform: Arch Linux   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: kwin wayland backtrace

Description shashwatkhanna312 2022-06-18 16:46:29 UTC
Created attachment 149901 [details]
kwin wayland backtrace

I updated to KDE 5.25 recently and was trying out Wayland. Everything seemed to work fine until I unplugged my external display.  My internal display remained disabled and I couldn't do anything. I could however switch to the TTY and was able to reboot from there.

This doesn't happen under X11. When my external display is connected, the laptop screen is disabled. When I unplug the external display, the laptop screen enables itself. 

1. Login with wayland
2. Connect external display
3. Unplug external display


The internal display remains black even after unplugging the external monitor.


The internal display enables after unplugging the external monitor.

Linux/KDE Plasma: Arch 
(available in About System)
KDE Plasma Version: 5.25.0
KDE Frameworks Version: 5.95.0
Qt Version: 5.15.4


I followed https://community.kde.org/KWin/Debugging and have attached kwin_wayland.gdb. I also found an entry for /usr/bin/kwin_wayland. I don't think I can attach multiple files so here's the logs for that.

(gdb) bt
#0  0x00007f936dc13454 in KWin::Output::scale() const () at /usr/lib/libkwin.so.5
#1  0x00007f936dc13dc2 in KWin::Output::geometry() const () at /usr/lib/libkwin.so.5
#2  0x00007f936dccbe93 in KWin::Workspace::clientArea(KWin::clientAreaOption, KWin::Output const*, KWin::VirtualDesktop const*) const () at /usr/lib/libkwin.so.5
#3  0x00007f936dc62835 in  () at /usr/lib/libkwin.so.5
#4  0x00007f936c89ce3e in QMetaMethod::invoke(QObject*, Qt::ConnectionType, QGenericReturnArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument) const () at /usr/lib/libQt5Core.so.5
#5  0x00007f930f04d248 in PlasmaApi::Workspace::clientArea(PlasmaApi::Workspace::ClientAreaOption, int, int) () at /usr/lib/qt/qml/org/kde/bismuth/core/libbismuth_core.so
#6  0x00007f930f049dce in  () at /usr/lib/qt/qml/org/kde/bismuth/core/libbismuth_core.so
#7  0x00007f930f04b2e3 in PlasmaApi::Workspace::qt_metacall(QMetaObject::Call, int, void**) () at /usr/lib/qt/qml/org/kde/bismuth/core/libbismuth_core.so
#8  0x00007f936d676634 in  () at /usr/lib/libQt5Qml.so.5
#9  0x00007f936d57a89c in  () at /usr/lib/libQt5Qml.so.5
#10 0x00007f936d57bd00 in QV4::QObjectMethod::callInternal(QV4::Value const*, QV4::Value const*, int) const () at /usr/lib/libQt5Qml.so.5
#11 0x00007f936d59ddce in QV4::Runtime::CallPropertyLookup::call(QV4::ExecutionEngine*, QV4::Value const&, unsigned int, QV4::Value*, int) () at /usr/lib/libQt5Qml.so.5
#12 0x00007f930f0e8971 in  ()
#13 0x00007fff55489830 in  ()
#14 0x0000000000000000 in  ()
Comment 1 shashwatkhanna312 2022-06-18 17:00:31 UTC
ah looks like the logs from coredumpctl are the same as the ones in the file I attached.
Comment 2 Patrick Silva 2022-06-18 19:56:52 UTC
Plasma crash with the same result reported as bug 453501
Comment 3 Nate Graham 2022-06-21 17:31:07 UTC

*** This bug has been marked as a duplicate of bug 448102 ***
Comment 4 shashwatkhanna312 2022-06-22 10:40:04 UTC
If I understood it correctly, this is supposed to be resolved in 5.25.1, right? I'm on 5.25.1 right now, and unplugging the external monitor still doesn't turn on the laptop display in wayland. X11 works fine though, as I said earlier.