Bug 454959

Summary: Electron apps cursor theme
Product: [Plasma] kwin Reporter: Francisco Z <rhodium.jka>
Component: wayland-genericAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: normal CC: bugseforuns, dev.bacteriostat, nate, rhodium.jka
Priority: NOR    
Version: 5.24.5   
Target Milestone: ---   
Platform: Arch Linux   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: cursor
moar

Description Francisco Z 2022-06-07 08:42:58 UTC
Created attachment 149522 [details]
cursor

SUMMARY
***
NOTE: If you are reporting a crash, please try to attach a backtrace with debug symbols.
See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports
***


STEPS TO REPRODUCE
1. Install any electron app (Visual studio code, heroic launcher, discord...)
2. Open the file picker of the previous installed app under wayland session
3. Mouse cursor theme don't match with breeze cursor.

OBSERVED RESULT

Cursor theme changes in File Picker or some places under Wayland, it doesn't happend in a X11 session.

EXPECTED RESULT

Do not change the mouse cursor theme. In X11 session this is fine.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Arch Linux x64
(available in About System)
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.4

ADDITIONAL INFORMATION

I'm not sure if it's a kde plasma bug or electron, so i open both: https://github.com/electron/electron/issues/34448
Comment 1 Francisco Z 2022-06-07 08:43:17 UTC
Created attachment 149523 [details]
moar
Comment 2 Bacteria 2022-06-07 10:01:28 UTC
I am not able to reproduce it on various electron apps. This is most likely an electron bug. Can you try on Code - OSS from Arch repo? 

Operating System: Arch Linux
KDE Plasma Version: 5.24.90
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.4
Graphics Platform: Wayland
Comment 3 Francisco Z 2022-06-07 10:17:38 UTC
(In reply to Bacteria from comment #2)
> I am not able to reproduce it on various electron apps. This is most likely
> an electron bug. Can you try on Code - OSS from Arch repo? 
> 
> Operating System: Arch Linux
> KDE Plasma Version: 5.24.90
> KDE Frameworks Version: 5.94.0
> Qt Version: 5.15.4
> Graphics Platform: Wayland

Same in Code - OSS, there is a video:

https://files.catbox.moe/f5gzsk.mkv
Comment 4 Patrick Silva 2022-06-07 13:28:11 UTC

*** This bug has been marked as a duplicate of bug 442839 ***
Comment 5 Nate Graham 2023-01-06 14:20:51 UTC

*** This bug has been marked as a duplicate of bug 459468 ***