Bug 451045

Summary: kded5 crashes when connecting PS5 Dualsense controller via Bluetooth
Product: [Applications] systemsettings Reporter: d-h <dh_logins>
Component: kcm_touchpadAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: kdelibs-bugs, nicolas.fella
Priority: NOR    
Version: 5.24.2   
Target Milestone: ---   
Platform: Arch Linux   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: journalctl-output between enabling Bluetooth in the system tray applet and the last message related to the attempted connection

Description d-h 2022-03-02 15:05:05 UTC
Created attachment 147243 [details]
journalctl-output between enabling Bluetooth in the system tray applet and the last message related to the attempted connection

SUMMARY
'kded5' process crashes and core dump is generated when connecting a Playstation 5 Dualsense Controller via Bluetooth to my Archlinux desktop. This happens most of the times but not always. I am not able to see any pattern in this behavior. This doesn't happen either if the controller is connected using a USB cabel.

STEPS TO REPRODUCE
1. Make sure you have the controller and a supported Bluetooth adapter ('TP-Link UB500' USB adapter in my case) available and the controller is paired.
2. Press the 'PlayStation' button in order to connect the controller.

OBSERVED RESULT
The controller is listed as 'connected' in the Bluetooth applet for a fraction of a second. Then, all system tray icons disappear and reappear a fraction of a second later. The Bluetooth tray applet closes during this process and then reopens, telling that Bluetooth is disabled. There is no Bluetooth connection to the controller established.

EXPECTED RESULT
The controller should be listed as connected, no process should crash.

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.24.2
KDE Frameworks Version: 5.91.0
Qt Version: 5.15.2
Kernel Version: 5.16.11-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 2600 Six-Core Processor
Memory: 15.6 GiB of RAM
Graphics Processor: AMD Radeon RX 580 Series

Bluetooth adapter: TP-Link UB500
Controller: Sony PlayStation 5 Dualsense Wireless Controller

ADDITIONAL INFORMATION
The KDE Crash Report tool doesnt appear.

The Dualsense Controller has a fully supported Touchpad. Given that the journalctl log contains outputs that specifically refer to a touchpad and no other touchpad is connected, this might be related to the bug.
Comment 1 Nicolas Fella 2022-03-02 23:39:31 UTC
#0  0x00007efcc0c9334c __pthread_kill_implementation (libc.so.6 + 0x8f34c)
                                                   #1  0x00007efcc0c464b8 raise (libc.so.6 + 0x424b8)
                                                   #2  0x00007efcc1d49384 _ZN6KCrash19defaultCrashHandlerEi (libKF5Crash.so.5 + 0x7384)
                                                   #3  0x00007efcc0c46560 __restore_rt (libc.so.6 + 0x42560)
                                                   #4  0x00007efcc0908916 XPending (libX11.so.6 + 0x32916)
                                                   #5  0x00007efca69d1059 n/a (kded_touchpad.so + 0x18059)
                                                   #6  0x00007efcc12f1a1f n/a (libQt5Core.so.5 + 0x2bda1f)
                                                   #7  0x00007efcc12f3ac9 _ZN15QSocketNotifier9activatedEiNS_14QPrivateSignalE (libQt5Core.so.5 + 0x2bfac9)
                                                   #8  0x00007efcc12f4540 _ZN15QSocketNotifier5eventEP6QEvent (libQt5Core.so.5 + 0x2c0540)
                                                   #9  0x00007efcc1f681a6 _ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent (libQt5Widgets.so.5 + 0x1791a6)
                                                   #10 0x00007efcc12c0b9a _ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent (libQt5Core.so.5 + 0x28cb9a)
                                                   #11 0x00007efcc130b906 n/a (libQt5Core.so.5 + 0x2d7906)
                                                   #12 0x00007efcbfe6dee3 g_main_context_dispatch (libglib-2.0.so.0 + 0x54ee3)
                                                   #13 0x00007efcbfec40f9 n/a (libglib-2.0.so.0 + 0xab0f9)
                                                   #14 0x00007efcbfe6b455 g_main_context_iteration (libglib-2.0.so.0 + 0x52455)
                                                   #15 0x00007efcc130cada _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5 + 0x2d8ada)
                                                   #16 0x00007efcc12b8e6b _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5 + 0x284e6b)
                                                   #17 0x00007efcc12c45c7 _ZN16QCoreApplication4execEv (libQt5Core.so.5 + 0x2905c7)
                                                   #18 0x0000563fd9da9a62 n/a (kded5 + 0x6a62)
                                                   #19 0x00007efcc0c31310 __libc_start_call_main (libc.so.6 + 0x2d310)
                                                   #20 0x00007efcc0c313c1 __libc_start_main@@GLIBC_2.34 (libc.so.6 + 0x2d3c1)
                                                   #21 0x0000563fd9daa0ce n/a (kded5 + 0x70ce)
Comment 2 Nicolas Fella 2022-03-02 23:52:29 UTC

*** This bug has been marked as a duplicate of bug 426937 ***