Bug 450965

Summary: Please add Functionality to Scheduled Transactions
Product: [Applications] kmymoney Reporter: schoenes-rad
Component: generalAssignee: KMyMoney Devel Mailing List <kmymoney-devel>
Status: RESOLVED FIXED    
Severity: wishlist CC: markm10538
Priority: NOR    
Version: 5.1.1   
Target Milestone: ---   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In: 5.1.3
Attachments: attachment-21356-0.html

Description schoenes-rad 2022-02-28 14:12:37 UTC
SUMMARY
***
I would like to be able to add certain codes to my scheduled transactions and see those once the transactions have been added to the ledger.
***
I have a list of scheduled transactions, being repeated at different intervals.  Whenever the scheduled transactions are being added to the ledger as they are due, the "No." number field remains blank, and I have to manually feed my desired codes in order to describe the type of transaction, e.g., "CC" for credit card, "DA" for Dauerauftrag, "LA" for Lastschrift, and the like.
I would like to be able to have this attribute added automatically in the same way I enter these codes for my manually entered transactions.

STEPS TO REPRODUCE
1. 
2. n/a
3. 

OBSERVED RESULT
see above

EXPECTED RESULT
see above

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: MX Linux Kernel: 5.10.0-11-amd64 x86_64 bits
(available in About System)
KDE Plasma Version: n/a

KDE Frameworks Version: 5.78.00
Qt Version: Qt 5.15.2 (built against 5.15.2)

ADDITIONAL INFORMATION
Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm 4.16.1 vt: 7
dm: LightDM 1.26.0 Distro: MX-21_x64 Wildflower October 20 2021

- nothing follows -
Comment 1 Mark Medoff 2022-03-05 13:04:51 UTC
This is also very important for me. I use that field in a way similar to how it was used in Quicken and I put ACH, EFT, BILLPAY, etc in it.
KMyMoney treats the field very inconsistently:
1) If anything is entered in the field in the Scheduled Transactions view, it appears to be accepted; but in fact, the data is ignored.
2) If anything is entered in the field in the Home View when entering the scheduled transaction, the data is accepted and a dialog box appears asking if you want to save the change for future scheduled transactions. Selecting yes saves the change. NOTE: if you return to Scheduled Transactions view and make any change to that schedule, such as to the amount, the data is the Number field is lost without any warning. Also, when you go to the Scheduled Transaction view and look at a schedule that did have data saved in the Number field previously, the field is displayed "blank" so there is no indication that data is in the field and will be lost during a subsequent edit.
3) It would be nice if Reports allowed Organize By to be set for the Number field as it can contain useful info beside just a number.
Comment 2 Thomas Baumgart 2022-03-06 07:16:34 UTC
Git commit 0ec67b8ee535ab0bedcee16bd5f2ec3491fe3fa9 by Thomas Baumgart.
Committed on 06/03/2022 at 07:14.
Pushed by tbaumgart into branch '5.1'.

Maintain information in number field of schedules

The number field in schedules was cleared out when the payment method
was not 'write check'. This limitation has been removed.
FIXED-IN: 5.1.3

M  +0    -28   kmymoney/dialogs/keditscheduledlg.cpp
M  +0    -1    kmymoney/dialogs/keditscheduledlg.h
M  +0    -6    kmymoney/dialogs/kenterscheduledlg.cpp

https://invent.kde.org/office/kmymoney/commit/0ec67b8ee535ab0bedcee16bd5f2ec3491fe3fa9
Comment 3 Mark Medoff 2022-03-06 13:03:47 UTC
Created attachment 147327 [details]
attachment-21356-0.html

Thank you for the prompt reply.
I am using Linux Version 5.1.2-dcb4ef208.

I find the issue still exists in this version:
If I create a new scheduled transaction and don't select the "Write Check"
from the pull-down, the check number box does not appear; BUT if I have
previously created a scheduled transaction and I edit it, the check number
box still appears even if the "Write Check" option is not selected and any
data put in the check number box is lost.

If I change my scheduled transaction to "Write Check", the program will
allow me to edit the transaction and will save any info in the check number
box, you advised.
Question: if non-numeric data is put into check number box, will the
program somehow increment it for the following transaction? Also note that
when I put a non-numeric value in check number on a transfer scheduled
transaction, it uses the non-numeric value for half the transfer and uses
the next numeric value for the other half of the transfer. I think it
should use the same non-numeric value for both parts of the transfer.

Thanks,
Mark Medoff

On Sun, Mar 6, 2022 at 2:16 AM Thomas Baumgart <bugzilla_noreply@kde.org>
wrote:

> https://bugs.kde.org/show_bug.cgi?id=450965
>
> Thomas Baumgart <thb@net-bembel.de> changed:
>
>            What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>          Resolution|---                         |FIXED
>       Latest Commit|                            |
> https://invent.kde.org/offi
>                    |
> |ce/kmymoney/commit/0ec67b8e
>                    |
> |e535ab0bedcee16bd5f2ec3491f
>                    |                            |e3fa9
>    Version Fixed In|                            |5.1.3
>              Status|REPORTED                    |RESOLVED
>
> --- Comment #2 from Thomas Baumgart <thb@net-bembel.de> ---
> Git commit 0ec67b8ee535ab0bedcee16bd5f2ec3491fe3fa9 by Thomas Baumgart.
> Committed on 06/03/2022 at 07:14.
> Pushed by tbaumgart into branch '5.1'.
>
> Maintain information in number field of schedules
>
> The number field in schedules was cleared out when the payment method
> was not 'write check'. This limitation has been removed.
> FIXED-IN: 5.1.3
>
> M  +0    -28   kmymoney/dialogs/keditscheduledlg.cpp
> M  +0    -1    kmymoney/dialogs/keditscheduledlg.h
> M  +0    -6    kmymoney/dialogs/kenterscheduledlg.cpp
>
>
> https://invent.kde.org/office/kmymoney/commit/0ec67b8ee535ab0bedcee16bd5f2ec3491fe3fa9
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
> You voted for the bug.
Comment 4 Thomas Baumgart 2022-03-06 14:03:49 UTC
Please do us a favor and cut off the original part when you respond via mail and possibly don't send HTML mails. It screws things up badly (see yourself at https://bugs.kde.org/show_bug.cgi?id=450965)

Now to the answer: The version you use is tooo old :)

commit 0ec67b8ee535ab0bedcee16bd5f2ec3491fe3fa9 (origin/5.1, 5.1)
Author: Thomas Baumgart <thb@net-bembel.de>
Date:   Sun Mar 6 08:14:55 2022 +0100

    Maintain information in number field of schedules
    
    The number field in schedules was cleared out when the payment method
    was not 'write check'. This limitation has been removed.
    
    FEATURE: 450965
    FIXED-IN: 5.1.3

commit dcb4ef20841a7958a34da4868151f019473b31b1
Author: Thomas Baumgart <thb@net-bembel.de>
Date:   Sun Feb 27 18:49:13 2022 +0100

    Resolve compiler warnings