Bug 450230

Summary: Improve cover and flip switch
Product: [Plasma] kdeplasma-addons Reporter: Josesk Volpe <joseskvolpe>
Component: Task SwitchersAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED FIXED    
Severity: wishlist CC: 0jaseel0, c3i8zv295, gudvinr+kde, isma.af, kde.bugs, mabo, me, nate, nl6720, ocawesome101, pprkut, ricardo, sombragris, thomas.bettler
Priority: NOR    
Version: 5.24.0   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
See Also: https://bugs.kde.org/show_bug.cgi?id=449180
Latest Commit: Version Fixed In: 6.0

Description Josesk Volpe 2022-02-14 16:09:44 UTC
Clip switch and cover switch had been replaced since they got removed on Plasma 5.23, but they're still not good enough, their animations are jerky and lacks effects we used to love. It currently doesn't looks how it looked before.
Suggestions for the next update:

* Bring back reflections
* Remove the borders on the selected task
* Replace the blurred grey background to the shaded background
* Add starting and ending animations
* Fix the glitchy movement when quick-switching tasks
* Make task windows bigger

To let users to optionally give a breeze minimalist look on this effect, it could add an option on the task-switch settings to remove reflections and shaded background. Task switchers are configurable.
Comment 1 Robin Bankhead 2022-02-14 17:45:08 UTC
Subscribing.

IIRC, Cover Switch was "inspired" by the UI of iTunes and/or the iPod Touch (wow we are going back a bit aren't we? lol). I wonder if the devs have actually experienced that UI?

While acknowledging that design trends move on, the new look I just find utterly lacking in the polish and slickness that appealed about the original. (Granted this is only v1.0, but I infer that the design changes have been conscious decisions.)

I also agree that configurability is desirable. It is kind of a KDE hallmark after all ;)
Comment 2 Ricardo J. Barberis 2022-02-15 00:04:06 UTC
I'd like at least these 3, especially the last one:

* Remove the borders on the selected task
* Replace the blurred grey background to the shaded background
* Make task windows bigger
Comment 3 sombragris 2022-02-15 00:30:12 UTC
Agreed. Confirmed here.
Current cover switch is NOT a replacement of the previous one but a vastly inferior product. I appreciate the effort but if you can't at least replicate the functionality, please reinstate the old effect. Thanks!
Comment 4 Julius R. 2022-03-02 11:52:55 UTC
I absolutely second the statements above. I was excited to see the QML rewrite of the Cover Switch effect, but it does fall a bit short in comparison to the old effect. It is good, but things like blur, window size, and margins should be configurable. It seems, this effect has not been designed with different resolutions and screen aspect ratios in mind.
Comment 5 Nate Graham 2022-04-21 16:17:39 UTC
*** Bug 451901 has been marked as a duplicate of this bug. ***
Comment 6 gudvinr+kde 2022-05-08 05:39:06 UTC
I think Flip/Cover switch should have desktop wallpaper on background. Current solid gray is rather lacking some appearance even compared to basic thumbnail/breeze switches.
Comment 7 Maximilian Böhm 2022-05-08 10:42:35 UTC
(In reply to gudvinr+kde from comment #6)
> I think Flip/Cover switch should have desktop wallpaper on background.
> Current solid gray is rather lacking some appearance even compared to basic
> thumbnail/breeze switches.

FULLACK
Comment 8 Ricardo J. Barberis 2024-05-18 21:12:26 UTC
As of today, both flip and cover switch have the blurred wallpaper as a background.

I think this bug can be safely closed.
Comment 9 Nate Graham 2024-05-18 22:29:23 UTC
Thanks!