Bug 449557

Summary: Akonadi Server crashes when starting KMail after booting the computer
Product: [Frameworks and Libraries] Akonadi Reporter: Dennis Schridde <devurandom>
Component: serverAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED UPSTREAM    
Severity: crash Keywords: drkonqi
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Gentoo Packages   
OS: Linux   
See Also: https://bugs.gentoo.org/show_bug.cgi?id=832012
Latest Commit: Version Fixed In:

Description Dennis Schridde 2022-02-03 13:29:16 UTC
Application: akonadiserver (5.19.1 (21.12.1))

Qt Version: 5.15.2
Frameworks Version: 5.90.0
Operating System: Linux 5.16.5-gentoo-dist x86_64
Windowing System: Wayland
Distribution: "Gentoo Base System release 2.8"
DrKonqi: 5.23.5 [KCrashBackend]

-- Information about the crash:
- What I was doing when the application crashed:

1. I restarted my computer.
2. I logged in.
3. I opened KMail.
4. I saw the notification that Akonadi Server had crashed. (Split-second after starting KMail. Not entirely sure what came first.)
5. KMail says it tries to start the PIM system, but eventually turns to say "the akonadi personal information managment service is not operational"

The reporter is unsure if this crash is reproducible.

-- Backtrace:
Application: Akonadi Server (akonadiserver), signal: Aborted

[KCrash Handler]
#4  0x00007fd999ac6d2c in ?? () from /usr/lib64/libc.so.6
#5  0x00007fd999a79a82 in raise () from /usr/lib64/libc.so.6
#6  0x00007fd999a64449 in abort () from /usr/lib64/libc.so.6
#7  0x00007fd999cf78b2 in __gnu_cxx::__verbose_terminate_handler () at /var/tmp/portage/sys-devel/gcc-11.2.1_p20220115/work/gcc-11-20220115/libstdc++-v3/libsupc++/vterminate.cc:95
#8  0x00007fd999d035e6 in __cxxabiv1::__terminate (handler=<optimized out>) at /var/tmp/portage/sys-devel/gcc-11.2.1_p20220115/work/gcc-11-20220115/libstdc++-v3/libsupc++/eh_terminate.cc:48
#9  0x00007fd999d03651 in std::terminate () at /var/tmp/portage/sys-devel/gcc-11.2.1_p20220115/work/gcc-11-20220115/libstdc++-v3/libsupc++/eh_terminate.cc:58
#10 0x00007fd999d038f3 in __cxxabiv1::__cxa_throw (obj=<optimized out>, tinfo=0x559a830ee260 <typeinfo for Akonadi::Server::DbException>, dest=0x559a82fd8870 <Akonadi::Server::DbException::~DbException()>) at /var/tmp/portage/sys-devel/gcc-11.2.1_p20220115/work/gcc-11-20220115/libstdc++-v3/libsupc++/eh_throw.cc:95
#11 0x0000559a82ee77f1 in Akonadi::Server::DbIntrospector::hasIndex(QString const&, QString const&) [clone .cold] ()
#12 0x0000559a82fda85b in Akonadi::Server::DbInitializer::checkIndexes(Akonadi::Server::TableDescription const&) ()
#13 0x0000559a82fdbb96 in Akonadi::Server::DbInitializer::updateIndexesAndConstraints() ()
#14 0x0000559a82fbd743 in Akonadi::Server::DataStore::init() ()
#15 0x0000559a82ef7f18 in Akonadi::Server::AkonadiServer::setupDatabase() ()
#16 0x0000559a82efa0d5 in Akonadi::Server::AkonadiServer::init() ()
#17 0x00007fd99a119b36 in QObject::event(QEvent*) () from /usr/lib64/libQt5Core.so.5
#18 0x00007fd99a0ee275 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib64/libQt5Core.so.5
#19 0x00007fd99a0f1915 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQt5Core.so.5
#20 0x00007fd99a140963 in postEventSourceDispatch(_GSource*, int (*)(void*), void*) () from /usr/lib64/libQt5Core.so.5
#21 0x00007fd99862735b in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#22 0x00007fd998627618 in ?? () from /usr/lib64/libglib-2.0.so.0
#23 0x00007fd9986276cf in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#24 0x00007fd99a1403f4 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#25 0x00007fd99a0ecc9b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#26 0x00007fd99a0f52cd in QCoreApplication::exec() () from /usr/lib64/libQt5Core.so.5
#27 0x0000559a82ef395e in main ()
[Inferior 1 (process 2504) detached]

The reporter indicates this bug may be a duplicate of or related to bug 434236.

Possible duplicates by query: bug 448616, bug 448195, bug 446579, bug 445746, bug 445496.

Reported using DrKonqi
Comment 1 Dennis Schridde 2022-02-03 20:39:52 UTC
This seems to be an issue between MariaDB 10.6.5 and Linux 5.16.5: https://bugs.gentoo.org/show_bug.cgi?id=832012