Bug 447728

Summary: When disconnecting my laptop from my single external monitor (via docking station using "External Display Only" option), my panels disappear. Only an issue on disconnect.
Product: kwin Reporter: geminiportkey
Component: wayland-genericAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: normal CC: nate
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Archlinux Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description geminiportkey 2021-12-31 09:27:06 UTC
When disconnecting my laptop from my single external monitor (via docking station using "External Display Only" option), my panels disappear. Only an issue on disconnect. 

My windows do not close, and I can open up new windows using krunner, and keyboard shortcuts (like CTRL + ALT + T for Konsole). 

There's two ways I've been trying to work around this, and neither are ideal. 

1. kwin_wayland --replace. This brings everything back (panels) on my laptop screen, but has the annoyance of closing every single open application. In addition, when I run this, and try to connect to my monitor again, my monitor shows its recieving a signal but shows a black screen. I know that data is going over the Type-C cable to my docking station because my keyboard is lit up and if I use the VolUp/VolDown keys on my keyboard, I can hear the "droplet" sound coming out of my speakers (which are also connected to the docking station). This behavior does not change/get better unless I reboot. 


2. kquitapp5 plasmashell && kstart5 plasmashell & in a terminal. This brings everything back, without closing all my windows, but the behavior with the external monitor is the same as #1. Nothing gets my external monitor working again until I reboot. 

Things to note; 

- This does not happen with the X11 session

- I notice that if I press the "Identify" button in the Display Configuration page when the laptop is connected to my monitor (set to external only), both the laptop screen and the external monitor screen "show up" on the external monitor screen. Please see bugreport-screen1-identify.png. I suspect this is problematic and I should not be seeing that "laptop screen" red box in the top left section of my external monitor. 

- I notice that if I had the Display Configuration window open on the external monitor, and then I unplug the laptop from the monitor, the Display Configuration window says "(Not Respondig)" in the titlebar, and I have to click the "X" several times to close it. 

- A reboot allows me to use my monitor (and everything else connected to the dock) flawlessly, at 60hz and native resolution (3840x1600). 

- I am currently running the linux-zen kernel, but on a clean install with the standard kernel, I notice the same behavior. 

- I have never filed a KDE bug report before, so if there's any information lacking, please let me know and I will be more than happy to provide it. 

Operating System: Arch Linux
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.89.0
Qt Version: 5.15.2
Kernel Version: 5.15.12-zen1-1-zen (64-bit) (tested with standard non-zen kernel, same behavior)
Graphics Platform: Wayland
Processors: 16 × AMD Ryzen 7 4800U with Radeon Graphics
Memory: 13.6 GiB of RAM
Graphics Processor: AMD RENOIR
Comment 1 geminiportkey 2021-12-31 09:29:52 UTC
Due to the filesize of my screenshot, I've uploaded the image "bugreport-screen1-identify.png" here: https://i.imgur.com/8VcOuLf.jpg
Comment 2 Nate Graham 2022-01-12 01:47:30 UTC
Should be already fixed in Plasma 5.24!

*** This bug has been marked as a duplicate of bug 447936 ***
Comment 3 geminiportkey 2022-01-23 22:02:06 UTC
I can confirm. Thank you Nate, not only is this issue fixed with the latest KDE, but the transition between laptop to external monitor has been ROCK solid. Incredible difference.
Comment 4 Nate Graham 2022-01-23 22:23:54 UTC
Don't thank me, thank Marco Martin! It was his work. I'm glad it's better for you now!