Bug 446871

Summary: Search problem with 2 Kickoff launcher
Product: plasmashell Reporter: Phisss <phissica>
Component: Application Launcher (Kickoff)Assignee: David Edmundson <kde>
Status: RESOLVED DUPLICATE    
Severity: normal CC: mikel5764, plasma-bugs
Priority: NOR    
Version: 5.23.4   
Target Milestone: 1.0   
Platform: Neon Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Phisss 2021-12-12 09:30:17 UTC
SUMMARY
I have a system with two screens, on both I have a Kickoff launcher in the control panel. When opening the launcher on one panel and typing some letters to search for a program, they are not displayed in the corresponding search field. Instead, apparently they are displayed in the search field of the launcher on the other screen. Somehow this seems to be related to which launcher was last used and happens in both directions: Typing something in after opening the launcher on screen A, the typed letters are displayed in launcher of screen B and vice-versa.


STEPS TO REPRODUCE
1. Set-up dual screen system with separate control panels and Kickoff launchers.
2. Open Kickoff on screen A and type some letters to search for a program
3. Open Kickoff on screen B, the typed letters are displayed there

OBSERVED RESULT
When opening the Kickoff launcher and typing some letters, they are not displayed in the search field (apparently depending on which of two separate Kickoff launchers was last used). Even when writing the full name of a program and pressing the ENTER key, the program does not start. Opening the second launcher, the typed letters are visible there.

EXPECTED RESULT
Entered search term should be displayed in the currently open Kickoff launcher and filter the program list accordingly

SOFTWARE/OS VERSIONS

Linux/KDE Plasma: KDE Neon
(available in About System)
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.3

ADDITIONAL INFORMATION
Possible duplicate of bug 443131
Comment 1 David Edmundson 2021-12-13 21:28:20 UTC

*** This bug has been marked as a duplicate of bug 443131 ***