Bug 446712

Summary: Compressing file crashed 15 processes
Product: dolphin Reporter: pqwoerituytrueiwoq
Component: generalAssignee: Dolphin Bug Assignee <dolphin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash CC: kfm-devel, nicolas.fella
Priority: NOR    
Version: 21.11.90   
Target Milestone: ---   
Platform: Kubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: ScreenCapture
backtraces
List of installed DEB packages
Screencapture

Description pqwoerituytrueiwoq 2021-12-09 04:39:12 UTC
Created attachment 144379 [details]
ScreenCapture

SUMMARY
Tried to compress a file in to a split archive on Kubuntu 22.04


STEPS TO REPRODUCE
1. Decompress this file: https://mega.nz/file/AI9lySDb#5fSMIqrW9qf6h_CcRjehtJpCtBmQhSgdretQUCgmOWA (not sure if it matters what is compressed)
2. See attached screencapture

OBSERVED RESULT
coredumpctl has all of these from the crash
Wed 2021-12-08 22:49:38 EST  1230 1000 1000 SIGABRT present  /usr/bin/kwalletd5                                   812.7K
Wed 2021-12-08 22:49:39 EST 13554 1000 1000 SIGABRT present  /usr/lib/x86_64-linux-gnu/libexec/drkonqi            388.7K
Wed 2021-12-08 22:49:39 EST 13562 1000 1000 SIGABRT present  /usr/lib/x86_64-linux-gnu/libexec/org_kde_powerdevil 498.8K
Wed 2021-12-08 22:49:39 EST 13567 1000 1000 SIGABRT present  /usr/lib/x86_64-linux-gnu/libexec/drkonqi            389.0K
Wed 2021-12-08 22:49:39 EST 13565 1000 1000 SIGABRT present  /usr/lib/x86_64-linux-gnu/libexec/drkonqi            390.3K
Wed 2021-12-08 22:49:39 EST 13569 1000 1000 SIGABRT present  /usr/lib/x86_64-linux-gnu/libexec/drkonqi            389.2K
Wed 2021-12-08 22:49:39 EST 13566 1000 1000 SIGABRT present  /usr/bin/kded5                                       281.7K
Wed 2021-12-08 22:49:39 EST 13568 1000 1000 SIGABRT present  /usr/lib/x86_64-linux-gnu/libexec/drkonqi            389.3K
Wed 2021-12-08 22:49:39 EST 13570 1000 1000 SIGABRT present  /usr/bin/plasmashell                                 600.0K
Wed 2021-12-08 22:49:40 EST  1480 1000 1000 SIGABRT present  /usr/lib/x86_64-linux-gnu/libexec/kactivitymanagerd  624.8K
Wed 2021-12-08 22:49:40 EST  1440 1000 1000 SIGABRT present  /usr/lib/x86_64-linux-gnu/libexec/org_kde_powerdevil 735.2K
Wed 2021-12-08 22:49:40 EST  1466 1000 1000 SIGABRT present  /usr/lib/x86_64-linux-gnu/libexec/DiscoverNotifier   938.3K
Wed 2021-12-08 22:49:40 EST  2529 1000 1000 SIGABRT present  /usr/bin/plasmashell                                  16.2M
Wed 2021-12-08 22:49:40 EST  1423 1000 1000 SIGABRT present  /usr/bin/kded5                                         6.5M
Wed 2021-12-08 23:00:47 EST 15497 1000 1000 SIGSEGV present  /usr/bin/dolphin                                      29.9M

EXPECTED RESULT
File gets compressed without over a dozen things crashing

SOFTWARE/OS VERSIONS
Operating System: Kubuntu 22.04
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.2
Kernel Version: 5.16.0-051600rc4-generic (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 5600G with Radeon Graphics
Memory: 13.6 GiB of RAM
Graphics Processor: AMD RENOIR
--------------------
Operating System: Kubuntu 22.04
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.2
Kernel Version: 5.16.0-051600rc4-generic (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 3600 6-Core Processor
Memory: 15.6 GiB of RAM
Graphics Processor: Radeon RX 580 Series
Comment 1 pqwoerituytrueiwoq 2021-12-09 04:41:29 UTC
Created attachment 144380 [details]
backtraces

Attach backtraces of all the things

This was my 1st attempt at reproducing this, it should not be necessary to start the 1st file compression that i did (was not sure what method i used the 1st time)
Comment 2 pqwoerituytrueiwoq 2021-12-09 04:46:46 UTC
Created attachment 144381 [details]
List of installed DEB packages

System only have DEBs installed, no non-native packages
Comment 3 pqwoerituytrueiwoq 2021-12-09 15:20:00 UTC
Got it to crash again: https://pastebin.com/KQANDMEJ (backtrace)
this time only dolphin crashed

chad@kde-test-system:~$ dolphin /tmp/
Qt: Session management error: networkIdsList argument is NULL
Cannot initialize model with data QJsonObject(). missing: QJsonValue(string, "urls")
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = dolphin path = /usr/bin pid = 2364
KCrash: Arguments: /usr/bin/dolphin /tmp/ 
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi

[1]+  Stopped                 dolphin /tmp/
chad@kde-test-system:~$ Unable to find file for pid 2364 expected at "kcrash-metadata/2364.ini"
QSocketNotifier: Invalid socket 8 and type 'Read', disabling...
QSocketNotifier: Invalid socket 14 and type 'Read', disabling...
QSocketNotifier: Invalid socket 15 and type 'Read', disabling...
Unable to start Dr. Konqi
Re-raising signal for core dump handling.
Comment 4 pqwoerituytrueiwoq 2021-12-11 14:38:06 UTC
Created attachment 144451 [details]
Screencapture

New screen capture showing it crashing quick and fast with the recent updates

Application: Dolphin (dolphin), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f7386794030 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f738698247c in QCoreApplicationPrivate::lockThreadPostEventList(QObject*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f7386983acd in QCoreApplication::postEvent(QObject*, QEvent*, int) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f73869b7da3 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f737003c8d6 in Kerfuffle::ReadOnlyArchiveInterface::finished(bool) () from /lib/x86_64-linux-gnu/libkerfuffle.so.21
#9  0x00007f73869b7da3 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007f73868e96ec in QProcess::finished(int, QProcess::ExitStatus) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007f73868ef203 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#12 0x00007f73868ef33e in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#13 0x00007f73869b7dd8 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#14 0x00007f73869bb2b3 in QSocketNotifier::activated(QSocketDescriptor, QSocketNotifier::Type, QSocketNotifier::QPrivateSignal) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#15 0x00007f73869bbae3 in QSocketNotifier::event(QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#16 0x00007f73874706b3 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#17 0x00007f73869804ba in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#18 0x00007f73869da435 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#19 0x00007f7384626b0b in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f738467ab98 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f73846241d3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f73869d9828 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#23 0x00007f738697edeb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#24 0x00007f7386987374 in QCoreApplication::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#25 0x000055814d7adb9e in ?? ()
#26 0x00007f73862b3fd0 in __libc_start_call_main (main=main@entry=0x55814d7a8320, argc=argc@entry=1, argv=argv@entry=0x7ffed0328c78) at ../sysdeps/nptl/libc_start_call_main.h:58
#27 0x00007f73862b407d in __libc_start_main_impl (main=0x55814d7a8320, argc=1, argv=0x7ffed0328c78, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffed0328c68) at ../csu/libc-start.c:409
#28 0x000055814d7ae325 in ?? ()
[Inferior 1 (process 3877) detached]

-------------------------

Operating System: Kubuntu 22.04
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.2
Kernel Version: 5.16.0-051600rc4-generic (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 5600G with Radeon Graphics
Memory: 13.6 GiB of RAM
Graphics Processor: AMD RENOIR

---------------------

dolphin:
  Installed: 4:21.12.0-0ubuntu1
  Candidate: 4:21.12.0-0ubuntu1
  Version table:
 *** 4:21.12.0-0ubuntu1 500
        500 http://us.archive.ubuntu.com/ubuntu jammy/universe amd64 Packages
        100 /var/lib/dpkg/status
p7zip:
  Installed: 16.02+dfsg-8
  Candidate: 16.02+dfsg-8
  Version table:
 *** 16.02+dfsg-8 500
        500 http://us.archive.ubuntu.com/ubuntu jammy/universe amd64 Packages
        100 /var/lib/dpkg/status
p7zip-full:
  Installed: 16.02+dfsg-8
  Candidate: 16.02+dfsg-8
  Version table:
 *** 16.02+dfsg-8 500
        500 http://us.archive.ubuntu.com/ubuntu jammy/universe amd64 Packages
        100 /var/lib/dpkg/status
Comment 5 pqwoerituytrueiwoq 2021-12-11 15:20:36 UTC
This is probably a duplicate of:
https://bugs.kde.org/show_bug.cgi?id=443540
Comment 6 Nicolas Fella 2021-12-14 01:18:23 UTC
There seem to be two separate things going on:
- The Dolphin crash when compressing is most likely https://bugs.kde.org/show_bug.cgi?id=443540
- All the other crashes in coredumpctl are unrelated and due to kwin_wayland crashing and taking down all applications with it. If you have a backtrace for kwin_wayland please do make a report for that
Comment 7 Nicolas Fella 2021-12-14 01:18:40 UTC

*** This bug has been marked as a duplicate of bug 443540 ***
Comment 8 pqwoerituytrueiwoq 2021-12-14 02:41:05 UTC
That is odd kwin_wayland should not have been running in the 1st place, kwin_x11 should have been the active process
Comment 9 Nicolas Fella 2021-12-14 11:33:24 UTC
The backtraces clearly show that these applications were running under Wayland. Also the timestamps from coredumpctl show that the Dolphin crash and the other crashes were 10 minutes apart