Bug 446561

Summary: unmounting USB device causes Plasma crash
Product: plasmashell Reporter: Germano Massullo <germano.massullo>
Component: generic-crashAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: normal CC: nate
Priority: NOR    
Version: 5.22.3   
Target Milestone: 1.0   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In:

Description Germano Massullo 2021-12-06 16:41:15 UTC
Everytime I unmount a USB device from the "removable devices" Plasma panel icon, Plasma crashes.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma:  Fedora 35
KDE Plasma Version: plasma-desktop-5.23.3-1.fc35.x86_64
KDE Frameworks Version:  5.88.0
Qt Version: 5.15.2


$ gdb plasmashell 36537
GNU gdb (GDB) Fedora 11.1-5.fc35
Copyright (C) 2021 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<https://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from plasmashell...
Reading symbols from /usr/lib/debug/usr/bin/plasmashell-5.23.3-1.fc35.x86_64.debug...
Attaching to program: /usr/bin/plasmashell, process 36537
[New LWP 36538]
[New LWP 36539]
[New LWP 36540]
[New LWP 36542]
[New LWP 36556]
[New LWP 36557]
[New LWP 36558]
[New LWP 36565]
[New LWP 36587]
[New LWP 36594]
[New LWP 36595]
[New LWP 36610]
[New LWP 36611]
[New LWP 36923]
[New LWP 37913]
[New LWP 37914]
Downloading -0.00 MB separate debug info for /lib64/libLLVM-13.so
[                                                                                                                                                                                                                                                         ]
Downloading -0.00 MB separate debug info for /home/user/.cache/debuginfod_client/460d8e1344ca4b3467c8dd05c50ba93d8442f0dc/debuginfo                                                                                                                 
Downloading -0.00 MB separate debug info for /lib64/libelf.so.1                                                                                                                                                                                            
Downloading -0.00 MB separate debug info for /home/user/.cache/debuginfod_client/82957e348b58e4b13f147f08a030f3a4997bcb12/debuginfo                                                                                                                 
Downloading -0.00 MB separate debug info for /lib64/libedit.so.0                                                                                                                                                                                           
Downloading -0.00 MB separate debug info for /usr/lib64/qt5/plugins/plasma/applets/plasma_applet_vault.so                                                                                                                                                  
Downloading -0.00 MB separate debug info for /home/user/.cache/debuginfod_client/d2758f4c8161fe96d0bf5d9a5c1bc34001b95161/debuginfo                                                                                                                 
Downloading -0.00 MB separate debug info for /lib64/libImath-3_1.so.29                                                                                                                                                                                     
Downloading -0.00 MB separate debug info for /home/user/.cache/debuginfod_client/04de66dbb5c5f8192ccdad15b7e009adb4332f52/debuginfo                                                                                                                 
Downloading -0.00 MB separate debug info for /lib64/libkcupslib.so                                                                                                                                                                                         
Downloading 0.01 MB separate debug info for /home/user/system-supplied DSO at 0x7ffe087d4000                                                                                                                                                        
[Thread debugging using libthread_db enabled]                                                                                                                                                                                                              
Using host libthread_db library "/lib64/libthread_db.so.1".
0x00007f220c11585f in __GI___poll (fds=0x562e6f871100, nfds=10, timeout=44372) at ../sysdeps/unix/sysv/linux/poll.c:29
29        return SYSCALL_CANCEL (poll, fds, nfds, timeout);
(gdb) 
(gdb) continue
Continuing.
[Detaching after fork from child process 38390]
[New Thread 0x7f21a1da5640 (LWP 38397)]

[TRIGGERED CRASH]

Thread 1 "plasmashell" received signal SIGSEGV, Segmentation fault.
QQmlNotifierEndpoint::connect (this=0x562e6fbe3680, source=0x562e6fe72890, sourceSignal=47, engine=0x0, doNotify=<optimized out>) at qml/qqmlnotifier.cpp:122
122             QObjectPrivate::get(engine)->threadData.loadRelaxed()->threadId.loadRelaxed()) {
(gdb) bt all
No symbol "all" in current context.
(gdb) bt
#0  QQmlNotifierEndpoint::connect (this=0x562e6fbe3680, source=0x562e6fe72890, sourceSignal=47, engine=0x0, doNotify=<optimized out>) at qml/qqmlnotifier.cpp:122
#1  0x00007f220dbbc1b9 in QQmlVMEMetaObjectEndpoint::tryConnect (this=0x562e6fbe3680) at qml/qqmlvmemetaobject.cpp:258
#2  0x00007f220dbbc389 in QQmlVMEMetaObject::connectAlias (this=this@entry=0x562e6fa9fcc0, aliasId=aliasId@entry=1) at qml/qqmlvmemetaobject.cpp:1294
#3  0x00007f220dbbe412 in QQmlVMEMetaObject::metaCall (this=0x562e6fa9fcc0, o=<optimized out>, c=QMetaObject::ReadProperty, _id=<optimized out>, a=0x7ffe086ed0e0) at qml/qqmlvmemetaobject.cpp:906
#4  0x00007f220db01f25 in QQmlPropertyData::readProperty (property=0x7ffe086ed0c0, target=<optimized out>, this=0x7f21d8954328) at ../../include/QtQml/5.15.2/QtQml/private/../../../../../src/qml/qml/qqmlpropertydata_p.h:357
#5  loadProperty (v4=0x562e6cb7db40, object=0x562e6cb8a420, property=...) at jsruntime/qv4qobjectwrapper.cpp:152
#6  0x00007f21bc0308b3 in ?? ()
#7  0x00007ffe086ed330 in ?? ()
#8  0x000000000000000c in ?? ()
#9  0x00007f21bc0305e0 in ?? ()
#10 0x0000000000000000 in ?? ()
(gdb)
Comment 1 Nate Graham 2021-12-07 03:50:53 UTC

*** This bug has been marked as a duplicate of bug 427945 ***