Bug 444321

Summary: Dolphin crashed after archiving with .7z LZMA
Product: dolphin Reporter: Lyubomir <liubomirwm>
Component: generalAssignee: Dolphin Bug Assignee <dolphin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash CC: ismailsahillioglu, jodr666, kfm-devel
Priority: NOR Keywords: drkonqi
Version: 21.08.2   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: New crash information added by DrKonqi

Description Lyubomir 2021-10-24 12:42:45 UTC
Application: dolphin (21.08.2)

Qt Version: 5.15.2
Frameworks Version: 5.87.0
Operating System: Linux 5.13.0-20-lowlatency x86_64
Windowing System: Wayland
Distribution: Ubuntu 21.10
DrKonqi: 5.23.1 [KCrashBackend]

-- Information about the crash:
- What I was doing when the application crashed:
I was archiving with .7z LZMA on Maximum settings. It crashed when it finished.

The reporter is unsure if this crash is reproducible.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault

[KCrash Handler]
#4  std::__atomic_base<QObjectPrivate::Connection*>::load (__m=std::memory_order_acquire, this=0x51) at /usr/include/c++/11/bits/atomic_base.h:836
#5  std::atomic<QObjectPrivate::Connection*>::load (__m=std::memory_order_acquire, this=0x51) at /usr/include/c++/11/atomic:570
#6  QAtomicOps<QObjectPrivate::Connection*>::loadAcquire<QObjectPrivate::Connection*> (_q_value=...) at ../../include/QtCore/../../src/corelib/thread/qatomic_cxx11.h:251
#7  QBasicAtomicPointer<QObjectPrivate::Connection>::loadAcquire (this=0x51) at ../../include/QtCore/../../src/corelib/thread/qbasicatomic.h:255
#8  QObjectPrivate::maybeSignalConnected (this=this@entry=0x7f132c2c4cc0 <main_arena+96>, signalIndex=signalIndex@entry=6) at kernel/qobject.cpp:486
#9  0x00007f132c7dd5ef in doActivate<false> (sender=0x56543e054750, signal_index=6, argv=0x7ffcd1542fb0) at kernel/qobject.cpp:3788
#10 0x00007f132c7d6d67 in QMetaObject::activate (sender=sender@entry=0x56543e054750, m=<optimized out>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7ffcd1542fb0) at kernel/qobject.cpp:3946
#11 0x00007f132d9ddef0 in KJob::result (this=this@entry=0x56543e054750, _t1=<optimized out>, _t1@entry=0x56543e054750, _t2=...) at ./obj-x86_64-linux-gnu/src/lib/KF5CoreAddons_autogen/include/moc_kjob.cpp:633
#12 0x00007f132d9e23bb in KJob::finishJob (this=0x56543e054750, emitResult=<optimized out>) at ./src/lib/jobs/kjob.cpp:98
#13 0x00007f132c7dda53 in QtPrivate::QSlotObjectBase::call (a=0x7ffcd15430e0, r=0x56543e054750, this=0x56543e6c8b20) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#14 doActivate<false> (sender=0x56543e49a7a0, signal_index=10, argv=0x7ffcd15430e0) at kernel/qobject.cpp:3886
#15 0x00007f131c3ae8d6 in Kerfuffle::ReadOnlyArchiveInterface::finished(bool) () from /lib/x86_64-linux-gnu/libkerfuffle.so.21
#16 0x00007f132c7dda53 in QtPrivate::QSlotObjectBase::call (a=0x7ffcd15431f0, r=0x56543e49a7a0, this=0x56543de0d3e0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#17 doActivate<false> (sender=0x56543dd90040, signal_index=11, argv=0x7ffcd15431f0) at kernel/qobject.cpp:3886
#18 0x00007f132c7d6d67 in QMetaObject::activate (sender=sender@entry=0x56543dd90040, m=m@entry=0x7f132ca40da0 <QProcess::staticMetaObject>, local_signal_index=local_signal_index@entry=2, argv=argv@entry=0x7ffcd15431f0) at kernel/qobject.cpp:3946
#19 0x00007f132c70f34c in QProcess::finished (this=this@entry=0x56543dd90040, _t1=<optimized out>, _t2=<optimized out>) at .moc/moc_qprocess.cpp:339
#20 0x00007f132c714e63 in QProcessPrivate::_q_processDied (this=0x56543e498190) at io/qprocess.cpp:1184
#21 0x00007f132c714f9e in QProcess::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=0x7ffcd1543370) at io/qprocess.h:320
#22 0x00007f132c7dda88 in doActivate<false> (sender=0x56543e436ff0, signal_index=3, argv=0x7ffcd1543370) at kernel/qobject.cpp:3898
#23 0x00007f132c7d6d67 in QMetaObject::activate (sender=sender@entry=0x56543e436ff0, m=m@entry=0x7f132ca43180 <QSocketNotifier::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffcd1543370) at kernel/qobject.cpp:3946
#24 0x00007f132c7e0f63 in QSocketNotifier::activated (this=this@entry=0x56543e436ff0, _t1=..., _t2=<optimized out>, _t3=...) at .moc/moc_qsocketnotifier.cpp:178
#25 0x00007f132c7e1793 in QSocketNotifier::event (this=0x56543e436ff0, e=0x7ffcd1543490) at kernel/qsocketnotifier.cpp:302
#26 0x00007f132d2946b3 in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x56543e436ff0, e=0x7ffcd1543490) at kernel/qapplication.cpp:3632
#27 0x00007f132c7a616a in QCoreApplication::notifyInternal2 (receiver=0x56543e436ff0, event=0x7ffcd1543490) at kernel/qcoreapplication.cpp:1063
#28 0x00007f132c800155 in socketNotifierSourceDispatch (source=0x56543cc3ee60) at kernel/qeventdispatcher_glib.cpp:107
#29 0x00007f132a4028bb in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f132a455f08 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f132a400003 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f132c7ff548 in QEventDispatcherGlib::processEvents (this=0x56543cc3d0a0, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#33 0x00007f132c7a4a9b in QEventLoop::exec (this=this@entry=0x7ffcd15436a0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#34 0x00007f132c7ad024 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#35 0x00007f132cb80d10 in QGuiApplication::exec () at kernel/qguiapplication.cpp:1867
#36 0x00007f132d294629 in QApplication::exec () at kernel/qapplication.cpp:2824
#37 0x000056543c76faba in main (argc=<optimized out>, argv=<optimized out>) at ./src/main.cpp:222
[Inferior 1 (process 216844) detached]

The reporter indicates this bug may be a duplicate of or related to bug 443540.

Possible duplicates by query: bug 443540, bug 421600.

Reported using DrKonqi
Comment 1 Tony 2021-10-25 21:53:00 UTC

*** This bug has been marked as a duplicate of bug 443540 ***
Comment 2 ─░smail 2021-11-09 06:52:39 UTC
Created attachment 143360 [details]
New crash information added by DrKonqi

dolphin (21.08.3) using Qt 5.15.2

- What I was doing when the application crashed:
I was compressing a folder with 7zip with LZMA in max compression.

-- Backtrace (Reduced):
#6  std::__atomic_base<QObjectPrivate::Connection*>::load (__m=std::memory_order_acquire, this=0x51) at /usr/include/c++/11/bits/atomic_base.h:836
#7  std::atomic<QObjectPrivate::Connection*>::load (__m=std::memory_order_acquire, this=0x51) at /usr/include/c++/11/atomic:570
#8  QAtomicOps<QObjectPrivate::Connection*>::loadAcquire<QObjectPrivate::Connection*> (_q_value=...) at ../../include/QtCore/../../src/corelib/thread/qatomic_cxx11.h:251
#9  QBasicAtomicPointer<QObjectPrivate::Connection>::loadAcquire (this=0x51) at ../../include/QtCore/../../src/corelib/thread/qbasicatomic.h:255
#10 QObjectPrivate::maybeSignalConnected (this=this@entry=0x7ff410000080, signalIndex=signalIndex@entry=6) at kernel/qobject.cpp:486