Bug 444165

Summary: Desktop Overview Unhides Autohidden Panels on Waland
Product: kwin Reporter: Dashon <sparky123558wify>
Component: effects-overviewAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED FIXED    
Severity: normal CC: nate, sparky123558wify
Priority: NOR    
Version: 5.23.1   
Target Milestone: ---   
Platform: Archlinux Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Dashon 2021-10-21 03:49:31 UTC
SUMMARY
I wasn't sure how to describe this one. I know that desktop overview is still pretty new, so I'll do my best to describe the problem. On Xorg, when triggering the desktop overview, my top panel becomes almost completely transparent while the bottom panel becomes semi transparent. I guess this is for better visibility, but it still isn't quite perfect since the search bar seems to be on top of my top panel. When I exit the the desktop overview, the panels rehide themselves.On wayland however, both the panels become semi transparent when entering the overview, and neither of the panels rehide themselves upon exiting the overview. I end up having to use the mouse to touch both the top and bottom edges of my screen to rehide both the panels. I was wandering if this effect could not trigger the panels at all or somehow avoid them all together.

STEPS TO REPRODUCE
1. Have a autohiding panel
2. Switch to a wayland session
3. Enable and trigger the Desktop Overview Effect
4. Exit the overview effect

OBSERVED RESULT
Panel remains visibile.

EXPECTED RESULT
Panel should rehide itself like it does on Xorg or not be unhidden at all.


Operating System: EndeavourOS
KDE Plasma Version: 5.23.1
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.2
Kernel Version: 5.14.12-zen1-1-zen (64-bit)
Graphics Platform: Wayland
Processors: 4 × Intel® Core™ i7-7500U CPU @ 2.70GHz
Memory: 15.4 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 620