Bug 444038

Summary: When Spectacle is configured to not save the screenshot to default folder and copy it to clipboard, nothing happens when I try to take a screenshot via keyboard shortcut on Wayland
Product: Spectacle Reporter: Patrick Silva <bugseforuns>
Component: GeneralAssignee: Boudhayan Gupta <me>
Status: RESOLVED FIXED    
Severity: normal CC: kde, nate
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Neon Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Patrick Silva 2021-10-19 12:35:56 UTC
STEPS TO REPRODUCE
1. use Wayland session
2. make sure "Autosave file to default folder" is unchecked and "Copy image to clipboard" is selected in Spectacle settings
3. close Spectacle
4. try to take a screenshot by pressing shift+printscreen 

OBSERVED RESULT
nothing happens

EXPECTED RESULT
screenshot should be taken and copied to clipboard

SOFTWARE/OS VERSIONS
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.23.80
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.3
Graphics Platform: Wayland
Comment 1 Patrick Silva 2021-10-23 14:14:17 UTC
The issue here is that apparently nothing happens because the taken screenshot is not copied to clipboard and consequently Plasma does not display a notification.

*** This bug has been marked as a duplicate of bug 429390 ***
Comment 2 Patrick Silva 2021-10-24 00:16:31 UTC
Humm, the screenshot should be saved after the provided steps despite broken "Copy image to clipboard" feature. On X11, the screenshot is saved after the provided steps, but on Wayland the screenshot is only saved if "Autosave file to default folder" is checked in Spectacle settings.
Comment 3 Patrick Silva 2022-05-23 11:18:26 UTC
Currently the screenshot taken on Wayland via keyboard shortcut is saved even when "Save file to default folder" is unchecked in Spectacle settings.

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.25.80
KDE Frameworks Version: 5.95.0
Qt Version: 5.15.4
Graphics Platform: Wayland
Comment 4 Patrick Silva 2022-05-23 14:05:33 UTC
Additional comments:

When 'Save file to default folder' is unchecked and 'Copy image to clipboard' option is selected, a screenshot taken on Wayland via keyboard shortcut is NOT saved to default folder but is copied to clipboard.

The screenshot taken on Wayland via keyboard shortcut is saved to default folder when 'Save file to default folder' is unchecked and 'Copy file location to clipboard' option is selected instead of 'Copy image to clipboard'.

Editing the bug title according to original steps and 'observed result'.