Bug 441799

Summary: After pipewire runs for a while, chainging volume with the applet/keyboard shortcut induces heavy cracking. Doesn't happen with pavucontrol.
Product: [Plasma] plasma-pa Reporter: jakubby
Component: appletAssignee: David Rosca <nowrep>
Status: RESOLVED UPSTREAM    
Severity: normal CC: denilsonsa, jakubby, nate, plasma-bugs
Priority: NOR    
Version: 5.22.4   
Target Milestone: ---   
Platform: Arch Linux   
OS: Linux   
Latest Commit: Version Fixed In:

Description jakubby 2021-08-31 07:12:42 UTC
STEPS TO REPRODUCE
1. Let pipewire survive multiple sleep cycles and hours-days.

OBSERVED RESULT
Lag+crackling.

EXPECTED RESULT
Smooth volume change.



SOFTWARE/OS VERSIONS
Linux/KDE Plasma:  5.13.12
KDE Plasma Version: 5.22.4
KDE Frameworks Version: 5.85.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
Workaround:
1. killall pipewire[pipewire restarts]/restart the pipewire path/socket/service
2. restart apps that use audio, restart plasmashell+latte-dock
Comment 1 Nate Graham 2021-08-31 17:22:29 UTC
Cannot reproduce. However this would be caused by an issue upstream of any KDE code; we don't manipulate the audio stream at all. So you would want to report this at https://gitlab.freedesktop.org/pipewire/pipewire/-/issues