Bug 441062

Summary: Unnecessary daemon reload makes logout process longer when exiting Plasma session
Product: [Applications] kdeconnect Reporter: Timothy B <yule2000>
Component: commonAssignee: Albert Vaca <albertvaka>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Manjaro   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: Journal log at logout

Description Timothy B 2021-08-17 00:00:39 UTC
Created attachment 140784 [details]
Journal log at logout

SUMMARY
In a Plasma session, kdeconnectd (the KDE Connect daemon) gets automatically (re)launched by DBus immediately after the user logs out or initiates a shutdown, causing the logout process to be delayed.

STEPS TO REPRODUCE
1. Make sure that KDE Connect is installed in the system and already set up
2. Log out or shut down from Plasma as usual

OBSERVED RESULT
Immediately after the user clicks on "Log Out" or "Shutdown" in Plasma, the KDE Connect daemon is relaunched by DBus, as shown in the included journal log. As a result, the logout process gets delayed, i.e. the session would be stuck at a blank screen with a movable cursor longer than the user would expect, sometimes around 30 seconds or more.

EXPECTED RESULT
KDE Connect and its tray icon would exit as soon as the user clicks one of the aformentioned session control buttons, and its daemon doesn't get relaunched as the user logs out. The session would exit sooner than observed and therefore it spends less time at a blank screen.

SOFTWARE/OS VERSIONS
KDE Connect Version: 21.08.0
Operating System: Manjaro Linux
KDE Plasma Version: 5.22.4
KDE Frameworks Version: 5.84.0
Qt Version: 5.15.2
Kernel Version: 5.13.6-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 1600 Six-Core Processor
Memory: 15.6 GiB of RAM

ADDITIONAL INFORMATION
The session exited immediately when I switched to a TTY and ran `pkill kdeconnectd`, confirming the culprit of the long delays with logging out.

The attached journal log has QML and XCB error messages removed for your convenience.
Comment 1 Timothy B 2021-08-17 00:47:18 UTC
Oops, it turns out this has been already reported in bug #432643. Marking this a duplicate of the said ticket and closing this one.

*** This bug has been marked as a duplicate of bug 432643 ***