Bug 440345

Summary: org.kde.pim.kimap: The stream parser raised an exception: Unable to read more data
Product: [Frameworks and Libraries] Akonadi Reporter: Aaron Williams <aaronw>
Component: IMAP resourceAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: NOR    
Version: 5.17.80   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description Aaron Williams 2021-07-28 04:04:45 UTC
SUMMARY
I keep getting this message repeated over and over again, approximately once per second.
When I turned on IMAP debugging I found that a single email repeatedly causes this.  This email had a massive CC list.

What appears to be happening is something Akonadi does makes the IMAP server (Microsoft Office355) complain about a "Cc:" command.

C: A000005 CAPABILITY
S: * CAPABILITY IMAP4 IMAP4rev1 AUTH=PLAIN AUTH=XOAUTH2 SASL-IR UIDPLUS MOVE ID UNSELECT CLIENTACCESSRULES CLIENTNETWORKPRESENCELOCATION BACKENDAUTHENTICATE
CHILDREN IDLE NAMESPACE LITERAL+
S: A000005 OK CAPABILITY completed.
C: A000006 NAMESPACE
S: * NAMESPACE ( ("" "/") ) ( ) ( )
S: A000006 OK NAMESPACE completed.
C: A000007 ID ("name" "Kontact IMAP Resource")
S: * ID ( name Microsoft.Exchange.Imap4.Imap4Server version 15.20 )
S: A000007 OK ID completed
C: A000008 APPEND "INBOX" "27-Jul-2021 14:58:48 +0000" {110937}
S: + Ready for additional command text.
C: Received: from DM5PR1801MB1898.namprd18.prod.outlook.com (2603:10b6:4:6c::35) by BYAPR18MB2469.namprd18.prod.outlook.com with HTTPS; Tue, 27 Jul 2021 14:5
9:39 +0000
Received: from CO2PR04CA0074.namprd04.prod.outlook.com (2603:10b6:102:1::42) by DM5PR1801MB1898.namprd18.prod.outlook.com (2603:10b6:4:6c::35) with Microsoft
 SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.4352.29; Tue, 27 Jul 2021 14:59:30 +0000
Received: from MW2NAM04FT047.eop-NAM04.prod.protection.outlook.com (2603:10b6:102:1:cafe::2c) by CO2PR04CA0074.outlook.office365.com (2603:10b6:102:1::42) wi
th Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.4308.20 via Frontend Transport; Tue, 27 Jul 2021 14:59:30 +0
000C: A000005 CAPABILITY
S: * CAPABILITY IMAP4 IMAP4rev1 AUTH=PLAIN AUTH=XOAUTH2 SASL-IR UIDPLUS MOVE ID UNSELECT CLIENTACCESSRULES CLIENTNETWORKPRESENCELOCATION BACKENDAUTHENTICATE
CHILDREN IDLE NAMESPACE LITERAL+
S: A000005 OK CAPABILITY completed.
C: A000006 NAMESPACE
S: * NAMESPACE ( ("" "/") ) ( ) ( )
S: A000006 OK NAMESPACE completed.
C: A000007 ID ("name" "Kontact IMAP Resource")
S: * ID ( name Microsoft.Exchange.Imap4.Imap4Server version 15.20 )
S: A000007 OK ID completed
C: A000008 APPEND "INBOX" "27-Jul-2021 14:58:48 +0000" {110937}
S: + Ready for additional command text.
C: Received: from DM5PR1801MB1898.namprd18.prod.outlook.com (2603:10b6:4:6c::35) by BYAPR18MB2469.namprd18.prod.outlook.com with HTTPS; Tue, 27 Jul 2021 14:5
9:39 +0000
Received: from CO2PR04CA0074.namprd04.prod.outlook.com (2603:10b6:102:1::42) by DM5PR1801MB1898.namprd18.prod.outlook.com (2603:10b6:4:6c::35) with Microsoft
 SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.4352.29; Tue, 27 Jul 2021 14:59:30 +0000
Received: from MW2NAM04FT047.eop-NAM04.prod.protection.outlook.com (2603:10b6:102:1:cafe::2c) by CO2PR04CA0074.outlook.office365.com (2603:10b6:102:1::42) wi
th Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.4308.20 via Frontend Transport; Tue, 27 Jul 2021 14:59:30 +0
000
...

S: Cc: BAD Command Error. 10
X


I have the entire log entry but I do not wish to include it here for obvious reasons since it contains hundreds of email addresses if not more.

When this happens I am unable to download any new email.

Restarting akonadi does not fix this.


SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: OpenSUSE 15.2
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 5.84.0
Qt Version: 5.15.2
Akonadi version: 21.07.80

ADDITIONAL INFORMATION
Comment 1 Aaron Williams 2021-08-10 16:59:42 UTC

*** This bug has been marked as a duplicate of bug 401054 ***