Bug 437179

Summary: Dolphin sometimes crashed when creating a folder on a network share
Product: [Applications] dolphin Reporter: Raindrops <raindrops>
Component: generalAssignee: Dolphin Bug Assignee <dolphin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash CC: kfm-devel, sitter
Priority: NOR Keywords: drkonqi
Version: 20.12.2   
Target Milestone: ---   
Platform: Fedora RPMs   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:

Description Raindrops 2021-05-15 22:16:57 UTC
Application: dolphin (20.12.2)

Qt Version: 5.15.2
Frameworks Version: 5.81.0
Operating System: Linux 5.11.19-300.fc34.x86_64 x86_64
Windowing System: X11
Drkonqi Version: 5.21.5
Distribution: Fedora 34 (KDE Plasma)

-- Information about the crash:
- What I was doing when the application crashed:
I was creating a new folder in a SMB network share and Dolphin crashed

- Custom settings of the application:
Enabled previews for remote files under 2 MiB, disabling previews for remote files seems to fix the problem

The reporter is unsure if this crash is reproducible.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault

[KCrash Handler]
#4  0x00007ff36bcae469 in QLineEdit::text() const () from /lib64/libQt5Widgets.so.5
#5  0x00007ff36cdff9b8 in QtPrivate::QFunctorSlotObject<KNewFileMenuPrivate::_k_slotTextChanged(QString const&)::{lambda(KJob*)#3}, 1, QtPrivate::List<KJob*>, void>::impl(int, QtPrivate::QSlotObjectBase*, QObject*, void**, bool*) [clone .lto_priv.0] () from /lib64/libKF5KIOFileWidgets.so.5
#6  0x00007ff36b03d4b0 in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
#7  0x00007ff36c16f350 in KJob::result(KJob*, KJob::QPrivateSignal) () from /lib64/libKF5CoreAddons.so.5
#8  0x00007ff36c17380b in KJob::finishJob(bool) () from /lib64/libKF5CoreAddons.so.5
#9  0x00007ff36b03d4b0 in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
#10 0x00007ff36c9495aa in KIO::SlaveInterface::error(int, QString const&) () from /lib64/libKF5KIOCore.so.5
#11 0x00007ff36c948dd7 in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /lib64/libKF5KIOCore.so.5
#12 0x00007ff36c9412fd in KIO::SlaveInterface::dispatch() () from /lib64/libKF5KIOCore.so.5
#13 0x00007ff36c94a862 in KIO::Slave::gotInput() () from /lib64/libKF5KIOCore.so.5
#14 0x00007ff36b03d4b0 in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
#15 0x00007ff36b034257 in QObject::event(QEvent*) () from /lib64/libQt5Core.so.5
#16 0x00007ff36bb6be73 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#17 0x00007ff36b00cf48 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#18 0x00007ff36b00fc76 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /lib64/libQt5Core.so.5
#19 0x00007ff36b059c57 in postEventSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib64/libQt5Core.so.5
#20 0x00007ff368eeb4cf in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#21 0x00007ff368f3f4e8 in g_main_context_iterate.constprop () from /lib64/libglib-2.0.so.0
#22 0x00007ff368ee8c03 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#23 0x00007ff36b0596f8 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#24 0x00007ff36b00b9b2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#25 0x00007ff36b013544 in QCoreApplication::exec() () from /lib64/libQt5Core.so.5
#26 0x00007ff36d1bcd3d in kdemain () from /lib64/libkdeinit5_dolphin.so
#27 0x00007ff36cfbdb75 in __libc_start_main () from /lib64/libc.so.6
#28 0x0000557e917550ae in _start ()
[Inferior 1 (process 32490) detached]

Possible duplicates by query: bug 436863, bug 435427, bug 432084, bug 431077, bug 429973.

Reported using DrKonqi
Comment 1 Harald Sitter 2021-07-08 09:42:39 UTC

*** This bug has been marked as a duplicate of bug 433347 ***