Bug 434821

Summary: Breeze taskbar does not put enough emphasis on the focused app
Product: plasmashell Reporter: frederic.parrenin <frederic.parrenin>
Component: Theme - BreezeAssignee: visual-design
Status: RESOLVED FIXED    
Severity: normal CC: nate, plasma-bugs
Priority: NOR    
Version: 5.20.5   
Target Milestone: 1.0   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In: 5.90
Attachments: .png screenshot of the taskbar
.png screenshot of the proposed taskbar
.png screenshot of the Windows 10 taskbar
.png screenshot of the proposed taskbar
.png screenshot of the proposed taskbar
.png screenshot of the proposed taskbar
.svgz file for the taskbar theme
.png screenshot of the proposed taskbar

Description frederic.parrenin@univ-grenoble-alpes.fr 2021-03-23 07:49:33 UTC
Created attachment 136976 [details]
.png screenshot of the taskbar

SUMMARY
I find that the Breeze theme does not put enough emphasis on the focused app in the taskbar.
The emphasis is put with a light blue, compared with a light grey for the other app.
There are many app using the blue in their icon, so I always have an hard time deciphering the focused app at a glance.
I attach a screenshot to illustrate the problem.
I am not sure what the best solution for this would be.
Maybe using a middle grey for the background would be more consistent with the light grey which is used to illustrated opened apps. Plus, the grey is not often used as a color for icons.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Debian 11 Bullseye 
KDE Plasma Version: 5.20.5
Comment 1 Nate Graham 2021-03-23 12:38:42 UTC
> I am not sure what the best solution for this would be.
Indeed, me neither. :) The current appearance is the result of a lot of tweaking and compromise over time.

If we changed the background to gray, that would make the selected app *less* distinct, no? And then we'd have to change the background color for open and not minimized apps, to avoid them both have a very similar if not identical appearance.

I think the bottom line is that absent any genius ideas for improvement (which I certainly don't have either lol) this is going to have to stay the way it is. :) But thanks for the bug report anyway!
Comment 2 frederic.parrenin@univ-grenoble-alpes.fr 2021-03-23 13:02:43 UTC
> If we changed the background to gray, that would make the selected app *less* distinct, no? And then we'd have to change the background color for open and not minimized apps, to avoid them both have a very similar if not identical appearance.

I think the problem is that the grey background for opened apps and the blue background for the focused app have a similar light, hence it is difficult to decipher them quickly.

My suggestion would be to use something darker for the focused app.
The problem to use a darker blue is that many app have blue in their icon, so that might be confusing.
So my suggestion was to use a darker grey.

An alternative would be to color only the top bar of the area in, e.g., dark blue, for the focused app.

I am not sure that would be a solution, but if there is an easy way to try a different color for the background or top bar of the focused app, I am willing to do the test.
Comment 3 Nate Graham 2021-03-23 14:30:15 UTC
Sure, feel free to play around with /usr/share/plasma/desktoptheme/default/widgets/tasks.svgz

(Source code lives at https://invent.kde.org/frameworks/plasma-framework/-/blob/master/src/desktoptheme/breeze/widgets/tasks.svg)
Comment 4 frederic.parrenin@univ-grenoble-alpes.fr 2021-03-23 16:07:46 UTC
Thanks for the tip.

I understood the different columns are for the position of the panel (bottom, top, left or right).
But could you please explain what are the different lines in this .svgz file?
If I understood correctly, line 6 is for the simple launchers, line 3 is for the opened apps and line 2 is for the focused app.
What are lines 1, 4 and 5 for?
Sorry for the basic question, I am new to KDE.

Also, I still have difficulties to test the backgrounds by modifying the .svgz file using Inkscape.
Sometimes, when I do a change on a rectangle object, it has an effect when I restart the shell, sometimes, it does not.
(I restart by doing a "kquitapp5 plasmashell" and then a "kstart5 plasmashell")
Comment 5 Nate Graham 2021-03-23 16:11:35 UTC
Explaining SVG theming is a bit beyond the scope of what we can do in a bug report. This video might help though: https://www.youtube.com/watch?v=3K4EP1KSC6k
Comment 6 frederic.parrenin@univ-grenoble-alpes.fr 2021-03-23 16:54:47 UTC
Created attachment 136991 [details]
.png screenshot of the proposed taskbar

Thanks for the video link.

So my suggestion is to not use the top-bar for the "normal" icons (those of opened apps).
You can still distinguish them from normal launchers since the background is darker.
But it gives more emphasis on the focused app.
I attach a screenshot to illustrate.

PS: I still don't understand why modifying the opacity of the normal-top object has no effect.
Comment 7 Nate Graham 2021-03-23 17:18:55 UTC
How would minimized status be communicated?
Comment 8 frederic.parrenin@univ-grenoble-alpes.fr 2021-03-23 17:21:50 UTC
> How would minimized status be communicated?

Do they really need to be communicated?
Personally, I do not care about minimized apps.
Comment 9 Nate Graham 2021-03-23 17:31:53 UTC
You may not, but that's not a luxury we developers have when it comes with our several million users. We can't just delete something that many or even most of them rely on or use daily because you don't personally use it. This is why development is hard: you have to find a way to cater to everyone, not just one person.

If you have it the way you want it at this point, great! Feel free to just keep it that way on your system.
Comment 10 frederic.parrenin@univ-grenoble-alpes.fr 2021-03-23 18:03:25 UTC
I understand your point, it is more difficult to be a developer and take decision with big impacts than to just comment on your own feelings.
Thanks you for your work!

However, for your information, Windows 10 does not seem to communicate on minimized apps and use the top bar only for the focused app.
I am not saying Windows 10 is always perfect, but they certainly have done many usability studies and they have billions of users.

The problem now IMO is that the focused app does not attract enough attention.
There might be a way to accommodate everybody, I will try to think more about it.
Comment 11 Nate Graham 2021-03-23 18:28:53 UTC
You're welcome. :) FWIW the Windows taskbar does communicate minimized status: the item's background disappears, and the colored bar on the bottom shrinks a bit.
Comment 12 frederic.parrenin@univ-grenoble-alpes.fr 2021-03-23 18:45:02 UTC
Created attachment 136997 [details]
.png screenshot of the Windows 10 taskbar

Regarding the Windows 10 taskbar, in the attached screenshot you have the file manager which is not focused, and OnlyOffice which is minimized.
I don't see any difference in the way they are displayed: the background and the bottom bars look the same.
It is exactly what I propose, having the same visual for opened apps and minimized apps.
The lighter background (and not the top bar as I wrote before) is used only for the focused app, which gives a stronger emphasis.
Comment 13 Nate Graham 2021-03-23 18:51:12 UTC
Oh interesting. I guess you're right. That's kind of weird IMO.
Comment 14 frederic.parrenin@univ-grenoble-alpes.fr 2021-03-25 10:19:24 UTC
Created attachment 137049 [details]
.png screenshot of the proposed taskbar

After a few days I became quite used to the subtle color scheme of the KDE taskbar, so I do not see the issue as big as before.

Still, I wanted to share an experiment I did by increasing the opacity of the "focus" state. It might be a bit more usable, with the downside that the colors are a bit less harmonious.
Comment 15 frederic.parrenin@univ-grenoble-alpes.fr 2021-03-25 11:06:51 UTC
Created attachment 137050 [details]
.png screenshot of the proposed taskbar

Another idea with a square surrounding the icon which puts even more emphasis.
Comment 16 frederic.parrenin@univ-grenoble-alpes.fr 2021-03-25 11:22:53 UTC
Created attachment 137051 [details]
.png screenshot of the proposed taskbar

Same idea with the square surrounding, but with the original color scale.
Comment 17 Nate Graham 2021-03-25 18:32:40 UTC
You know, I don't mind that "greater opacity" idea. I think that might actually look pretty nice.

Would you be interested in submitting it as a merge request at https://invent.kde.org/frameworks/plasma-framework/-/merge_requests/? We could see if KDE's VDG members like it as well.
Comment 18 frederic.parrenin@univ-grenoble-alpes.fr 2021-03-25 18:48:40 UTC
Thanks Nate.
What do you think about the surrounding square?
I have to say that I personally like it, but I don't know if that would impact the general consistency of the theme.
Anyway, I can submit the two options.
I think it makes sense to also put more emphasis on the "attention" state, but maybe not on the "progress" state.
Comment 19 Nate Graham 2021-03-25 18:51:54 UTC
I think the square outline might be a bit too bold in its current form. Maybe it might be better if the newly-added border lines are much thinner, and only the already-there line keeps its current thickness.
Comment 20 frederic.parrenin@univ-grenoble-alpes.fr 2021-03-26 09:55:53 UTC
Created attachment 137071 [details]
.svgz file for the taskbar theme

I tried to post the merge request, but apparently I do not have the right to do so. So I am posting it here. This is for the approach with the enhanced opacity.
Comment 21 Nate Graham 2021-03-26 10:13:09 UTC
You need to sign up for an account at identity.kde.org. Full instructions can be found at https://community.kde.org/Infrastructure/GitLab. Let me know if I can help you through that.
Comment 22 frederic.parrenin@univ-grenoble-alpes.fr 2021-03-26 11:09:29 UTC
I see the link at the bottom of the merge request page "Email a new merge request to this project" and I sent the email.
But I got an response that it was rejected:

"Unfortunately, your email message to GitLab could not be processed.
You are not allowed to perform this action. If you believe this is in error, contact a staff member."

I did use the correct email address to post.
Comment 23 Nate Graham 2021-03-26 15:28:19 UTC
I don't recommend using the email merge request feature. As you can see, it's not reliable. :) It's trying to abstract away a bunch of stuff that IMO can't really be abstracted away. The instructions I provided should work a lot better. :)
Comment 24 frederic.parrenin@univ-grenoble-alpes.fr 2021-03-29 08:18:48 UTC
So I sent the merge request 2 days ago:
https://invent.kde.org/frameworks/plasma-framework/-/merge_requests/223
Please be indulgent since this is my very first merge request. :-)
Comment 25 Nate Graham 2021-03-30 14:36:43 UTC
Thanks, great job! I will review it soon.
Comment 26 frederic.parrenin@univ-grenoble-alpes.fr 2021-12-03 13:54:17 UTC
So, following the discussion of the zero-dot users, I have a proposition for the taskbar.
Normal -> Top bar, but no background
Minimized -> Bottom bar, no background
The rest -> as is

This would allow to have the same background for almost all icons, so it would give more attention to the focus, attention and progress states.
I have tried to implement this but I have difficulties to understand how the theme engine works.
Comment 27 frederic.parrenin@univ-grenoble-alpes.fr 2021-12-03 15:16:43 UTC
Created attachment 144172 [details]
.png screenshot of the proposed taskbar
Comment 28 Nate Graham 2021-12-03 15:58:33 UTC
Can we focus on getting your existing merge request merged first? It's marked as accepted, but cannot be merged as there is a merge conflict. If you fix that, then we can merge it and then iterate on a new styling.
Comment 29 frederic.parrenin@univ-grenoble-alpes.fr 2021-12-03 17:26:08 UTC
Well, I think the current proposition makes the old proposition obsolete.
Indeed, by removing the background of the normal and minimized states, it puts more emphasis on the focus, attention and progress states.
So I would suggest to discuss the current proposition first.
The good news is that today, I discovered how to modify the .svg file without messing up everything, so I can finish the merge request properly next time.
Comment 30 Nate Graham 2021-12-10 17:36:30 UTC
Git commit 7feec7ce65c1f50f8ac788dd03f7a545c1ce1d78 by Nate Graham, on behalf of Frédéric Parrenin.
Committed on 10/12/2021 at 17:36.
Pushed by ngraham into branch 'master'.

widgets/tasks.svgz: Use more saturated colors for the focus and attention states

This way they stand out a bit more from the "running" and "minimized" states.
FIXED-IN: 5.90

M  +72   -72   src/desktoptheme/breeze/widgets/tasks.svg

https://invent.kde.org/frameworks/plasma-framework/commit/7feec7ce65c1f50f8ac788dd03f7a545c1ce1d78