Bug 426788

Summary: Flatpak gtk applications opens without the breeze gtk theme
Product: [Applications] systemsettings Reporter: viniciusbr <viniciusbrbio>
Component: kcm_styleAssignee: Plasma Bugs List <plasma-bugs>
Status: REPORTED ---    
Severity: normal CC: aleixpol, jgrulich, kde, luca.bacci, mail, nate, postix, r9290x, sitter
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Neon   
OS: Linux   
See Also: https://bugs.kde.org/show_bug.cgi?id=432756
https://bugs.kde.org/show_bug.cgi?id=418936
Latest Commit: Version Fixed In:

Description viniciusbr 2020-09-21 00:05:46 UTC
Hi,

Some gtk applications, as gpodder, opens without the breeze gtk theme, despite I have already selected it in the system settings. So, I need to open the config and apply it again.
Comment 1 Nate Graham 2020-09-23 17:21:33 UTC
And then it works? Does this happen in any other apps?
Comment 2 viniciusbr 2020-09-23 17:34:46 UTC
Them it works. I noticed on gpodder because it is the gtk app that I use the most ... the other apps in gtk are using flatpak, but I will open my eyes these days.
Comment 3 Nate Graham 2020-09-23 20:05:54 UTC
Is gpodder a flatpak app or does it come from your distro's package repo?
Comment 4 viniciusbr 2020-09-23 21:09:07 UTC
Good question. In fact I have both (runned from source and flatpak) and the problem that I'm listing here was in the flatpak one. This is odd... can I change the flatpaks theme in the system settings?
Comment 5 Bug Janitor Service 2020-10-08 04:33:13 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 6 Christoph Feck 2020-10-15 06:02:27 UTC
New information was added with comment 4; changing status for inspection.
Comment 7 Nate Graham 2020-10-16 23:43:57 UTC
FWIW it's working for me with my flatpak GTK apps.

Does anyone know what's needed to get Flatpak GTK apps to pick up the theme here?
Comment 8 Harald Sitter 2020-10-20 10:10:58 UTC
Maybe a bug in the portal?

I'm guessing the set theme is read through the Settings portal so if it starts working after reapplying the theme in systemsettings then I'd guess the portal is the first thing to blame.
Comment 9 soredake 2021-01-04 09:33:39 UTC
Any progress on this?
Comment 10 Nate Graham 2021-02-11 16:26:09 UTC
*** Bug 432756 has been marked as a duplicate of this bug. ***
Comment 12 Paul McAuley 2021-02-18 13:39:37 UTC
(In reply to Nate Graham from comment #10)
> *** Bug 432756 has been marked as a duplicate of this bug. ***

Not sure that that bug is a duplicate. My issue is that Flatpak CSD apps are ALWAYS opening with the Breeze window decorations, even when another window decoration is selected.
Comment 13 Hasshu 2022-05-21 17:12:01 UTC
Plasma 5.24.5 here, and this annoying issue persists: once every few reboots, some GTK-based software installed via Flatpak would get its appearance reset to default. Manually reapplying the GTK theme via the System Settings is enough to fix both the theme and the font(s) instantly. At times, it also can be fixed by simply rebooting the system, as the breakage seems to take place during startup.

Oddly enough, it doesn't seem to affect all software equally. For example, there was at least one time when Firefox (the primary offender) forgot its appearance settings, but LibreOffice (also GTK) did not.
Comment 14 Hasshu 2022-11-30 10:39:23 UTC
At some point I noticed that the aforementioned issue of mine affects the static build of Tor Browser as well, so it's not exclusive to Flatpak. Apparently, it's caused by xsettingsd randomly deciding not to run on startup. Manually toggling the GTK theme in the System Settings does start xsettingsd, but having to do that is a nuisance.

Any suggestions as to what could be causing it, and/or where should it be reported?
Comment 15 Luca Bacci 2023-02-27 20:44:10 UTC
Interesting, I'm going to investigate on this!

I seem to recall that Flatpak enables access to themes installed in the host system, but only those that are installed per-user under $HOME; themes placed under /use/share/themes aren't exposed.

Theoretically speaking, Flatpak shouldn't expose system themes to sandboxed applications because incompatibilities may arise. It would be best to install Breeze as a Flatpak package. Breeze Flatpak should be versioned for each KDE major.minor release (for example, 5.27) and System Settings should install Breeze Flatpak matching the KDE install on the base system.

However that can become complicated. For example, when upgrading KDE versions Breeze Flatpak should also be upgraded.