Bug 424767

Summary: Dolphin crashes when closing with multiple tabs open
Product: [Applications] konsole Reporter: Matthias Mailänder <matthias>
Component: generalAssignee: Konsole Developer <konsole-devel>
Status: RESOLVED WORKSFORME    
Severity: crash CC: kfm-devel
Priority: NOR Keywords: drkonqi
Version: 20.04.2   
Target Milestone: ---   
Platform: openSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description Matthias Mailänder 2020-07-28 21:36:51 UTC
Application: dolphin (20.04.2)

Qt Version: 5.12.7
Frameworks Version: 5.71.0
Operating System: Linux 5.3.18-lp152.33-default x86_64
Windowing system: X11
Distribution: "openSUSE Leap 15.2"

-- Information about the crash:
- What I was doing when the application crashed:
Multiple tabs were open. It asked me if I want to close them all. The crash dialog appears. As I am closing anyway I don't mind the crash, but the wizard said the debug info is helpful so here you go.

The crash can be reproduced sometimes.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8e83867900 (LWP 6446))]

Thread 4 (Thread 0x7f8e5a07f700 (LWP 21601)):
#0  0x00007f8e830f16db in poll () from /lib64/libc.so.6
#1  0x00007f8e76de3f71 in ?? () from /usr/lib64/libpulse.so.0
#2  0x00007f8e76dd5b10 in pa_mainloop_poll () from /usr/lib64/libpulse.so.0
#3  0x00007f8e76dd61a0 in pa_mainloop_iterate () from /usr/lib64/libpulse.so.0
#4  0x00007f8e76dd6230 in pa_mainloop_run () from /usr/lib64/libpulse.so.0
#5  0x00007f8e76de3eb9 in ?? () from /usr/lib64/libpulse.so.0
#6  0x00007f8e72217018 in ?? () from /usr/lib64/pulseaudio/libpulsecommon-13.0.so
#7  0x00007f8e772224f9 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f8e830fbf2f in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f8e69145700 (LWP 6449)):
#0  0x00007f8e830f16db in poll () from /lib64/libc.so.6
#1  0x00007f8e74a9c779 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f8e74a9c88c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f8e7cd4619b in QEventDispatcherGlib::processEvents (this=0x55eedbe10f90, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f8e7cce732a in QEventLoop::exec (this=this@entry=0x7f8e69144c80, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#5  0x00007f8e7cb0d10a in QThread::exec (this=<optimized out>) at thread/qthread.cpp:531
#6  0x00007f8e7d1b6cd5 in ?? () from /usr/lib64/libQt5DBus.so.5
#7  0x00007f8e7cb0e8b2 in QThreadPrivate::start (arg=0x7f8e7d42ed80) at thread/qthread_unix.cpp:361
#8  0x00007f8e772224f9 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f8e830fbf2f in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f8e6ae70700 (LWP 6448)):
#0  0x00007f8e830f16db in poll () from /lib64/libc.so.6
#1  0x00007f8e77649307 in ?? () from /usr/lib64/libxcb.so.1
#2  0x00007f8e7764af3a in xcb_wait_for_event () from /usr/lib64/libxcb.so.1
#3  0x00007f8e6dc65300 in ?? () from /usr/lib64/libQt5XcbQpa.so.5
#4  0x00007f8e7cb0e8b2 in QThreadPrivate::start (arg=0x55eedbd73410) at thread/qthread_unix.cpp:361
#5  0x00007f8e772224f9 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f8e830fbf2f in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f8e83867900 (LWP 6446)):
[KCrash Handler]
#4  0x00007f8e5f32c98f in Konsole::SessionController::<lambda()>::operator() (__closure=<optimized out>) at /usr/src/debug/konsole-20.04.2-lp152.1.1.x86_64/src/SessionController.cpp:1693
#5  QtPrivate::FunctorCall<QtPrivate::IndexesList<>, QtPrivate::List<>, void, Konsole::SessionController::showDisplayContextMenu(const QPoint&)::<lambda()> >::call (arg=<optimized out>, f=...) at /usr/include/qt5/QtCore/qobjectdefs_impl.h:146
#6  QtPrivate::Functor<Konsole::SessionController::showDisplayContextMenu(const QPoint&)::<lambda()>, 0>::call<QtPrivate::List<>, void> (arg=<optimized out>, f=...) at /usr/include/qt5/QtCore/qobjectdefs_impl.h:256
#7  QtPrivate::QFunctorSlotObject<Konsole::SessionController::showDisplayContextMenu(const QPoint&)::<lambda()>, 0, QtPrivate::List<>, void>::impl(int, QtPrivate::QSlotObjectBase *, QObject *, void **, bool *) (which=<optimized out>, this_=<optimized out>, r=<optimized out>, a=<optimized out>, ret=<optimized out>) at /usr/include/qt5/QtCore/qobjectdefs_impl.h:439
#8  0x00007f8e7cd18d0f in QtPrivate::QSlotObjectBase::call (a=0x7ffd557ec7b0, r=0x55eedc400e30, this=0x55eedc8f1ce0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#9  QMetaObject::activate (sender=sender@entry=0x55eedc400e30, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffd557ec7b0) at kernel/qobject.cpp:3784
#10 0x00007f8e7cd19307 in QMetaObject::activate (sender=sender@entry=0x55eedc400e30, m=m@entry=0x7f8e7d18f960 <QObject::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffd557ec7b0) at kernel/qobject.cpp:3657
#11 0x00007f8e7cd193af in QObject::destroyed (this=this@entry=0x55eedc400e30, _t1=<optimized out>, _t1@entry=0x55eedc400e30) at .moc/moc_qobject.cpp:218
#12 0x00007f8e7cd206b9 in QObject::~QObject (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:912
#13 0x00007f8e5f3365f8 in Konsole::SessionController::~SessionController (this=0x55eedc400e30, __in_chrg=<optimized out>) at /usr/src/debug/konsole-20.04.2-lp152.1.1.x86_64/src/SessionController.cpp:233
#14 0x00007f8e5f336699 in Konsole::SessionController::~SessionController (this=0x55eedc400e30, __in_chrg=<optimized out>) at /usr/src/debug/konsole-20.04.2-lp152.1.1.x86_64/src/SessionController.cpp:243
#15 0x00007f8e7cd1680b in QObjectPrivate::deleteChildren (this=this@entry=0x55eedc4bbaf0) at kernel/qobject.cpp:2017
#16 0x00007f8e7cd203bb in QObject::~QObject (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:1033
#17 0x00007f8e5f35ff69 in Konsole::ViewManager::~ViewManager (this=0x55eedc4bba70, __in_chrg=<optimized out>) at /usr/src/debug/konsole-20.04.2-lp152.1.1.x86_64/src/ViewManager.h:63
#18 0x00007f8e5f607dce in Konsole::Part::~Part (this=0x55eedc11dbf0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/konsole-20.04.2-lp152.1.1.x86_64/src/Part.cpp:90
#19 0x00007f8e5f607e29 in Konsole::Part::~Part (this=0x55eedc11dbf0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/konsole-20.04.2-lp152.1.1.x86_64/src/Part.cpp:91
#20 0x00007f8e7cd1680b in QObjectPrivate::deleteChildren (this=this@entry=0x55eedc0aad80) at kernel/qobject.cpp:2017
#21 0x00007f8e7e02271c in QWidget::~QWidget (this=0x55eedc0aace0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1696
#22 0x00007f8e83437459 in TerminalPanel::~TerminalPanel (this=0x55eedc0aace0, __in_chrg=<optimized out>) at /usr/src/debug/dolphin-20.04.2-lp152.1.1.x86_64/src/panels/terminal/terminalpanel.cpp:61
#23 0x00007f8e7cd1680b in QObjectPrivate::deleteChildren (this=this@entry=0x55eedc0a6fd0) at kernel/qobject.cpp:2017
#24 0x00007f8e7e02271c in QWidget::~QWidget (this=0x55eedc0a31e0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1696
#25 0x00007f8e83464f21 in DolphinDockWidget::~DolphinDockWidget (this=0x55eedc0a31e0, __in_chrg=<optimized out>) at /usr/src/debug/dolphin-20.04.2-lp152.1.1.x86_64/src/dolphindockwidget.cpp:61
#26 DolphinDockWidget::~DolphinDockWidget (this=0x55eedc0a31e0, __in_chrg=<optimized out>) at /usr/src/debug/dolphin-20.04.2-lp152.1.1.x86_64/src/dolphindockwidget.cpp:63
#27 0x00007f8e7cd1680b in QObjectPrivate::deleteChildren (this=this@entry=0x55eedbf098c0) at kernel/qobject.cpp:2017
#28 0x00007f8e7e02271c in QWidget::~QWidget (this=0x55eedbf16da0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1696
#29 0x00007f8e80685d5d in KMainWindow::~KMainWindow (this=0x55eedbf16da0, __in_chrg=<optimized out>) at /usr/src/debug/kxmlgui-5.71.0-lp152.1.1.x86_64/src/kmainwindow.cpp:417
#30 0x00007f8e83414f58 in DolphinMainWindow::~DolphinMainWindow (this=0x55eedbf16da0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/dolphin-20.04.2-lp152.1.1.x86_64/src/dolphinmainwindow.cpp:212
#31 0x00007f8e83414fa9 in DolphinMainWindow::~DolphinMainWindow (this=0x55eedbf16da0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/dolphin-20.04.2-lp152.1.1.x86_64/src/dolphinmainwindow.cpp:214
#32 0x00007f8e7cd197c0 in QObject::event (this=this@entry=0x55eedbf16da0, e=e@entry=0x55eedd2e8840) at kernel/qobject.cpp:1252
#33 0x00007f8e7e026f23 in QWidget::event (this=this@entry=0x55eedbf16da0, event=event@entry=0x55eedd2e8840) at kernel/qwidget.cpp:9409
#34 0x00007f8e7e130880 in QMainWindow::event (this=this@entry=0x55eedbf16da0, event=event@entry=0x55eedd2e8840) at widgets/qmainwindow.cpp:1339
#35 0x00007f8e80688121 in KMainWindow::event (this=this@entry=0x55eedbf16da0, ev=ev@entry=0x55eedd2e8840) at /usr/src/debug/kxmlgui-5.71.0-lp152.1.1.x86_64/src/kmainwindow.cpp:885
#36 0x00007f8e806c9597 in KXmlGuiWindow::event (this=0x55eedbf16da0, ev=0x55eedd2e8840) at /usr/src/debug/kxmlgui-5.71.0-lp152.1.1.x86_64/src/kxmlguiwindow.cpp:121
#37 0x00007f8e7dfe6a0c in QApplicationPrivate::notify_helper (this=this@entry=0x55eedbd50c50, receiver=receiver@entry=0x55eedbf16da0, e=e@entry=0x55eedd2e8840) at kernel/qapplication.cpp:3701
#38 0x00007f8e7dfee020 in QApplication::notify (this=0x7ffd557ed490, receiver=0x55eedbf16da0, e=0x55eedd2e8840) at kernel/qapplication.cpp:3447
#39 0x00007f8e7cce90d8 in QCoreApplication::notifyInternal2 (receiver=0x55eedbf16da0, event=0x55eedd2e8840) at kernel/qcoreapplication.cpp:1088
#40 0x00007f8e7cce92ae in QCoreApplication::sendEvent (receiver=<optimized out>, event=event@entry=0x55eedd2e8840) at kernel/qcoreapplication.cpp:1476
#41 0x00007f8e7ccebc97 in QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x55eedbd46bb0) at kernel/qcoreapplication.cpp:1825
#42 0x00007f8e7ccec238 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1679
#43 0x00007f8e7cd46b63 in postEventSourceDispatch (s=0x55eedbe96ae0) at kernel/qeventdispatcher_glib.cpp:276
#44 0x00007f8e74a9c464 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#45 0x00007f8e74a9c800 in ?? () from /usr/lib64/libglib-2.0.so.0
#46 0x00007f8e74a9c88c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#47 0x00007f8e7cd4617f in QEventDispatcherGlib::processEvents (this=0x55eedbd56360, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#48 0x00007f8e7cce732a in QEventLoop::exec (this=this@entry=0x7ffd557ed3a0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#49 0x00007f8e7ccf0530 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1389
#50 0x00007f8e8340549f in kdemain (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/dolphin-20.04.2-lp152.1.1.x86_64/src/main.cpp:172
#51 0x00007f8e8302434a in __libc_start_main () from /lib64/libc.so.6
#52 0x000055eedb09380a in _start () at ../sysdeps/x86_64/start.S:120
[Inferior 1 (process 6446) detached]

Possible duplicates by query: bug 424760, bug 424232, bug 424171, bug 424122, bug 423729.

Reported using DrKonqi
Comment 1 Justin Zobel 2022-10-12 03:50:02 UTC
Thank you for reporting this crash in KDE software. As it has been a while since this issue was reported, can we please ask you to see if you can reproduce the crash with a recent software version?

If you can reproduce the issue, please change the status to "CONFIRMED" when replying. Thank you!
Comment 2 Matthias Mailänder 2022-10-13 17:10:39 UTC
Dolphin Version 22.08.1 on Arch Linux does not crash when closing multiple tabs.