Bug 422629

Summary: Ability to disable "smooth scrolling", or at least recognize PageUp/PageDown during "smooth scrolling"
Product: [Applications] okular Reporter: Alexander Ewering <ae>
Component: generalAssignee: Okular developers <okular-devel>
Status: RESOLVED DUPLICATE    
Severity: wishlist CC: aacid, keziolio123, oliver.sander
Priority: NOR    
Version: 1.10.1   
Target Milestone: ---   
Platform: Other   
OS: Linux   
See Also: https://bugs.kde.org/show_bug.cgi?id=420755
Latest Commit: Version Fixed In:

Description Alexander Ewering 2020-06-08 13:23:12 UTC
While others might think differently, I find "smooth scrolling" (when using PageUp/PageDown) quite annoying and it slows me down -- it would be nice to have an option to disable this. What compounds this is that PageUp/PageDown are not recognized "during" smooth scrolling, so it is effectively impossible to quickly scroll through a PDF document using those keys.
Comment 1 Laura David Hurka 2020-06-08 19:58:52 UTC
You’re not alone with your feelings. In 420755 someone already suggested respecting the global style settings; but I start to think that people actually wish this option for Okular, so the option creep argument won’t hold.

I don’t like smooth scrolling too. It’s just smearing and flickering in my eyes, does not help to track the movement in any way. I wonder how many people would complain if we actually revert this.

<blablah>
It’s like when you called someone at +12 333 12345, and then you want to call someone at +12 333 12349, but you have to wait until your phone is done with waking up all the people with numbers in between: +12 333 12346, +12 333 12347.23, 12 333 12347 + π/4, etc, and then someone angry from +12 333 12345 + e - √2 calls you back. (Share your weird comparisons here: https://bugs.kde.org/show_bug.cgi?id=422629)
<blablah>

*** This bug has been marked as a duplicate of bug 422050 ***